Sync Error on Wi-Fi Sync [Resolved: Uncheck 'Block all incoming connections' in OS X Firewall]

alpipegoalpipego
edited July 2015 in Android

When I try to sync my vault via Wi-Fi from my Mac to my OnePlus One I get a:

Sync Error
There was a temporary connection problem during sync. Please check the connection on both devices and try again.

As you can imagine I have tried again... and again... and...
The Mac and the phone are both in the same Wi-Fi, neither of them is having a connection problem.

Android Version 4.5

(Minor Bug Report: The Wifi Server section of the osx app preferences still says: "Run a Wi-Fi server from this Mac to sync with iOS devices")


1Password Version: 1Password 5 Version 5.3.2 (532001) Agile Web Store
Extension Version: Not Provided
OS Version: OS X 10.10.4
Sync Type: Not Provided

Comments

  • periperi

    Team Member

    Hey @alpipego. Thanks for getting in touch with us today. I'm sorry to hear about the trouble you're having with WiFi sync at the moment. Let's see what's going on here. :)

    First off, it may be that something is blocking our discovery service from connecting to Bonjour on your Mac. Do you have the OS X firewall enabled? If so, please open System Preferences > Security & Privacy > Firewall on the Mac, and then click the lock to make changes. Open up the firewall options and make sure that it is not set to "Block all incoming connections."

    1Password on Android uses Network Service Discovery to connect with Apple’s Bonjour service for WiFi sync. Having the firewall set to block all incoming connections will block 1Password on your Android device from being able to communicate with 1Password on Mac.

    Also, do you have any antivirus or firewall software enabled on your Android device?

    Thanks for bringing up the issue with Mac showing "Run a Wi-Fi server from this Mac to sync with iOS device." Our developers are aware of this and have updated the language in the WiFi sync window in our recent beta builds. We're testing the betas at the moment, and hope to have this released in a stable update soon. :)
    ref: OPM-3166

    Let us know what you find out with regards to the firewalls! Thanks!

  • Hey @peri.
    Thank you very much for your assistence. It was indeed the OS X firewall.
    "Block all incoming connections" was checked.

  • periperi

    Team Member

    That's great news, @alpipego. I'm glad to hear that you were able to get WiFi sync working. :)

    Let us know if you have any other questions or problems in the future. Thanks!

This discussion has been closed.