Unable to disable autosave on Okta website

For some peculiar reasons, 1password keeps asking to save my password when I am login on Okta (a popular identity manager). It happens all the time, even if I have already saved my password or if I have disabled autosave for the domain I am on.

Let me know if you'd like the URL to check it yourself.
It is very annoying as the only way to fix it would be to disable autosave entirely :(


1Password Version: 5.3.2
Extension Version: 4.3.1.90
OS Version: OS X 10.10.3
Sync Type: Not Provided

Comments

  • Something that has been annoying me for a while but I just ignored. Whenever I go to login to specific sites that I don't want to get queried about Auto Save. I use the little gear icon in the bottom left corner, choose to not Auto Save for that domain, it adds the domain to the blacklist in prefs. But, it still always asks me if I want to remember a login for the blacklisted site.

    I have tried with both Safari and Chrome.

    Thanks,
    lazz


    1Password Version: 5.3
    Extension Version: 4.3.1.90
    OS Version: OSX 10.10.3
    Sync Type: Not Provided

  • Hi @gbws,

    I created a test account so we won't need you to supply your personalised URL and I've found exactly as you have. In fact I even went as far as adding the exclusion *.com which stops which stops the automatically ask to save new logins everywhere but this site. I cannot explain why we're doing this - it baffles me completely. We've had a couple of reports from others so I've added your comments and my own findings to the ticket in the hope that it helps.

    Unfortunately nobody has found a workaround so far. It seems like disabling Automatically ask to save new Logins is the only answer for the moment :( Hopefully we can get this oddity resolved.

    ref: OPM-3030

  • Thanks littlebobbytables, very strange indeed.

    Something I have noticed was happening with 3D secure iframes / pages too although it that specific case, I could think of some technical limitations to explain the behavior. In this case, no idea why it is happening. Glad to hear your findings correlates mine.

    What would be the best way to know if this problem is resolved?
    Is your ticket publicly accessible? (I presume it isn't).

  • Hi @gbws,

    Our bug report system isn't publicly accessible I'm afraid. Now we do try to document which bugs have been fixed in any given beta/stable release, see our 1Password for Mac changelog and the reference is OPM-3030.

    The other route is to pop back here if you've seen an update been downloaded and ask. It might be we have bad news to report and we haven't fixed it yet but maybe we get to report good news and say we've squashed that one :smile:

  • Hi @lazz,

    I find that generally the exclusion list works but I did identify a particular site earlier today that just doesn't work. If you have examples where it isn't working would you mind supplying URLs please. Anything I can add to help the devs isolate what is going on helps. A spartan bug report that doesn't give good examples could end up having a dev decide nothing is wrong because they test with sites that work (which is the majority based on my limited usage of this feature). Instead, if I can list sites with issues it means they see the problem is real and they can use the examples to narrow down what is going on. Hopefully we can figure out what is happening.

    ref: OPM-3030

  • Hi, we use the SSO service Okta for our SaaS app access management. It is their site that does not work correctly with our company subdomain. i.e. if your their customer you get x.okta.com as the signin page. Even though I have the password saved for this page it just keeps asking if I want to update any of them. I have 3 stored passwords for this site under admin and other accounts. I try to set them to ignore, and it won't accept it.

    Thanks,
    lazz

  • Drew_AGDrew_AG 1Password Alumni

    Hi @lazz,

    Thanks for letting us know the site where you've been having that problem! It turns out that's the same site littlebobbytables referred to, and we have an open bug report for that. I'll add your comments to our internal tracker, and I've merged your thread with another discussion about the same issue, just to keep it all in one place.

    I'm sorry for the inconvenience! I don't have a timeframe for when this issue will be solved, and unfortunately we haven't found a workaround so far, aside from completely disabling the auto-save option for all websites. I'm sorry I don't have a better answer about that right now, but please do let us know if you have more questions or run into any other problems.

  • This issue (okta.com can't disable autosave) is driving me batty. Please fix this!

  • Hi @1TicketTerm,

    I've added your comments and we haven't forgotten this is happening. We still haven't found out why this site behaves so differently yet. I apologise I don't have any progress to report.

  • I am seeing this issue as well.

  • Hi @whargrove,

    Sadly anyone using this site will suffer at the moment. I do believe this is a high priority but I'll gently nudge the devs after I add your comment to the bug report (to help make sure the report isn't forgotten :wink:)

  • Hi @gbws, @lazz, @1TicketTerm & @whargrove,

    We've just released 4.4.3.BETA-2 with a hopeful fix for this. If you're interested this page on Installing beta versions of the browser extension will help you try it out and see if it works as well for you as it did for me just now :smile:

  • @littlebobbytables: The beta works great. Problem solved. :)

  • It feels like we've been playing catchup with the extension a bit recently so it's really nice that I get to share this good news @whargrove :smile: here's to many more Good News Everybody! posts (big Futurama fan here :tongue:)

This discussion has been closed.