Autofill switching between Chrome profiles

Chrome Version 45.0.2454.46 beta (64-bit)
1Password Version 5.3 (530029) Mac App Store
1Password browser extension Version

Also tried with 1Password browser extension Version

I have two Chrome profiles, signed into one window each. Doing the "⌘\" command and choosing the login opens and fills it out on the other profile window. Clicking either the menubar icon or the Chrome extension icon and manually selecting the login fills it out in whatever profile is in the foreground.

Under Advanced in 1password settings, "Verify browser code signature" is checked, everything else is unchecked.

1Password Version: 5.3
Extension Version:
OS Version: OS X 10.10.5
Sync Type: Dropbox


  • Hi @safusu,

    We may need your help with this one as at the moment I'm unable to reproduce the issue.

    I opened up a second profile (so two windows, one for each) and to test I went with Amazon's login page which I loaded in both profiles. So at this point I have a single tab in each profile. All my testing with the keyboard shortcut ⌘\ filled in the front window without interacting with the background one. I'm assuming you find this bad behaviour is quite reproducible and so I'm wondering if you can describe a scenario that I should be able to duplicate and see the same behaviour. We're both running the same version of OS X and 1Password so I'm hoping that I can get it to misbehave too. I started off with the stable version of Chrome and then went on to test the beta version too but both behaved as expected. Hopefully the right steps will show us the issue :smile:

  • That's a bit tough - I just deleted Google Chrome from my Applications and deleted the Chrome folder from ~/Library/Application\ Support/Google to attempt a fresh reinstall, no luck. Reinstalled the extension on both profiles, still no luck. Deleted the app store version of 1password and downloaded v 5.3.2 from the website, still no luck.

    It's difficult to describe a scenario that you should be duplicate the scenario as it's happening in every combination of 1password (mac app store, website downloaded, beta) and browser extension (beta, normal) I can create.

    Would a console dump of and com.agilebits.onepassword4.log help?

  • littlebobbytableslittlebobbytables

    Team Member
    edited August 2015

    Hi @safusu,

    Let's start with the stable versions of everything which would be:

    • 1Password Version 5.3 (530029) Mac App Store
    • Google Chrome Version 44.0.2403.157 (64-bit)
    • 1Password Chrome Extension Version

    As you're willing, wipe the Google support folder once more and reboot your Mac just to be on the safe side.

    Start up Chrome with a single profile, download the extension and ensure that works. I suggest picking a single site for consistency. I'm going to use Twitter for my example. You don't have to but if you could let us know what site you're using it may prove insightful.

    With the sanity check done, create a second Chrome profile and visit to download and install the 1Password Chrome Extension into the second profile. Visit the same site in the second profile and double check that you indeed have two Chrome windows open, one per profile with each having a single tab loaded at the designated site (in my case Twitter) and each with the 1Password Chrome Extension installed.

    Then try filling first in profile 1, checking to see if it fills here and then checking to see if it fills in profile 2. Reset both pages if necessary and repeat in profile 2, checking to see if anything bleeds over into profile 1.

    In my tests I tried filling using the following methods.

    1. The keyboard shortcut ⌘\.
    2. The keyboard shortcut ⌥⌘\ (equivalent to the menu bar icon)
    3. Clicking the Extension button in the toolbar.

    What I found was filling methods 2. and 3. worked as expected with no confusion over profile. I found their was an oddity with filling method 1. that for reasons unknown I didn't observe yesterday. The oddity wasn't to do with filling. It correctly filled the right profile but then proceeded to open the 1Password mini menu and then I eventually remembered this was a known issue waiting for a fix.

    ref: OPM-2185 & ref: OPX-647

    If we still can't get consistent results between us we'll take a look at a diagnostic report and see if that sheds any light on the matter.

  • Hi Bobby, thanks for looking into this. I did a bit more searching and my issues sound commensurate to the ones in the following post:

    Using your example above, I did notice a ~.25 second lag to bring up the mini menu bar when performing the ⌘\ shortcut - performing the ⌥⌘\ shortcut brought up the mini menu bar prompt nearly instantly. It certainly sounds like 1password is searching between windows to open the browser extension on, fails, then opens the mini menu bar icon in that ~.25 seconds.

    Since it sounds like a known issue and that you guys are still looking into it so I'll stash the pitchforks and torches for now :)

  • safususafusu
    edited August 2015

    One additional note:

    When repeatedly pressing ⌘\ on a page with a text input field (even if it's's search bar), I get mixed results if I do the shortcut quickly or slowly.

    For example, if I press ⌘\ back-to-back-to-back, the 1password password box switches from being drawn in the browser to being drawn from the menu bar.

    If I press ⌘\ about once per second, the password box is drawn only from inside the browser.

    If there is no text input field and I press ⌘\, no matter how slowly or quickly I perform the shortcut, it always opens in the menu bar.

  • Hi @safusu,

    Just to clarify though, the bug we have reported does fill the correct profile but centres around the fact that multiple 1Password Chrome Extensions results an unnecessary 1Password mini menu bar appearing. If you're still experiencing the wrong profile being filled we do want to try figure this out as the fix for the other issue would seem unlikely to fix this.

  • I've submitted a diagnostic report to [email protected] and included this post's url in the body.

  • littlebobbytableslittlebobbytables

    Team Member
    edited August 2015

    Hi @safusu,

    Thanks, somebody will be in contact shortly :smile:


This discussion has been closed.