1Password not filling logins in Chrome "popup"-style windows.

The latest version of the 1Password Chrome extension ( no longer fills in logins if the window is "popup" style (with no address bar and tabs).

The problem is not with the hotkey. If I have a login page in a popup window and hit Cmd-\, it will pop up the 1Password Mini window, let me enter my password, and show me a list of my logins for that site. But when I select the one I want, it simply doesn't fill in the login fields. Basically, it works exactly as it would in a normal window--except for the very last step when the filling-in should happen.

The easiest way to see the bug in action is to use an extension like this one:


That extension will convert any tab into its own popup window. Navigate to any login page, try filling it when it's a normal tab, then convert the tab to a popup window and try it again to see the bug.

But just to be clear, it's nothing to do with that extension. I've seen this behavior in other popup windows when that extension is not installed. It seems to be purely an issue with popup windows in Chrome.

I still had an old version ( in Chrome on a different computer and can confirm that version worked perfectly with popup windows, so it appears something has changed between that version and the current one.

I'm using:
Chrome 43.0.2357.134 (64-bit)
1Password 5.3.2 (532001)
1Password extension for Chrome
OSX 10.10.4
MacBook Air 13" mid-2012

Thanks! Please let me know if you need any further detail on this.

1Password Version: 5.3.2 (532001)
Extension Version:
OS Version: OS X 10.10.4
Sync Type: Not Provided


  • pattepatte Junior Member

    Mh. I've setup many pop-up style windows for my favorites sites. This would explain why 1Password doesn't work anymore for them.

    It would also be tremendously useful for those sites which let you log-in via a pop-up.

    Google Chrome: 43.0.2357.134 (64-bit)
    1Password Extension:
    1Password 5.3.2 (532001)
    OS Version: OS X 10.10.4
    Mac Pro (Early 2008)

  • MeganMegan

    Team Member

    Hi @mayostard and @patte,

    Could you provide a few web addresses that you're seeing this problem with? I'd love to do some testing here.

  • Hi Megan,

    So far I've seen the problem with every address I've tried--it doesn't seem to have anything to do with which site it is, only if the site is being visited in a popup-style window in Chrome. But I've recently confirmed the problem with:

    https://www.dropbox.com/ (then click the "Sign in" link at the upper right)

    Hope that helps. Thanks!

  • brentybrenty

    Team Member

    @mayostard: I think there may be a misunderstanding. I use these sites frequently, but I double-checked anyway just to be sure. However, none of them use popups for their login forms.

    If you are seeing popups, I don't know if this is another extension you have installed or malware of some kind that is causing this, but it's certainly worth looking into since this means that something is interfering with the login process.

    If I've misconstrued something, I apologize, and I hope you'll clarify for me. Perhaps a screenshot would help in that case? Thanks in advance! :)

  • @brenty, you're correct, those sites don't open their own popups by default. I think maybe I wasn't clear enough in my original posting. In Chrome, any URL can be opened in a popup window--'popup' is just one of the window types supported in Chrome. It's a window with no decoration, no address bar, and which only displays a single tab. Many extensions and apps use popup windows to make the browsing experience less cluttered or for other reasons.

    The problem is that in the latest version of the 1Password extension, you can no longer fill in a login form if it happens to be in a popup window. It seems pretty clearly not an intended feature, since you can still use the cmd-\ hotkey, open the 1Password Mini window, and select your login. It just won't fill in. And in the previous version, it did.

    In my original post, I provided a link to one extension in the Chrome web store that allows you to turn any tab into a popup-style window. I provided that so you could see the problem with any login you choose. Just navigate a tab to any site you want, then convert it to a popup and you'll see the problem.

    But the problem doesn't have anything to do with that particular extension (or any other). If you want to see the problem without using any extension (other than 1Password), go into developer mode, open the background page of the 1Password extension, and try this command:

    chrome.windows.create({url: 'https://discussions.agilebits.com/entry/signin?Target=', type: 'popup'});

    All this does is create a popup-style window (the URL you provide could be any site you want). You'll see that the 1Password extension functions exactly as intended--except that it will not actually fill in the login form.

    I hope that helps clarify? I can do a screenshot walkthrough if that'd be useful.

  • brentybrenty

    Team Member

    @mayostard: Ohhh, got it. Thanks for clarifying! So you're using an extension to open up these popup windows? I (and I think Megan too) was under the impression that the extension was a separate issue from the filling. Sorry for misunderstanding!

    We don't design 1Password to work around other extensions, as those are not a known quantity, and there is no shortage of new ones. However, we can and must work around Chrome and extension framework issues and changes because, well...that's just par for the course when it comes to browser integration. It's Google's playground, after all!

    That said, we can certainly see if there's a simple tweak we can make to help in this case, but it isn't something I can promise; and we certainly can't guarantee that extensions X, Y, and Z will peacefully coexist with 1Password ing forward — especially you're using them to modify the way webpages load normally. Thanks for bringing it to our attention. We'll look into this further! :)

  • Hi @brenty,

    I understand of course that you can't make accommodations for every extension, but I'm pretty certain this doesn't have to do with extensions. It's entirely to do with handling of popup windows.

    I've created an example to show you. I set up a simple Wordpress site here:


    I've set up an account on the site for you to test with (or you can register your own user if you prefer):

    user: test
    pass: testpass

    You'll notice on the left under the "Meta" menu there's a "Log in" link. If you click that it takes you to the login page and you'll find that 1Password works perfectly for logging in.

    There's also a "Test" menu where you'll find a "Log in Popup" link. If you click that, it will take you to the same login page, but in a popup window, and you'll find that 1Password will not fill in the login fields.

    In fact, having set up this site, I can now confirm that the same problem exists in Firefox and Safari. If I click the regular login link, 1Password works fine. If I click the popup link, 1Password recognizes the site, but will not fill out the fields.

    I know this used to work in version on Chrome, but I don't know if it worked or not in older versions in Firefox and Safari.

    Not sure if it helps or not, but when I was trying to fill in fields in the popup window, I saw this console message:

    1Password: Failed to locate active tab.

    Thanks again! I hope this helps.

  • khadkhad Social Choreographer

    Team Member
    edited July 2015

    Thanks for writing back, @mayostard. (Love the username, by the way. I recently finished re-watching Mr. Show from beginning to end.) :)

    I wasn't able to reproduce any trouble on that test site at first. But that's because my default browser is Safari. When the popup window appears with the login form, I simply use the ⌘\ keyboard shortcut to log in. It is working well for me in Safari every time.

    But I see exactly what you mean in Chrome and Firefox. I'm not sure why this is. I'll have the developers dig deeper so we can get this fixed in an update. I think that console message you included is indeed related to this.

    Thanks for (your persistence in) reporting the issue!
    ref: OPX-1029

  • Thanks, @khad! Glad the problem is clear. Yeah, I just tried it again in Safari and this time it worked fine for me. Not sure why I thought it wasn't working this morning.

    Long live Mr. Show! Off topic, but have you heard about "With Bob & David"? New sketch series they're doing for Netflix. I have high hopes.


  • khadkhad Social Choreographer

    Team Member


    Excellent! I mean, it's not excellent that the problem exists, but I'm glad we are both experiencing it consistently. That should make it easier to resolve.

    I'm excited to see "With Bob & David". Right now my wife and I are working our way through "The Increasingly Poor Decisions of Todd Margaret". :)

  • I just ran into this issue as well and took a quick peek inside the Chrome extension.

    @khad, you might have already found this culprit since it's a small one, but I thought I'd share just in case. The Chrome-specific code to get the browser's active tab runs this query:

        chrome.tabs.query({currentWindow: false, windowType: 'normal', active: false},

    Just removing the windowType param from the query should work and return the expected popup window tab (provided that window filter isn't intentionally there for security or otherwise).

    p.s. I'm more of a mustardayonnaise fan myself ;)

  • brentybrenty

    Team Member
    edited July 2015

    Thanks! :):+1:

    P.S: I'm afraid the condiment debate goes right over my head, but it's amusing nonetheless. :lol:

  • khadkhad Social Choreographer

    Team Member

    p.s. I'm more of a mustardayonnaise fan myself ;)


    @brenty: We gotta watch Mr. Show together sometime apparently. :)

  • khadkhad Social Choreographer

    Team Member

    @yellinben, @mayostard, @patte,

    We ran out of mustmayostardayonnaise, so we were able to stop making sandwiches long enough to get this fixed. :)

    It is in the latest beta version of the extension that we just released a moment ago. From the 1Password extension release notes:

    No longer limiting login filling to normal windows in Chrome.

    If you don't want to wait for it to hit the next stable build, you can switch to the beta channel:

    Installing beta versions of the browser extension

    Please let me know how it goes for you. It should be resolved, but it is always great to have additional confirmation.

    Now, if you'll excuse me, I have to run to the store to pick up some more mustmayostardayonnaise and get back to those sandwiches…

  • pattepatte Junior Member
    edited July 2015

    That's great news @khad. Thanks!

  • khadkhad Social Choreographer

    Team Member

    Happy to help! If you do end up having any trouble, please let me know the URL of the site where you are still seeing the issue when using the latest beta version of the 1Password extension.

  • Thanks, @khad! Just installed the beta and it seems to be working perfectly for me. I'll post again if I see any problems, but it seems great. Thank you so much! I'm sure it was really all the time you saved not having to separately put mustard and mayonnaise on your sandwiches that allowed this to happen.

    Just remember, mayonnaise will expire before mustard.

  • khadkhad Social Choreographer

    Team Member
    edited July 2015

    That's wonderful news, @mayostard! And I shall always heed the warning. But I do have to wonder what happens if you stir it all up. Does the expiration sort of average out?

    I'll have to experiment. :)

  • brentybrenty

    Team Member


  • When will the stable version be releases with this fix?

  • Hello @manu_j,

    This will likely depend on Firefox. We're currently working on modifying our workflows as Firefox will soon require extensions to be signed after a review process. As the extension is simultaneously released for Safari, Firefox and Chrome we need to make sure everything is in place with the Firefox extension before we can proceed. Hopefully not long now :smile:

  • Ah. Firefox. But current stable 1password extension is working on the latest Firefox 40. So an update should work on FF 40 and then you can work on the FF signing mechanism in peace ? :)

  • Hi @manu_j,

    I understand your desire but the next stable release has to be signed, I fear anything less will have people beating down our doors to ask why. It's one of the more active queries that we see as it affects all Firefox users. It shouldn't be too much longer to wait because Firefox's next release will require some console-fu for unsigned extensions and that's something we need to avoid.

  • I fear anything less will have people beating down our doors to ask why

    Ha ha. OK. Will wait :)

This discussion has been closed.