Thank you, Chrome dev-channel works again with 1Password extension 4.4.4.1 beta

Just an FYI

The 4.4.4.1 beta extension 25-08-2015 released has fixed Chrome/1Password.

I'm currently using OSX Chrome Version 46.0.2490.4 dev (64-bit).

If anyone doesn't know about the beta extension releases, they are here, click "Show betas":

https://app-updates.agilebits.com/product_history/OPX4

Chrome specifically:

https://d13itkw33a7sus.cloudfront.net/dist/1P/ext/1Password-4.4.4.1.crx

Thank you, I was waiting for this. :-)


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Hello @rmichael,

    Actually all the thanks goes to Google for the fix if it's the issue I'm thinking of. For a while WebSocket communication was broken (I don't know the specifics) in certain branches of Chrome, the result being the extension was blocked from communication with 1Password. I believe the fix made it into the dev branch very recently and it resolved the issue completely. Does that relate to the issue you were facing?

  • @littlebobbytables Yes, that's right. I'd heard from Agile support that the websocket-related Chrome ticket was private, so I couldn't follow it. I just assumed something (interface, API, etc.) would change in Chrome and require a consequent change in the 1Password Extension. Though, if there's really no change required to the 1Password Extension code, then I suppose the earlier (non-beta) extension would have simply started working again.

    Regardless, I am happy Chrome is working again. :-)

  • Hello @rmichael,

    I don't know if the bug had time to trickle down to the beta or not but if it did I'm sure we'll see scores of happy people once the fix arrives there too :smile: I'm glad it's working again for all of you Chrome users.

This discussion has been closed.