1Password doesn't work until I relaunch Google Chrome

This is very annoying. Often I try to use 1Password to fill in a username/password, and I get an error. I then have to go to settings->About and relaunch the newest version of Chrome (that has been automatically installed). What gives? Can I fix this tiresome problem? Do I have to turn off automatic updates in Chrome? Please advise.

Thanks


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Hello @ajahn,

    I know this is a thing but I don't know the precise cause. It's either the pending update causes an issue with the browser signature (which we check) or it's Chrome causing this as part of the upgrade process. While technically disabling automatic updates would work I'm not sure how possible it is. Google seem to be enacting a lot of measures e.g. force updating, adopting the stance that it's for the user's own good. It might be that turning of Verify browser code signature in the Advanced tab of 1Password's preferences helps but I can't easily test as Chrome is up to date on my system at the moment.

    May I ask, what branch of Chrome are you running that you're getting a lot of updates. If you're running the stable branch it isn't that often is it?

  • ajahnajahn
    edited August 2015

    This happens a few times a month. For me it's no problem because I recognize the error and go to my settings and relaunch after the update. But my wife on the other hand, ends up hand copying username and password each time. I happened to notice her doing that and I asked her why. She told me 1Password doesn't work anymore so I have to do it this way... (sigh). I have shown her how to fix it but she forgets. Just wondering if there was an easy work-around. Whenever I get an update, this happens until I re-launch Chrome. I wonder if there is a way to tell Chrome to auto-launch, but I assume that may cause issues and you may lose a tab or two. I just wish this didn't affect 1Password. Oh, and I'm using the latest versions of Chrome on OS X Mavericks and Yosemite.

  • brentybrenty

    Team Member

    @ajahn: I'm not sure that there is much we can do to mitigate this inconvenience, but we'll continue to look into it. It may be that websockets are shut down when an update is pending.

    Personally, I try to keep my browsers closed when I'm not using them because they tend to eat up more and more resources over time...but I know plenty of my colleagues here have similar habits to you, leaving it open all the time, so if there's a solution I suspect we'll find it. ;)

This discussion has been closed.