Update using old data

RicollectRicollect
edited September 2015 in Mac

Hi Agile, i'm so intensely frustrated at present, as i've spent the last 3 hours trying to work this out but haven't been able to. So i'm keen to get your help, and am sure you'll quickly set me on the right path.

I recently upgraded from 1Password 3 to 1Password 5. I wasn't really able to before as i had an older machine running Snow Leopard.

The trouble is, when i upgraded, the new version took up an old version of all my 1Password data. So now i find that when i look at certain entries, they're out of date by a year or more.

I upgraded quickly without looking at instructions, so didn't delete 1Password 3 until after the upgrade. You have a neat article on Making use of an .agilekeychain_zip backup from 1Password 3 for Mac, and although it may be obvious to you, you don't actually say how to make use of this backup.

I followed your instructions, and put the resulting file in Dropbox, since that's what i sync with, moving the agilekeychain i was using, but it didn't make a difference. In other words, i wasn't really sure how to make use of the file.

In any case, all i want to do is restore 1Password to the state it was in before the upgrade ie where 1Password entries - or at least those that count - were up to date. Help! ; )


1Password Version: 5.3.2
Extension Version: 4.4.3
OS Version: 10.10.5
Sync Type: Dropbox

Comments

  • Drew_AGDrew_AG 1Password Alumni

    Hi @Ricollect,

    I'm really sorry this has been so frustrating, it is normally a much easier process! We try to have 1Password do as much of the work as possible, so it tries to find your existing data. The downside to that is it can end up finding older data in certain circumstances. But don't worry, we'll be glad to help you get this all straightened out!

    I see you bought the 1Password 5 for Mac upgrade yesterday - thank you so much for your purchase! :) Thanks also for the feedback about the knowledgebase article on using a .agilekeychain_zip backup from 1Password 3. You're right, it's rather vague on how to use that file once you've created it. I'll let our documentation team know about that, I'm sure they'll be happy to make improvements there. That file can be used in a few different ways, and I'll explain how as part of my troubleshooting steps.

    If your vault in 1Password 5 currently has the old data, you can follow the steps in this knowledgebase article to reset 1Password 5: How do I start over with an empty vault?

    After following those steps, opening the 1Password 5 app should be like the very first time, as described in our User Guide. At that point, if you created a .agilekeychain file from one of your 1Password 3 backups, and if that .agilekeychain file is somewhere in your Dropbox folder, you'll want to choose that you've used 1Password before, and then choose that your data is in Dropbox. That will let you select the .agilekeychain file you moved to your Dropbox folder.

    For more specific steps on choosing your data in Dropbox during the setup, see our user guide here: Sync existing Dropbox data

    Does that help solve the problem? If you have questions about that or something doesn't happen as described, just let us know - we're here for you! :)

  • RicollectRicollect
    edited September 2015

    Hi Drew. Something is very wrong, and i want to get your comments before i waste any more time.

    I followed the instructions in How do i start over with an empty vault? I then used the last 1Password 3 agilekeychain file i had, dated 8 Sep 2015. That basically returned the same old data (minus the very latest logins i'd saved).

    Thinking that the latest file might have got corrupted in the upgrade, since the data i started with in 1Password 5 was out of date, i decided to follow How do i start over again. This time i used the previous 1Password 3 agilekeychain file i had, dated 4 Sep 2015. However that again returned much older data (as well as missing the very latest entries that i'd made since my purchase).

    So now i'm concerned all - or at least some - of my old 1Password 3 backup files have been corrupted, and i may be searching fruitlessly for one that gets close to an up to date version.

    Do you recommend i keep trying to go backwards to find a 1Password 3 backup file closest to what i last had, or is there another way around this?

  • Following from my previous post, it seems unlikely that any files are corrupt, since the dates in the filenames are the same as the modified dates of the files. Yet the data is old. It's as though 1Password isn't 'taking' the old backup files. I have no idea what it might be using in their place, but the data is definitely old ??????

  • Drew_AGDrew_AG 1Password Alumni

    Hi @Ricollect,

    I'm sorry you're still having trouble with that! I don't believe the .agilekeychain files are corrupt, or they would probably not work at all. If you're able to sync your data from those keychains to your vault in 1Password 5, it sounds like they are working, and that they simply contain the older data you're seeing.

    If you have one or more of your .agilekeychain files in Dropbox, you can actually check the data they contain by using the 1PasswordAnywhere feature. That allows you to view your data in the .agilekeychain from a web browser, by signing into your account on the dropbox.com website. That might help you confirm which data is in each .agilekeychain file without needing to reset & setup the main 1Password app every time. It's simple, and we have instructions here: 1PasswordAnywhere

    Now, if your .agilekeychain files only seem to contain an older set of data, where exactly do you have your latest 1Password 3 data? Do you still have it on your older Mac? Or did you install 1Password 3 on your new Mac and migrate your data there first before you installed 1Password 5? You should still be able to open 1Password 3 on whichever Mac has it installed, and it will help if you can confirm whether or not you still see the newer data in there. Please let us know, thanks!

  • Hi Drew, i'm still having problems. I wasn't able to find the right file on DropBox, because we know the current agilekeychain file is wrong and when i look through deleted files, there are so many, and there doesn't seem to be a search for deleted files.

    Even so, i wasn't aware of the 1PasswordAnywhere feature, which is very neat, so thanks for pointing that out.

    I decided to download 1Password 3 again, and try going through my backup files to see which might at least be more current than the one i end up getting in 1Password 5 (which is way out of date). I tried the latest backup dated 8 September, but that just gave me the same as i have in 1Password 5. So then i went back to the file from 3 September. This worked! At least the entries should be up to date to 3 September 2015, which means i'd be missing a few after that.

    Still, i was prepared to accept that, since a file from 3 September is a lot better than one that's months old.

    So then i followed your instructions on using an agilekeychain_zip backup from 1Password 3 again, as well as How do i start over with an empty vault? I placed the resulting agilekeychain file into DropBox and opened 1Password 5 again. It asked me to choose which vault to use, i chose the agilekeychain file from 3 September, then looked through 1Password 5.

    I cannot work this out - i was back to the same months old data, rather than any from 3 September. I'd previously deleted the old agilekeychain file, but somehow 1Password 5 is getting data that's months old. Can you shed any light on this?

    There appears to be some conflict between 1Password 3 and 5. I left 1Password 3 open while i opened the 'new' agilekeychain for 1Password 5. Now both programs are open, but i'm unable to look at 1Password 3 again. That is, when i click on the icon for it, it won't come up.

  • A few additional notes. I subsequently found out that if i use the 1Password 3 backup file from 4 September, that also works in 1Password 3. That's a day later than the 3 Sep file, so i'm going to try to work with that from now on.

    When i again put the 4 Sep agilekeychain file on my mac or DropBox, and ask 1Password 5 to restore data from that, not only does it restore months old data, it changes the modified date on the backup file to whatever the time is when 1Password 5 starts to use it.

    I'm totally mystified as to what to do. I've tried several more times to use the backup file from 4 Sep which works successfully in 1Password 3, but then reverts to months ago when i try to use the same file in 1Password 5. What's going on?

  • I've also just verified that when i put the 4 September agilekeychain file into Dropbox and view it with 1PasswordAnywhere, it has the up to date data. So the reversion is happening when 1Password 5 gets hold of it.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @Ricollect,

    Thanks for all the details, I think we're getting very close to solving this!

    If I understand, right now you can open 1Password 3 on your new Mac and see your newer/up to date info. Is that correct? If so, please follow these steps:

    • Open 1Password 5, then hold the Control key on your keyboard and go to the menu for 1Password > Quit 1Password and 1Password mini.
    • Open 1Password 3 on your Mac and confirm you see your up to data information.
    • Go to the menu for 1Password > Preferences, then click the General tab.
    • Right-click somewhere in the Data File path and choose Show In Finder (in the window that opens, that .agilekeychain file should be highlighted).
    • Copy (via ⌘C or Edit > Copy) the highlighted .agilekeychain file to the Desktop.
    • Quit the 1Password 3 app.

    Next, use the Folder sync option in 1Password 5 to sync the contents of the keychain file on your Desktop:

    • Open 1Password 5, go to the menu for 1Password > Preferences, and select the Sync tab.
    • You should only have one vault ("Primary") but in case you've set up multiple vaults, select Primary on the left.
    • Change the “Sync Primary vault with” pop-up menu from Dropbox to Folder.
    • Click the Disable Sync button (do not delete the data from Dropbox).
    • Click the Choose button and select the .agilekeychain file from the Desktop (then click Open).
    • Click Merge with Existing to start syncing (enter your master password if prompted).

    At this point, the newer data from that keychain should merge with the rest of your data in 1Password 5. Did that work? If so, you can go back to the Sync preferences in 1Password 5 and switch from Folder sync back to Dropbox sync (you can choose to delete the data from the Desktop folder if you want to). When you re-enable Dropbox sync and choose the keychain in Dropbox, you'll likely be asked to merge data again, but that shouldn't be a problem.

    Please let us know how it all goes, thanks! :)

  • RicollectRicollect
    edited September 2015

    Hi Drew, yes, you understand correctly: right now i can open 1Password 3 on my new mac and see the newer info (from 4 Sep 2015, according to the date on my agilekeychain backup file).

    Thanks for the detailed instructions, but unfortunately this didn't work. Everything went as expected, and i completed the Merge, only to find that no data had changed in 1Password 5. When i copied the agilekeychain from the desktop to Dropbox and checked it using 1PasswordAnywhere, the data on it had been changed to the old data.

  • RicollectRicollect
    edited September 2015

    I also tried starting with a new vault again, using another 'fresh' copy of the agilekeychain backup file from 4 Sep. I'd previously disabled sync completely - ie no Dropbox syncing or syncing to a folder - and told 1Password 5 to use data from my mac, then i selected this file. Old data again.

    I'm not saying this is the case, but it's as if the keychain file contains both old and new data, and when 1Password 5 uses it, it picks the old data ahead of the new data.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @Ricollect,

    To be honest, I'm rather perplexed - the behavior you're describing doesn't make sense to me. I'm not sure why that's happening, but there is another way to get your data from 1Password 3 into 1Password 5 that you can try, which is to export the data from 3 and import it into 5:

    • Open 1Password 3 on your Mac (make sure you can still see your newer info there).
    • Go to File > Export All > 1Password Interchange File....
    • In the window that opens, choose the Desktop, then click the Export button.

    Once it finishes processing, it should open the folder it created on the Desktop, which will have a name similar to "1Password 2015-09-10 121420 (XX items).1pif" (the data, time, and number of items will be different for you, of course). There will be a file in that folder named data.1pif which has the data you exported - it's not encrypted, and although it's not easy to read, you can actually open that file in a text editor (such as TextEdit) and make sure it contains your newer info. Once you open that file in TextEdit, press ⌘F (or go to Edit > Find > Find...), then search for some text from one of the newer items you have in 1Password 3. Once you confirm the .1pif file has the newer info, you can close that file (or quit TextEdit) and follow these steps to import that into 1Password 5:

    • Quit 1Password 3, if it's still open.
    • Open 1Password 5, unlock with your master password (if prompted), then go to File > Import...
    • In the window that opens, make sure 1Password Interchange Format (.1pif) is selected as the File Format (near the bottom).
    • Choose the .1pif folder you created from the Desktop (if you can't click the Open button after choosing the .1pif folder, hit Return or Enter on your keyboard).

    Once you import that into 1Password 5, the newer items should definitely be in your vault. Try checking for those. If you can't find them, remember you can still open the data.1pif file in TextEdit to confirm that newer data still exists in that file.

    Hopefully this works - let us know! :)

  • RicollectRicollect
    edited September 2015

    Hi Drew, the information i provided you doesn't make sense to me, either. It hasn't made sense for a while.

    No big surprise, then, that i had a problem with the process you describe. I exported the interchange file fine, and confirmed that it contained the new data. I quit 1Password 3 then opened 1Password 5. This is when the problems started.

    I unlocked the program with my master password, then went to File > Import. Fine. I ensured that 1Password Interchange Format (.1pif) was selected and chose the .1pif folder i put on my Desktop. 1Password started importing, then the screen showing import progress suddenly disappeared.

    I don't know what happened. But in the process of repeating this a few times, i caught a message that seemed to fly by in the background and hide. I'm sorry i can't repeat this message verbatim, i'm just going on memory - i'm not going to repeat the process until i see it again. It says something to the effect that there are problems as my Preferences need to be set up.

    The last time i used 1Password 5 i set it to stop Syncing. So i thought maybe i have to give it a location to Sync. I set up a blank folder on my desktop and set 1Password to sync to that. I guess that wasn't the issue, because when i repeated the import (a few times), the import progress bar again disappeared after a short time. I presume no import took place, or was only partial, since 1Password 5 still contains old data.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @Ricollect,

    The Import process usually happens very quickly, so normally I'd say it's ok if the progress bar just seems to disappear. But it sounds like an error message about that is briefly appearing, so something is definitely wrong. I'm so sorry this isn't working the way it's supposed to!

    At this point, to help us figure out what's wrong and how to fix it, I'd like to ask you to create a Diagnostics Report from your Mac: https://support.1password.com/diagnostics/mac.html

    Attach the Diagnostics Report to an email message addressed to [email protected].

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum username so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report and make sure you receive a reply as quickly as possible. Once we see the report we should be able to better assist you. Thanks in advance! :)

  • The Support ID provided by BitBot was [#WXY-14895-947].

  • Vee_AGVee_AG 1Password Alumni

    Hi @Ricollect,

    Thanks for the cross-reference! We appreciate it. I'll go ahead and close this thread for now to avoid getting wires crossed, and our support team will continue to assist you via email to work this out! :+1:

This discussion has been closed.