Safari extension no longer working

Just today I noticed the the 1Password icon in Safari was just a gray box. I can't remember when I used it last in Safari, so I'm not sure if it just disappeared today or I just noticed it now. To get it back, I searched for it in Safari extensions. It had a choice to install it so I installed it. After installing it reappeared, but clicking on it gives the error message shown in the attached image. I completely exited out of Safari and restarted, but I still get the same message. I can open the desktop application fine and the extension works fine in Chrome. My purchase was from agilebits.com rather than the app store.


1Password Version: 3.8.22 build 32010
Extension Version: 4.2.2
OS Version: OS X 10.10.5
Sync Type: Dropbox

Comments

  • brentybrenty

    Team Member

    @writemom: Aha, thanks for the screenshot! That explains it. Sorry or the confusion! It appears that you're trying to use the 1Password 4 extension with 1Password 3, which...well 1Password 3 just doesn't know anything about those that came after its time.

    Now, you can install the 1Password 3 Safari extension (1Password menu > Install Browser Extension), but since you're running Yosemite, you may want to consider upgrading to 1Password 5. It is a paid upgrade, but you can use your 1Password 3 license key to get a discount from the AgileBits Store. We've made substantial improvements to the new extension and added a lot of new features to the app itself as well in the years since 1Password 3 was released.

    I hope this helps. Be sure to let me know if you have any other questions! :)

  • I followed your directions. I double click the install file for the Safari extension and I get a popup message that asks me if I'm sure I want to install the extension "1Password". I choose "Install". I get a second popup that says, "Safari can't install this extension" and "An error occurred while installing the extension '1Password'". Any idea what's wrong?

  • Hi @writemom,

    Can I ask, do you have any other extensions installed, indeed if you try to install a completely different extension, say Ghostery (that's a link to Safari's extension gallery btw) does that extension correctly install? Now the one extension I've used as an example is one I trust, it's available from an Apple curated page and you don't have to keep the extension, you can uninstall it straight away if you wish, all we're interested in is does it install?

    We have had instances in the past where the extension preferences in Safari can get mangled and require resetting. This is my thought at the moment but the above should hopefully confirm one way or another if this is worth trying.

  • I installed your suggested extension and that installed fine. Afterwards it occurred to me that I might need to uninstall the 1Password extension before I tried to install the new one. After I did that, it came back and functions fine. I had had the box checked to have Safari update extensions automatically so I've also changed that until I'm able to upgrade 1Password so that this doesn't happen again. Thanks for your help.

  • Hi @writemom,

    I'm curious, when you say

    I might need to uninstall the 1Password extension before I tried to install the new one

    Do you mean you needed to uninstall the 1Password 4 extension or did you have a non-functional copy of the 1Password 3 Safari Extension that you needed to remove first? The latter would make sense, Safari probably doesn't allow you to install duplicates but I would be puzzled if you needed to remove the 1Password Safari Extension to install the older one - I'm often re-installing one or the other as part of all the testing we tend to do during the average day.

    Of course you may not be bothered at this point, if you have a working extension again that was the goal after all :smile:

    Just to let you know, the 1Password 4 and 1Password 3 Browser extensions are independent of each other so Safari will never download from the 1Password 4 branch if you have the 1Password 3 version installed. This means you can safely re-enable automatic installation of extension updates in Safari.

  • I had to uninstall the 1Password 4 extension to install the 1Password 3 extension. The other thing worth noting is that this whole thing started with the 1Password 3 stopped working. I guess I installed the 1Password4 extension myself trying to fix it, but something made the 1Password 3 extension not work. it not work.

  • Hi @writemom,

    It might be one of those things where we never learn what caused the initial issue now but I'm still surprised, only yesterday I installed the 1Password 3 extension into Safari to test something and I never remove the 1Password 4 extension prior to doing so. Still, if it worked for you I'm not going to argue as the end goal is all that matters now.

    Just a quick heads up, I personally haven't had the chance to download and try El Capitan which is to be officially released by the end of the month but we've had one user report that 1Password 3 crashes repeatedly for them. I don't know if it's an isolated case or an issue specific to a beta version of OS X. If something has changed which breaks 1Password 3 though it won't be corrected by us as 1Password 3 hasn't been in active development for a while now. Just something to be aware of rather than to receive a nasty surprise..

  • Thanks for the heads up. As long as there is a newer version that is supported, then all is well. 1Password is terrific and if I have to spend a little more to keep using it, I'm fine with that. It's not really even a matter of having to pay to keep using. From what I can tell, the newest version has quite a few improvements so it should be worth buying. If I can hang onto 1Password 3 fine, but if not I'm prepared to go with the upgrade. Thanks again for your time and attention to my problem.

  • Glad we could help :smile: if you have any questions at all please ask.

This discussion has been closed.