Do I need to turn off firewall to sync iphone 5 and imac

iPhone 5, 9.0, imac 10.10, trying to sync via wifi, get to sync but phone does not recognize computer, even after I hit refresh, computer does not appear on phone. Is there a firewall I need to disable?


1Password Version: 5.3
Extension Version: 5.3.2
OS Version: 10.10.5
Sync Type: wifi
Referrer: forum-search:Do I need to turn off firewall to sync iphone 5 and imac

Comments

  • JacobJacob

    Team Member

    Hey @kaykay!

    Firewalls can interfere with WiFi sync. First, have you checked to make sure both devices are on the same WiFi network (and that the WiFi is enabled on the iPhone)? If all looks well there, are you getting any errors when you initiate a WiFi sync session?

    It's worth disabling the OS X firewall to see if it's causing trouble. Here's how to do that:

    1. Launch System Preferences
    2. Select the Security & Privacy pane
    3. Click the Firewall tab
    4. Unlock the pane by clicking the padlock in the bottom left of the window if necessary
    5. Click Turn Off Firewall
    6. Try syncing with WiFi again

    If you have a firewall outside the system one, also try disabling that. Let me know if this helps!

  • brentybrenty

    Team Member

    @kaykay: Definitely worth trying! That said, it shouldn't be necessary to disable the firewall completely on a permanent basis (although it's possible), but at the very least you may need to make an exception for Bonjour traffic and 1Password itself.

    Do you have separate security software you're running? Even if you don't, and the OS X firewall is disabled, try toggling it on and off again. I've seen cases where there was some glitch causing it to behave like it was enabled when it appeared that it wasn't. please let me know what you find! :)

  • Thank you for the help. We were recently traveling and for some reason when we came home my phone joined a different wifi than the one my computer is on. Couldn't believe I would have to disable the firewall just to sync. Again, thank you.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @kaykay,

    ...my phone joined a different wifi than the one my computer is on.

    Ah, that would certainly explain it! I'm glad you figured that out, and hopefully Wi-Fi sync continues to work well for you. If you need anything else, please let us know - we're always glad to help! :)

This discussion has been closed.