Cannot import 1pif file into 1Password (v3.8.22).

Get message "Failed to run import script". 1pif file has software licenses from a Mac bundle. Have seen various posts about needing to run a terminal command first if have v3. Have tried all of those with no luck... FYI, I am running Mavericks on a MacBook Pro. Thanks.

1Password Version: 3.8.22
Extension Version: Not Provided
OS Version: mavericks
Sync Type: Not Provided
Referrer: forum-search:1pif import problem


  • MrCMrC Community Moderator

    Hi @bunker ,

    Can you tell me where this 1PIF file came from?

  • Hi @bunker (and @MrC),

    The issue won't be the 1PIF file in this instance, instead the problem is the library that 1Password 3 used for importing is no longer available in Mavericks and newer.

    @bunker, you have a couple of options and both involve 1Password 4.

    1. You download and install 1Password 4 from our AgileBits Download page.
    2. On launch it should find your existing 1Password 3 Agile Keychain and connect to it.
    3. You import the 1PIF file using the menu option File > Import... and follow the steps.

    Here are where the two options come in.

    1. Right now you're running 1Password 4 in trial mode. You can use your existing 1Password 3 licence file to obtain an upgrade discount on a new 1Password 4/5 licence and continue running 1Password 4 for Mac.
    2. 1Password 4 will synchronise the import back to your 1Password 3 Agile Keychain. You can remove the 1Password 4 application and return to running 1Password 3.

    Other quirks we're aware of running 1Password 3 for Mac on newer systems include, 1Password 3 can no longer sense that Dropbox is running, there is a workaround for this and the 1Password Firefox Extension no longer works as of Firefox 40 - options there are detailed in 1Password 3 extension missing in Firefox 40 or later.

    Hopefully that helps but please do let us know if you have any questions.

  • Thanks for the suggestions. Fyi, the file came from a Bundlehunt bundle

  • Tried the suggestion of downloading v4 and importing file. That worked - got access to the license info from the file when reopened v3 of 1pw. Thanks for the help.

  • brentybrenty

    Team Member

    Ah, excellent! Thanks for the update. On behalf of lil bobby, you are most welcome! I knew that automatic registration feature was good for something! ;)

    It sounds like you should be all set, but be sure to reach out if we can be of further assistance. We're always here to help! :)

This discussion has been closed.