IE9 Firefox & 1Password Problem

I'm also having a problem since running Windows updates on my laptop. I've been running 1Password on my Mac since 2007 with no problems. I'm using Dropbox to keep 1Password synced between the two machines and all was well until I updated Windows. Before the updates I was running IE8 but the updates installed IE9 version 9.0.8112.1624 After the IE9 update, 1Password stopped working with IE9 but Firefox appeared to work. 22 Windows updates were still recommended so I updated all. Now Firefox doesn't work other than very rarely. My problem appears to be a little different than the problem others are having. I unlock 1Password, open the browser, click the 1Password icon, unlock 1Password again as required, click the log-in button in the pop-up window. 1Password fills in the username and password but then it instantly disappears and the page reloads telling me - incorrect username and password. As far as I can tell I'm running the 32 bit version of IE9.
Thanks

Comments


  • Before the updates I was running IE8 but the updates installed IE9 version 9.0.8112.1624 After the IE9 update, 1Password stopped working with IE9


    You need to update 1Password to version 1.0.5.177
  • Doug in AlaskaDoug in Alaska Junior Member

    You need to update 1Password to version 1.0.5.177


    I checked for the latest version on the pc when I started having problems. I am running v1.0.5.177, no updates are available.
    Thanks
  • Doug in AlaskaDoug in Alaska Junior Member
    I'm wondering if this a security setting or something. I'm running Windows 7 64 bit but it had always worked fine before the updates. User name and password fields are being populated but then disappear before being detected by the web-site. Most of the time the user name sticks but no password. Worst case, I am able to open 1Password and find the info for each site but it is kind of a pain.
  • DBrownDBrown 1Password Alumni 1Password Alumni
    edited April 2011
    Doug, please try disabling auto-submit for just that Login item, and see whether that helps. Just edit the item, and set the Submit option to "Never."

    You'll have to click a button on the site's login form to submit it, but it would be helpful to know whether the filled fields stay filled if auto-submit is disabled.
  • Doug in AlaskaDoug in Alaska Junior Member
    In 'preferences' I set 'auto submit is on' to 'never for this site only. I then unlocked 1Password, clicked the 1Password button in the toolbar, the dialog box popped up and I clicked on the button 'log-in with XXXXXX, the user id field then populated. I then clicked in the site's password field and clicked the 'log-in button' and I was logged in. I then get a pop-up box from 1Password asking me if I want to save this log-in for the site. This works the same way for IE9.
    Thanks and I hope this help to get to the bottom of this problem.
    Doug
  • DBrownDBrown 1Password Alumni 1Password Alumni

    ...the user id field then populated. I then clicked in the site's password field and clicked the 'log-in button' and I was logged in...

    Thanks, Doug.

    It sounds like you were able to log in with only the username field (but not the password field) filled in. Is that correct?

    If so, are you able to do the same manually (fill in the username field, leave the password field blank, and click the login button) and successfully log in to the site?
  • Doug in AlaskaDoug in Alaska Junior Member
    edited April 2011
    DBrown wrote:

    Thanks, Doug.

    It sounds like you were able to log in with only the username field (but not the password field) filled in. Is that correct?

    If so, are you able to do the same manually (fill in the username field, leave the password field blank, and click the login button) and successfully log in to the site?


    No, if I manually fill in the user name and click the log-in button, the 1Password dialogue box jumps up, asking me if I want to save the log-in for the site. I close the 1Password dialogue box and manually enter the password, click log-in and I get the 'you have entered and incorrect user name and password' message from the site.

    After doing what you originally suggested, I still had to populate the password field and user name, but it was a two step process.
  • DBrownDBrown 1Password Alumni 1Password Alumni
    edited April 2011
    I'm a bit confused by the part of your process where you fill in just the username and then click on the log-in button. At that point, there's no password specified for 1Password to save, and subsequent login attempts will always fail, because no password is being submitted.

    Here's the intended usage model:
    1. When you first visit a site's login page, you fill in both the username and the password, then submit the login form, and accept 1Password's offer to save a new Login item for you.
    2. When you return to the site's login page, you press Ctrl+\ so 1Password will fill (and optionally submit) the form.

    At this point, I think the best thing might be to start over with a new and complete Login item for the site:
    1. Visit the site's login page.
    2. Enter your username and password, but do not submit the form yet.
    3. Click the 1P button in your browser’s toolbar; then click the Save Login button.
    4. Set the Action field to Create New Login, and specify a name that's different from the existing Login item.
      (Assuming the new Login item works, you can delete the old one at your convenience.)
    5. Click the Save button.

    Please try that, Doug, and let us know how it goes.
  • Doug in AlaskaDoug in Alaska Junior Member
    I would have to do this for every bookmarked site I have a username and password for. I'll try to explain better what happens when I disable the auto-submit for just the one site.

    1. Open and unlock 1Password
    2. Select the site from 'Logins' in 1Password
    3. Click 'Edit'
    4. In the submit drop-down - Change from 'if auto-submit is ON' to 'Never'
    5. Click 'OK'
    6. Open FireFox
    7. Navigate to web-site
    8. Click 1Password button
    9. 1Password box pops up - click 'Log in with this forum' button
    10. Unlock 1Password box pops up asking for master password - type in as required and click 'Unlock'
    11. User name only field is populated on web-site
    12. Now if I click within the password field - the password is entered
    13. Click Login button on the web-site and 1Password box pops up asking if I want to save login for this site but I am now logged into the site

    This only happens when I have disabled the auto-submit and changed to 'Never' as in #4 above. Same exact thing happens in IE9

    Thanks
  • DBrownDBrown 1Password Alumni 1Password Alumni
    edited April 2011
    Doug, please pick a site where you're seeing that behavior, and try the five-step "new Login" procedure exactly as I outlined it above.

    Then go back to the site's login page, and press Ctrl+\.

    Then let us know what happens.

    Thanks!
  • Doug in AlaskaDoug in Alaska Junior Member
    DBrown wrote:

    Doug, please pick a site where you're seeing that behavior, and try the five-step "new Login" procedure exactly as I outlined it above.

    Then go back to the site's login page, and press Ctrl+\.

    Then let us know what happens.

    Thanks!


    I tried to follow the five steps but didn't see the 'Create New Login' option.
    1. Visited the site's login page
    2.Entered my user name and password, did not submit form
    3.Clicked the 1P button in the browser toolbar and a 1P box appeared

    In this box I have four fields-
    1. Log in with xxxxxx forum - no other choices
    2. Go and Fill Login (drop-down box-only other option is 'Unassigned'
    3. Fill last generated password - this box is grayed out
    4. Save Login

    Auto-Save Logins and Auto-Submit Logins boxes are checked.

    Odd thing, I went to two sites I rarely use in order to test before testing with my most accessed sites, 1P worked fine with these sites.

    Thanks
  • DBrownDBrown 1Password Alumni 1Password Alumni
    edited April 2011

    ...
    3.Clicked the 1P button in the browser toolbar and a 1P box appeared

    In this box I have four fields-
    1. Log in with xxxxxx forum - no other choices
    2. Go and Fill Login (drop-down box-only other option is 'Unassigned'
    3. Fill last generated password - this box is grayed out
    4. Save Login

    Doug, if you click on that Save Login button, as mentioned in step 3 of the 5-step procedure I described above, you'll see the Create New Login option I mentioned in step 4 and the Save button I mentioned in step 4.

    2011-04-17_19-18-39.png
  • Doug in AlaskaDoug in Alaska Junior Member
    It works, I assume I'll need to do this with all the web-sites that don't work.

    Thanks for your help,
    Doug
  • DBrownDBrown 1Password Alumni 1Password Alumni
    That's great news, Doug!

    The best way to create a Login that will work is to let 1Password create it for you, so whenever you have a Login item that doesn't work, the first step is to make a new one.
  • Doug in AlaskaDoug in Alaska Junior Member
    Thanks again for your help David. After I create a new login that works and then trash the old one, is it safe to edit and rename to the old login?

    Thanks for the support!
  • DBrownDBrown 1Password Alumni 1Password Alumni
    Glad to help, Doug.

    It's safe to rename a Login item, and you can add attachments, make notes, and so on.

    Be careful about editing them, though: changing the names, values, types, or designations of the fields listed in "edit view" could cause the Login item not to work.

    Of course, if that happens, you can always create a new Login again.
  • Doug in AlaskaDoug in Alaska Junior Member
    Thanks much for your help!
This discussion has been closed.