Enter previous password to install the extension

Hi,
I have the latest version of 1Password running on my iMac (Yosemite), it runs well on my iPhone, and 1Password (3.8.22) also runs well on my old white MacBook (Lion, 10.7.5).
Three problems on the latter, though.

  • Due to unknown problems, Safari often freezes and stops working. (No 1Password issue.)
  • So I make Firefox (42.0) the default browser. I like Firefox , so no problem. But: 1Password claims it cannot install the extension on this version of Firefox.
  • So I decide to install Google Chrome. I install the 1Password extension. But when I try to start the extension, Google Chrome asks for my previous 1Password master password. (I may have tried Chrome in the past for a little while, I am not sure.) But I really have no idea of a previous master password.
  • What am I to do now? I have hundreds of passwords stored in 1Password. Deleting them all and starting all over again is no option.

Thanks for helping me out.

Martin


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Hi @MahjongNews,

    So unfortunately Firefox 42 isn't an option for anybody still running 1Password 3 for Mac. Rather than a large explanation here if it's okay I'll link you to a couple of pages we have, 1Password 3 extension missing in Firefox 40 or later & 1Password 3: Modern browsers and OS X. One talks specifically about Firefox and the 1Password 3 Firefox Extension and the other is a more general comment on the current state of compatibility of 1Password 3 with the latest versions of either browsers or OS X.

    So let's direct our attention towards Chrome. If it is accurate to say that the vault you can see in 1Password 3 for Mac is up to date and in line with what you can see on your Yosemite Mac and iPhone then I would recommend trying the following.

    1. Uninstall the 1Password Chrome Extension.
    2. Quit Chrome.
    3. Possibly overkill but reboot your MacBook.
    4. Launch 1Password 3 for Mac.
    5. Install the 1Password Chrome Extension on your MacBook from https://agilebits.com/extensions/mac/
    6. If you try to unlock the extension and you simply see a number incrementing reboot your Mac once again.

    The 1Password 3 Browser Extension keeps a separate copy of your vault (still encrypted) inside the browser and uninstalling the extension will cause the browser to delete the database. This way when you re-install it should connect with the 1Password Helper process as part of the initialisation process. I don't know if you'll need the second reboot of your Mac but at least in the last few times I've tested 1Password 3, albeit on much newer versions of OS X, I found that the extension could not connect to 1Password Helper until I rebooted the Mac.

    If viewing your vault from the 1Password 3 application's main window doesn't show you the exact vault as you can see from the extension in Safari please let us know. It is possible for the extension to become disconnected from the main application and we'd need to resolve that. Hopefully though this isn't the case and you'll be reported success. Either way though we'd love to know how you get along.

  • Hi - This worked! Thanks a lot, guys. 1Password really is great!

  • brentybrenty

    Team Member

    Excellent! Thanks for the update. On behalf of lil bobby, you are most welcome! I'm glad to hear that all is well. It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance. We're always here to help! :)

This discussion has been closed.