I have 1Password 3.8.22 for Mac, I can't see my passwords, I just see a blinking black vertical bar

I've been using 1Password for years, never had a problem, I've just tried to update one of my passwords, so I went to logins, then to the one I wanted to update, I press "edit" and instead of seeing my current password I saw a blinking black vertical bar, which rotates its location from left to right, and so on. In conclusion, I can't see, nor even change and of my passwords, my only option is the iPhone app, which is working correctly, but I can't use my 1Password Mac App. A video would be the best way to explain this weird issue, but I'm attaching a picture instead.

Comments

  • @bilbo63 as your post relates to 1P3 for Mac I've moved it from the 1P for Mac forum to the 1P:3 for Mac legacy forum where you'll get more help. I think a good place to start is with the AgileBits posts in this thread at the top of the forum.

    Stephen

  • Hi @bilbo63,

    I believe the link Stephen_C posted will likely explain why you're seeing this and what the only real option is. You may very well have questions so please do ask if you do.

  • My first help request was posted when I upgraded my OS X to “El Capitan”, and from that moment the item fields on 1Password become invisible when editing, the text is still present, but I can't see it. I followed your advice and I read this thread: https://discussions.agilebits.com/discussion/48839/1password-3-modern-browsers-and-os-x
    then I realized that the best choice was upgrading to 1Pasword 5 for Mac (I had 1Password 3), so I did it. I bought the upgrade, but when I tried to open it for the first time, I was required to uninstall the old version. Before doing it, I tried to ensure that all the data had migrated from my iPhone to my Mac. Since I can't see the ítem fields, I've made a simple sync test: I erased and old and item from my iPhone, and the I synced with the Mac, but when I opened 1Password 3 on mi Mac, the old item was still there, in other words, 1Password 3 under El Capitan is not only making the items invisible when editing, besides that it doesn't synchronize at all.
    In addition to this, I don't know for what reason about 3 years ago a new vault was created, so I have 2 vaults on the iPhone, the Main Vault has the old information and the new one (named “1Password”) has the updated information. So every time I sync the iPhone I previously must switch from "Main" to "1Password". I always wondered if the main vault could be replaced for the other one, or if I could make 1Password the main vault, but this issue remains a mystery for me and I don't know if it has something to do with the previously described issues.
    I don't know what to do now, I'm terrified of losing all my information, I bought a licence that can’t be used, and I depend entirily on my iPhone, it’s a very risky situation. I have more than 500 items, and no spare time to make a screen shot of each one, let alone re-typing all of them again. Considering the amount of money I've spent on AgileBits over the years and the waste of time, I am very upset! Please could you help me? Thanks

  • Hi @bilbo63,

    So there's a bit to untangle but we will get you there and it won't involve manually recreating a vault.

    So are you following a particular guide that states you need to remove 1Password 3? The reason I ask is technically the two can co-exist so removal of 1Password 3 prior to being content that 1Password 5 is working isn't required. If it's come from one of our guides then we should look at altering that. I don't know if it will reassure at all but as long as you don't use an app cleaner of any kind the removal of the 1Password application (any version) does not remove your vault. It's why if something funky happens to the application at all sometimes what we'll recommend is deleting the broken copy, reboot and replace with a freshly downloaded one.

    When you start 1Password 5 for the first time it will check a number of places to see if it can find existing 1Password data. It sounds like you've been using Dropbox sync to keep 1Password 3 and 1Password for iOS in sync (we'll handle 1Password for iOS after the Mac). If there is a single Agile Keychain in Dropbox 1Password 5 will find it and it should simply ask you for the password for this vault. All going well you should find the exact same vault that was in 1Password 3 is now in 1Password 5.

    The one aspect I'm not entirely sure of is first you say

    it doesn't synchronize at all

    in relation to 1Password 3 for Mac but later you suggest a secondary vault on your iPhone is up to date. If it is up to date then I believe 1Password 3 is still syncing but at the moment only you can say for sure.

    I think a good place to start is to try launching 1Password 5 and see what it finds. If it turns out to be a bit messier than that we'll show you how to submit a diagnostic report and that will let us see a 1Password specific breakdown and from there we should be able to say steps x, y & z will get you sorted.

    So try launching 1Password 5 and if it's a simple scenario the first scary step is over with and then we can work with you to get your iPhone shrunk down to one vault :smile:

  • OK thanks, your quick reply is a good start.
    I opened 1Password 5. This time the "Uninstall Old Version" message was gone. I could see the data, but not updated, so it seems that it is not synchronizing.

  • Maybe I was not clear enough, this time I was not required to uninstall the old version, but I tried to synchronize with the iPhone and it didn't work. So I can't use the new license, and I'm still having two vaults

  • Hi @bilbo63,

    Let's check a hunch of mine. I am assuming you're running 1Password 6.1.1 for iOS, the latest version available.

    1. Launch 1Password for iOS and enter Settings > Vaults.
    2. On this screen tap on your secondary vault, the real vault.
    3. Tap on the top line that should say Sync Service on the left.
    4. Just below where it says Dropbox you should see a path that looks something like /1Password/1Password.agilekeychain.
    5. Make a note of that path.
    6. Launch 1Password for Mac and enter 1Password's preferences.
    7. Switch to the Sync tab.
    8. Is your primary vault syncing to Dropbox?
    9. If it is, there will be a be a path under the menu option that says Dropbox and it too will be a path. It will look slightly different e.g. LittleBobbyTables ► Dropbox ► 1Password ► 1Password.agilekeychain.

    I suspect the two paths will be different and that 1Password found old data, possibly whatever the primary vault is. If I'm correct the following will work.

    1. Follow our How do I start over with an empty vault? guide on your Mac.
    2. Find the Agile Keychain that 1Password for Mac found (the one you don't want) and move it out of Dropbox, say onto your Desktop where we don't search by default.
    3. Launch 1Password for Mac again. This time I believe it will find the '1Password' Agile Keychain that represents your real vault.

    This has still just covered your Mac so far. Don't worry, I haven't forgotten about your iOS device but of course we're still working on making sure 1Password 5 for Mac is happy and that you can feel confident about 1Password for Mac there before we think about touching 1Password for iOS.

  • Nothing works my friend, I'm wasting precious hours, during my work time and at home too, and I'm still stuck and unable to use 1Password. I've tried to uninstall 1Password 3, but syncronizing test (using 1Password extension on Safari), failed. and honestly, I am unable to complete all the steps required to send a "Diagnosis Report", which seems so long, and so complicated, that it should be filled by a Silicon Valley genius. I'm just a ordinary guy, not a technician, and a very disappointed user. I trusted on 1Passord, because it seemed to be the best password app, although expensive, but it became more and more complex and complicated over the years. Now I'm finding myself unable to use the Main app on my Mac and scared to dead to lose all my data on my iPhone 6, because I can't synchronize, and in addition I have 2 vaults, This is a real nightmare, I thing the only way to solve this is through a chat help service, there are too many things that are not working. I paid another new license for nothing, I just have more problems in return of my loyalty. I am going to summarize: 1) I upgraded my OS X to “El Capitan”, and from that moment the item fields on 1Password become invisible when editing. This was solved by upgrading to 1Password 5. 2) But I could not eliminate 1Password 3, and I can't synchronize now. So right now I have both 1Password 3 and 1Password 5 on my Mac. 2) I have 2 vaults on my iPhone 6, the Main Vault with the old data, and the other with the right information. I did not create 2 vaults, it just happened at one point in the past, maybe when I changed some of the iPhones for the new one. I'm still unable to fix this. So this morning I've spent 2 hours taking screen shots of each data on my iPhone! This is unbelievable, please tell me if the chat support is available. 1Password became a nightmare instead of a solution. Thank You!

  • Hi @bilbo63,

    You should have an email in your inbox from us, we'll continue the conversation over email now.

    ref: IHD-55869-826

This discussion has been closed.