1Password Anywhere lost data

Logging onto 1Password Anywhere shows different (old?) data

Dear Sirs,

1Password (windows) is working fine on the original installed machine, however, "1Password Anywhere" is having problems.

I am using Dropbox to sync, and when I try to run the html to launch 1Password Anywhere I get problems. (on any machine)

In IE it does not work at all. This is fine as it is consistent with other issues in this forum, BUT:

In Chrome I get the message about not loading the encyrption.js data file. I cannot log on.

In Firefox I can at least log on, but the data is incomplete, it is as if it is reading an old backup file. Most of the information I have loaded is not visible.

Using 1Password shows the data is there, but if I close down and log onto "anywhere", the data is again incomplete. (same data missing as previously.)

Not being able to use browsers consistently is a serious flaw in 1Password Anywhere, because it means it is no longer "anywhere", but "anywhere with Firefox"!!! (and then data is missing)

Please advise - thanks.


  • svondutchsvondutch

    Team Member

    In Firefox I can at least log on, but the data is incomplete, it is as if it is reading an old backup file. Most of the information I have loaded is not visible.

    Have you tried this? File > Repair 1Password Data
  • DBrownDBrown 1Password Alumni
    Alan, welcome to the forum!

    Internet Explorer simply doesn't work with the technology used in the 1Password.html file; Chrome prohibits opening the file when stored on the same computer as is running Chrome (though Chrome is quite happy to open the same file on a different computer, as is the case when you use 1PasswordAnywhere in your Dropbox folder.

    As for Firefox, I've helped a couple of customers solve exactly the problem you describe (incomplete data) by having them launch 1Password for Windows and change their master password (on the Security tab of 1Password preferences). This worked even when the rather limited "repair data" function reported no problems found.

    Please give that a try, and let us know how it goes.
  • Thank you both for your help.

    First I tried changing master password. - Logged onto "anywhere" and no difference, still incomplete data.

    Interestingly though, recent changes to the data had registered and were visible, but only about a quarter of the overall data was visible. Out of interest I had a look at the "contents.js" file, and it showed the contents of the incomplete data set as visible in "anywhere", rather than the full set of data visible in "1Password".

    So I then repaired data - data apparently healthy and no errors, but then to my surprise, "anywhere" correctly showed all data. A further check of the "contents.js" file now showed ALL the data reflecting the "1Password" data.

    So, could it be that the writing of the contents file is at fault and that "anywhere" is using the contents.js file rather than the encrypted data files?
  • svondutchsvondutch

    Team Member
    edited April 2011
    I knew "Repair 1Password Data" would fix this. I guess it is not that "rather limited" after all ;-)
  • DBrownDBrown 1Password Alumni
    edited April 2011
    I'm glad it worked out, Alan!

    The "repair data" function in 1Password for Windows doesn't go quite as deep (or maybe wide) as the corresponding command in 1Password for Mac does, which is why I referred to it as limited.

    The surprise to me (and it's a pleasant one!) is that the "repair data" function didn't help a couple of customers whose symptoms appeared to be exactly as you described, so their problem must've been caused by something else, because simply changing the master password had exactly the result you described.

    Anyway, the good news is that you're up and running! Thanks for letting us know.
This discussion has been closed.