Secure Notes not syncing between Win/OS X and iOS

I created a new secure note on Windows. It synced to OS X but not on either of my iOS devices (iPhone 5s, iPad Air 2). I'm syncing via DropBox and checked that syncing is working. Changes to Logins sync w/o any issues. I have Pro Features purchased.

1Password Version: (Win), 5.3 (OS X), 5.4.3 (iOS)
Extension Version: Not Provided
OS Version: Win 8.1, OS X 10.10.3, iOS 8.3
Sync Type: DropBox


  • MeganMegan

    Team Member

    Hi @tannebil,

    I'm sorry to hear that you're having trouble keeping things synced up! Thanks so much for including all your version details here - that helps a lot.

    Let's see if we can figure out why this note is being difficult:

    • If you make edits to the note (in either 1Password for Mac or 1Password for Windows) does this trigger a sync and cause the note to show up on your iOS devices?
    • Create a test entry on your Mac ("Test, Mac") and add some data
    • Create a test entry on your PC ("Test, PC") and add some data
    • Create a test entry on each of your iOS devices ("Test, iPhone/iPad") and add some data
    • Does "Test for Mac" and/or "Test for PC" show up on either of your iOS devices?
    • Does "Test for iPhone" and/or "Test for iPad" show up on your Mac?
    • Does "Test for iPhone" and/or "Test for iPad" show up on your PC?
    • Log in to the Dropbox website and click on the 1Password.html file inside your 1Password.agilekeychain folder
    • Enter your Master Password
    • Do either or any of your test entries show up in your database here?

    Please let me know the results of this little experiment - once we have a better idea of where things are going sideways, we should be able to get this straightened out simply for you :)

  • OK. I created all three entries on the respective platform with just one word in the note. All entries synced onto all platforms as they should. Slightly puzzled by my success, I updated the Windows note on Windows to have the same content as the note that isn't fully syncing (just plain text). The note did not update on either OS X or iOS. I checked the Dropbox web site and the entry there has the updated contents.

  • MeganMegan

    Team Member

    Hi @tannebil,

    Thanks so much for running those tests for me! I just want to be sure I understand your results correctly here, because it certainly sounds a bit odd:

    • All of your test entries synced to all of the places that they should.
    • However, when you edited the Windows test entry to include the text from the note that didn't sync ... that test entry also did not sync?

    If this is the case, some follow-up questions:

    • Are we talking about a substantially large text note here?
    • Did you allow a bit of time for the changes to sync down to all your devices?
    • When you say that the troublesome note "isn't fully syncing", could you describe a little bit more about what this looks like? (For example, do you see the note's title and a portion of the text?)

    We appreciate your patience as we work to track this down!

  • Just to deepen the mystery a bit, the note created on Windows doesn't show at all on my iPhone. The item count in 1P is one less on the iPhone than the iPad (705 vs 706).

    I always check the latest sync times to ensure that Dropbox has synced. Note that I was not including my iPhone in my testing nor a few other devices (in total, 4 iOS, 2 Win, 2 OS X), that replicate my Dropbox and are running 1P so I don't know if the initial note replicated before I made the edit.

    The note is about 10 short lines of text.

    When I say "not fully syncing", I'm referring to the initial version of the test note being synced but the edited version not being synced on iOS.

    I get a "key data file could not be loaded" error if I try to open password.html on iOS. The troubleshooting link only talks about Win/OS X but if I try to follow it and click on the "key data file " link, nothing happens. It does work fine on the Dropbox web site where I again confirmed that the edited version of the note exists.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @tannebil,

    I'm sorry for the delay in getting back to you about this! I'm assuming you're still having the same problem, but please let us know if anything has changed.

    I've been reading over everything here and I have to admit I'm quite confused about what works, what doesn't work, and where problems are happening. Issues like this can certainly become confusing when referring to different computers, devices, items, edits, and so on, so I'd like to make sure I've got it all straight:

    The original problem was that you created a new Secure Note in 1Password on Windows, and that new Secure Note synced to Mac but did not sync to iOS devices. However, changes to other items sync correctly between all computers/devices. Is that correct?

    After creating some new test items on your Mac, PC, iPad, and iPhone, each new test item synced correctly to each computer/device. At that point, what was the state of the original Secure Note you created on Windows that synced to Mac but not to iOS? Did that Secure Note end up syncing to your iPhone & iPad at some point? Or, is that original Secure Note still not syncing to iOS, even though other new items created on Windows do sync to iOS?

    Then you said:

    I updated the Windows note on Windows to have the same content as the note that isn't fully syncing (just plain text). The note did not update on either OS X or iOS. I checked the Dropbox web site and the entry there has the updated contents.

    Are you still referring to the original Secure Note that you created on Windows? Or is that one of the test items that Megan asked you to create? If it's the original Secure Note, on which computer or device did you make the update to the content that didn't sync back to Windows? If the original Secure Note started syncing to the iOS devices at some point, is the problem now that changes to that Secure Note (or possibly other items) do not sync correctly between all devices?

    I apologize if some of these answers seem obvious to you! As I said, this type of thing can get very confusing, so if you can be very specific in your answers and about what you've tried / what happened / where it happened, I think that will help clear some of this up for us so we can help solve the problem. Thanks in advance! :)

  • That was my attempt at a specific answer. :-)

    I'll confine myself to a new test case which involves a Windows 8.1 PC, a Mac Mini, and an iPad Air 2 all running the latest versions of everything.

    1) I create create a new note named "test5 from Windows" on Windows with just the text "test5" in it. It syncs to the OS X and iPad without any issue.

    2) I modify the note on Windows to be "test5 - update 1". The modification syncs to OS X and the iPad without any issue.

    3) I replace the existing text on Windows with:

    Windows 8.0/8.1 upgrades


    Windows 8.0

    Windows 8.1 Pro
    Product Part No.: [8]X18-15
    Installed from 'Compliance Checked Product' media.
    Product ID:
    CD Key:
    Computer Name: ABBY
    Registered Owner: William Tanner
    Registered Organization:


    4) The note does not show the update on either OS X or iOS

    5) The Dropbox web site matches the note as displayed on Windows.

    Testing notes:

    I saw the OS X notification that Dropbox updated after making the change in (3) but 1PW doesn't display it.

    I'm unable to check if Dropbox on the iPad has the modified version as password.html throws an error when I try to open it.

    I checked an iPhone that uses 1PW with the same Dropbox account and it does not show the test5 note at all.

    I checked the sync status of Dropbox after each change. OS X was always current almost immediately but I manually forced a sync on iOS in most cases.

    Selective Sync is enabled on Windows but the 1Password.agilekeychain folder is selected. It is not enabled on OS X.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @tannebil,

    Thank you so much for the details! The new "confined test case" was a great idea and it really helped me to understand what you're experiencing on your end. I appreciate it! :)

    Since you sent us that message yesterday, the first thing I wanted to ask is, has anything changed since then? The reason I ask is that I've seen cases where sometimes changes don't seem to sync immediately via Dropbox, but eventually do sync after a delay. If the new text you entered in your Secure Note on Windows (in step 3) are finally showing up on your Mac and iPad now, then it sounds like the sync is working (although it's taking longer than it should, of course).

    On the other hand, if those changes still haven't shown up in that Secure Note on your Mac or iPad, please try a few simple tests on your Mac:

    1. Quit the main 1Password app on your Mac, then reopen it. Check that Secure Note. Do the changes you made on Windows show up now?
    2. If it still doesn't show the recent changes, make a small change to a different item in 1Password on your Mac (any change is fine - you can add a word to the notes field of a Login item, for example). Save the change - this should "force" a new sync with Dropbox. Go back to the test Secure Note. Does it show the changes from Windows?
    3. If not, hold the Control key on your keyboard and go to the menu for 1Password > Quit 1Password and 1Password mini. Reopen 1Password and check the Secure Note. Do you see the changes yet?
    4. If not, go to Help > Troubleshooting > Restart 1Password mini. Quit 1Password, then restart your Mac. After the restart, open 1Password and check the Secure Note. I'm almost afraid to ask at this point, but... are the changes there?

    Please let us know how that goes. If the changes from Windows still won't sync to the Mac, there might be something wrong with the 1Password.agilekeychain in Dropbox.

    I'm unable to check if Dropbox on the iPad has the modified version as password.html throws an error when I try to open it.

    It sounds like you're trying to open that from the Dropbox app on the iPad. The Dropbox mobile app can't load the entire data bundle because it can only load a single file at a time (i.e. the 1Password.html file), but your data is made up of hundreds of smaller files. But that's not a problem! You only really needed to check that from a web browser on one of your devices/computers. That simply confirms the change you made on Windows was successfully copied to the Dropbox servers (and it sounds like it was). It helps us narrow down where the problem is happening.

    If you really want to, you should be able to check that from in the Safari browser on your iPad. But again, it's not necessary - that should show you the same information as when you did that from a web browser on one of your computers. It's the same data in the same account on If you do try it though, let us know if there's a problem.

    I think we're getting a lot closer to figuring out the problem! Looking forward to hearing back from you.

  • I tried all four of the troubleshooting steps but none made any difference.

    I've been using 1PW with Dropbox for a long time on a lot of different machines so there have been plenty of opportunities for a subtle corruption error to occur.

  • This certainly is quite the puzzle you've brought us @tannebil,

    Let's see if 1Password for Windows Repair 1Password Vault function can make any difference. You can find that option in 1Password's File menu.

    After that I suggest we try creating a brand new agilekeychain which we can easily do from one of your Macs if it holds a complete copy of your vault other than this oddity.

    On a Mac with a good vault you would perform the following:

    1. Launch 1Password for Mac and enter 1Password's preferences.
    2. Switch to the Sync tab.
    3. Change the menu option from Dropbox to None.
    4. In the confirmation window that appears tick the checkbox titled Delete data from Dropbox and confirm you wish to Disable Sync.
    5. Pause for a moment to let Dropbox synchronise the deletions with the server.
    6. Set up Sync with Dropbox again.

    This will create a brand new agilekeychain based on the vault on this Mac. Now you will have to re-enable Dropbox Sync on all your other Macs and iOS devices as they will recognise this agilekeychain is not the same one and as a precaution they will disable syncing. In 1Password for Windows the agilekeychain is your vault you would simply open this new one.

    So I would recommend trying the repair tool in 1Password for Windows first as it works on the existing agilekeychain. Then the slightly more drastic option is to create a brand new agilekeychain. Hopefully this starts behaving better as a result as it's very curious but not something I've been able to reproduce despite your clear steps and supplied text.

  • Repair 1Password Vault run but it didn't display any messages and it didn't fix the problem.

    I went through the reinitialization process for Dropbox Sync. I deleted the test note and the note that was originally causing the problem before disconnecting Dropbox. I then:

    1. Changed the sync option to None on my Mac Mini, told it to delete data from Dropbox, and waited for Dropbox to delete the 1Password files on all the devices.
    2. Changed the sync option on the Mac Mini to Dropbox and waited for the Dropbox sync to finish across my devices
    3. Created a test secure note on Windows with the multi-line text that was causing a problem. It synced fine to OS X
    4. I edited the test note to remove some existing lines and add new ones. The edits did not sync to OS X. On Windows, the note says it was last edited on 7/5/2015 12:51:22 AM. On OS X, it says lasted edited on 7/5/2015 12:41 AM. Dropbox on both systems shows as up-to-date.
    5. I checked the Dropbox web site and the note is the edited version.

    I tested creating and editing a similar note in OS X instead of Windows and that worked fine syncing to Windows until I edited the note in Windows. Syncing broke at that point so the problem only seems to occur when the secure note is edited in Windows.

  • Hi @tannebil,

    It feels like we're narrowing down the issue although rather annoyingly I still can't reproduce (We're both running the same version of 1Password for Windows so I would hope we'd observe the same behaviour). As you can imagine, being able to replicate the issue makes it so much easier to discover why and thus where in the code.

    A couple of things.

    1. Does OS X still not show the changes if you lock 1Password. You can do this using the keyboard shortcut ⌃⌥⌘L for example. When you unlock it forces 1Password to synchronise and we are/were aware of some quirks with FSEvents where we don't seem to be notified in a timely manner when Dropbox makes changes. I haven't tested recently to see if anything changed in any of the updates.
    2. You tested OS X extensively which was great, I'm wondering if iOS behaves in the same way given it doesn't rely on FSEvents like OS X does.

    The tests I've completed see both the individual password item and contents.js updated so in theory everything that 1Password for Mac needs to be aware of a change has happened. All very puzzling.

  • Locking/unlocking 1PW on OS X has no effect.

    iOS has the original, rather than the edited version of the note. Note that in this case, 1PW was completely reinstalled after the edit had been completed so it's not clear to me why Dropbox would even have the unedited version unless it's automatically doing some sort of versioning at the client level.

    The reason it was a complete reinstall on iOS is because, when I reconnected iOS to Dropbox, 1PW showed a merge conflict error and recommended not merging. I was at a bit of a loss as to the proper course and ended up deleting 1PW from the device and reinstalling it. I've got three more iOS devices to reconnect, so I'd appreciate some advice as to the best course to take with those devices.

  • BenBen AWS Team

    Team Member
    edited July 2015

    Thanks, @tannebil.

    Please open 1Password for Mac and enable 1Password > Preferences > Advanced > Show Item > Copy UUID menu item (if not already enabled). Then select one of the items that is not syncing properly, and select Item > Copy UUID from the menubar.

    Then please send us a diagnostic report from each of the devices:

    Attach each file to an email to us: [email protected], and also include the UUID from the clipboard that you got above.

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can quickly track down the report and ensure that it is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks in advance!


    ref: NJR-51856-821

  • Has this problem been fixed or at least root caused? I am seeing exactly the same problem: a secure note I entered from a Windows 8 machine does not show up on my Mac or iOS devices.

  • BenBen AWS Team

    Team Member

    Hi @stevefu,

    The problem was caused by the use of a non-ASCII character in the problem item(s). If a character does not appear in red in the first table on this page then I wouldn't recommend using it in 1Password.



  • MrCMrC Community Moderator
    edited December 2015


    Your statement about non-ASCII is concerning to me.

    1. Which fields/locations are you referring to regarding the avoidance?
    2. The GUIs support input of Unicode characters, as does 1PIF (which is in UTF-8), so your mentioned restriction is surprising.

    All of my converters export UTF-8 into the 1PIF, so I hope this is just a misstatement.

  • BenBen AWS Team

    Team Member

    @MrC -

    Indeed. Removing the only non-ASCII character in the item resolved the issue in the other reported case. I don't know what specific characters may be causing the issue (in that case it was something that looked like a dash, but was not).

    I've only got limited information at this point -- just the one case, so I wouldn't make any rash decisions at this point based on it.

    I would recommend removing any non-ASCII characters from items having difficulty as a troubleshooting step though.


This discussion has been closed.