gmail multiple account login problem

I am running 1Password for Windows (test mode, I'll buy a copy as soon as I know this works), release 1.0.5.177, on a laptop with Windows 7 Ultimate, usually using Firefox.

I have three gmail accounts and had no problem setting up the three different 1Password logins for them. The logins worked fine for a few days, but then none of them worked. 1Password would fill in the user name and password correctly, but the login was rejected. I do not get a gmail message that the login failed - the login screen simply reappears with the username completed but the password box empty. I deleted all three of logins, recreated them, and they worked fine for a couple of days. Then the same problem reappeared.

I went into the 1Password file for these three accounts, deleted the dsh and GALX lines (whatever the hell those are), and now the logins work fine.

Please explain what the problem is, what I just did to fix it (monkeys banging on the typewriter creating Shakespeare?), and whether there is a different 1Password fix for this.

Thanks.

Comments

  • DBrownDBrown 1Password Alumni
    Bob, none of my co-workers can think what "the dsh and GALX lines" might be.

    Are you saying you edited your three Login items in 1Password, and those were fields that were listed in the table at the bottom of the edit window?

    What URL are you using to log in to your Gmail accounts?
  • Super Dave -

    Your description is correct - I edited the three login items in 1Password, and deleted the "dsh" and "GALX" fields in the table at the bottom of the edit window.

    I don't know what those lines did, or what the data in those fields meant, but when I deleted them the 1Password login worked again.

    I usually get to my gmail by going to www.gmail.com and then use 1Password to select the login identity. But the problem still occurred when I would open a new blank window, click on the 1Password button, select the login identity, and let 1Password fill in the url, user name and password.
  • DBrownDBrown 1Password Alumni
    Thanks, Bob.

    My own Gmail account Login items don't have dsh or GALX fields, nor did those of my co-workers when I asked, yesterday.

    Just now, I saved a new Login for the form at www.gmail.com, and this is what 1Password for Windows created:

    1P-win.png


    Then, I saved a new Login for that form using 1Password for Mac:

    1P-mac.png


    So I still don't know where those fields came from, except that they must have been somewhere within the HTML code for the <form> element when you saved the Login item, or 1Password couldn't have picked them up.

    At this point, I'd say "Good job!" on getting them cleared out, so that your Login items work as expected.

    Sorry not to have a more helpful answer for you, Bob.
This discussion has been closed.