Can't Enable 1Password for FF4

In 1Password/Preferences/Browsers I cannot enable Firefox 4. The check box will not accept a checkmark. FF3 will accept a checkmark but I'm using FF4(the current stable version, not a beta.)
If it matters, I'm running OS 10.5.8.

Comments

  • jpgoldbergjpgoldberg Agile Customer Care

    Team Member
    Hi Uncle Vishnu. Welcome to the forums!


    In 1Password/Preferences/Browsers I cannot enable Firefox 4. The check box will not accept a checkmark. FF3 will accept a checkmark but I'm using FF4

    When you say that you can't check the box for the FF4 extension is the line and box grayed out? Or does clicking on the box simply do nothing?

    What happens if you try "Remove All Extensions" and then "Install All Extensions" in that preferences pane?.

    If that doesn't work, I would guess that there might have a damaged copy of 1Password and would suggest that you reinstall 1Password version 3.5.9 which you can fetch from

    http://help.agile.ws/1Password3/legacy_versions.html

    If it matters, I'm running OS 10.5.8.

    Also can you let us know whether you are using an Intel or PPC Mac?

    Thanks! I think that the things I've listed above should resolve the problem, please let us know.

    Cheers,

    -j
  • edited April 2011
    The box is NOT grayed out; clicking on it does nothing, no check mark remains after clicking on the box.
    Doing "Remove All Extensions" and then "Install All Extensions" doesn't help.
    I just reinstalled v3.5.9 but the problem remains.
    I'm using a MacBook Pro Intel core 2 duo.
  • khadkhad Social Choreographer

    Team Member
    edited April 2011
    I'm sorry that you are still having this problem.

    It sounds like some kind of corruption in your Firefox profile. Please make sure you have tried all the steps in our troubleshooting guide specifically creating a new profile in Firefox if the other steps do not get you up and running.

    Please let me know how it turns out.

    Thanks!
  • Sorry, but I'm pretty weak on terminal use. In terminal, right after my name, I entered cd and hit "enter" but nothing happens; If I enter Applications/Firefox.app/Contents/MacOS/firefox-bin -ProfileManager, and hit "enter" the response in terminal is: dyld: unknown required load command 0x80000022
    Trace/BPT trap
    I imagine that I'm doing it wrong in some way. What's the proper protocol?
  • khadkhad Social Choreographer

    Team Member
    edited April 2011
    I am terribly sorry about that. We need to fix that in the documentation. It is not your fault at all. Please copy and paste this into Terminal and then press the Return key on your keyboard:

    /Applications/Firefox.app/Contents/MacOS/firefox-bin -ProfileManager
    

    Then follow the steps to create a new profile here:

    http://support.mozilla.com/en-US/kb/Managing profiles#w_creating-a-profile
  • edited April 2011
    Using the terminal command doesn't work. Here's the result:
    Last login: Tue Apr 26 13:47:56 on console
    unclevishnu's-macbook-pro:~ unclevishnu$ /Applications/Firefox.app/Contents/MacOS/firefox-bin -ProfileManager
    dyld: unknown required load command 0x80000022
    Trace/BPT trap
    unclevishnu's-macbook-pro:~ unclevishnu$
  • brentybrenty

    Team Member
    edited April 2011
    Hey there, Vishnu! Thanks for your response. That gave me an idea of how to proceed. :)

    After doing some searching, I found this site, which seems to indicate that it could be a problem related to it trying to launch as 64-bit. Leopard, of course, is 32-bit only. Perhaps the ProfileManager is foolishly trying to run in 64-bit mode! Please try this modified command instead, to force the ProfileManager to load in 32-bit mode (and make sure you change it to reflect the location and name of the Firefox 4 app on your system if necessary.) Run this in Terminal:

    arch -i386 /Applications/Firefox.app/Contents/MacOS/firefox-bin -ProfileManager
    


    All of this begs the question: Why is there no way to launch ProfileManager in the GUI? <img class=" />

    Anyway, you are now hopefully staring at the ProfileManager window. Click Create Profile and pick a name. You can uncheck the box that says "Don't ask at startup" if you want to be prompted to choose a profile when you launch Firefox in the future, and then select your new profile and launch Firefox.

    Now, quit Firefox and try to install the 1Password extension. Hopefully this works now. If you are still having this issue, please email us at [email protected] and include a Diagnostics Report. You can do this by launching 1Password and going to Help > Troubleshooting > Diagnostics Report... and then either dragging the icon to an email or using Export to save it and attach it manually. Also, be sure to include a link to this forum thread so we can connect the two. We will get you back up and running. :)


    +++++++++++++++++

    Using the terminal command doesn't work. Here's the result:
    Last login: Tue Apr 26 13:47:56 on console
    unclevishnu's-macbook-pro:~ unclevishnu$ /Applications/Firefox.app/Contents/MacOS/firefox-bin -ProfileManager
    dyld: unknown required load command 0x80000022
    Trace/BPT trap
    unclevishnu's-macbook-pro:~ unclevishnu$
This discussion has been closed.