Different passwords for the same vault? [upgrade 1Password for Mac]

DidikoDidiko
edited December 2015 in Windows Beta

Hello,

I have one single vault synchronised to several versions of 1P. When I used the Win10 Alpha version for the first time, I had to modify the password for the new software to be able to open it.
What surprises me is that I worked last week-end on my "old" MacPro with 1P (version 4 I guess) and I had to enter my old password to unlock it (but pointing to the same vault on Dropbox): is this normal? I thought that it was changed "everywhere"!


1Password Version: Beta
Extension Version: Not Provided
OS Version: Win 10 Pro
Sync Type: Dropbox

Comments

  • DBrownDBrown 1Password Alumni

    Hi, @Didiko!

    It's hard to pin down what happened without knowing all the exact details.

    For starters, though, are you using a .opvault or .agilekeychain folder to sync your data, and what sync method are you using?

    Also, can you check the exact version of 1Password that's running on your Mac?

    Thanks!

  • Agilekeychain format, synchronised with Dropbox

    The software on my MacPro is version 4.4.3

    And I confirm that my "old" password is required on the MacPro ... and the new one on my SurfacePro with 1P Beta.

    Still, luckily, both are working all right and seem identical at least: any clue?

    Thanks in advance

  • And to be as complete as possible, if my memory is correct, I changed the master password on another (third) version of 1P running under Windows 7 Pro on my previous computer (which I don't use anymore)...
    Don't remember the exact version number anymore but it was the latest available on Windows 7 Platform for sure.

  • DBrownDBrown 1Password Alumni

    Thanks for the follow-up, @Didiko.

    The first thing to check, I think, is to make sure that (a) the older Mac is really using the exact same .agilekeychain folder in the exact same location in your Dropbox hierarchy, and (b) Dropbox has finished syncing your data onto the older Mac.

  • DBrownDBrown 1Password Alumni

    Also, if you can upgrade to a more recent version of 1Password for Mac, I believe the post-4.x releases clear up some issues with syncing of the master password.

    (This blog post might be interesting.)

  • Thanks for the information. All I can say is that it points to the same Dropbox vault.
    As a test, I logged on the MacPro and deleted 5 records, went back to my Surface and launched 1P Beta: same number of records there, so I guess this is definitely the very same vault... still I must use the old password on the MacPro and the new one on the Surface.
    As for the update, the 4.4.3 is the latest one I can get on my current configuration because I checked manually for updates (in 1P itself)and it says "no update available". I'm still in Mavericks (10.9.5) so I don't think I can skip to version 5 :(

  • DBrownDBrown 1Password Alumni

    I'm checking with my colleagues who might have more insight into the master password–syncing question, @Didiko; one of us will post here as soon as there's any more information available.

    Sorry I don't have an immediate answer for you. :(

  • DBrownDBrown 1Password Alumni

    Well, that didn't take too long! :D (I have very smart and helpful colleagues!)

    Apparently, you just need to change the master password on the older Mac (Mavericks and 1Password 4.4.3) to the same master password as you use on your other devices (where the new master password is already recognized).

    I hope that helps, @Didiko. Please let us know how it goes.

  • Ok, I probably did something stupid: said to myself: let's try to reverse to the old password on the Beta instead!
    But now I can't login anymore, nor with the old password, nor with the new one: please help.
    I tried to uninstall and re-install the software but it restored the old settings automatically and the problem is still there of course.
    I can still login with 1P 4 on the old Mac but not anymore with 1P Beta :(
    Please help...

  • No clue what happened but found the "run" command. Had to go until op resethard and clean master data.
    1P restarted from the beginning, pointed again to Dropbox and it's back on track!
    Still I don't understand what happened exactly: apparently you cannot change the master password successfully with this Beta version (at least with a vault located on Dropbox in agilekeychain format)
    ;)

  • DBrownDBrown 1Password Alumni

    Unless you're using a 1Password for Teams vault, changes to your vault are not written out to the "sync point" (the .agilekeychain or .opvault folder you opened in the beta app) and won't be recognized on other platforms.

    That said, changes you make to that vault on the other platforms will be recognized by the beta app, as soon as the vault has re-synced (typically when you launch the app, but also possible to trigger manually).

This discussion has been closed.