No prompt to save password on login

Hi all -
I'm setting up a team member's Mac and 1Password is working fine, except I don't get a prompt to save a password when logging into a new site. Similarly, the 'Save new login' option (Command + N) from the menu simply doesn't do anything.

I tailed the log while logging into a new website, and the following error was displayed:

Wed Dec 16 22:12:02 2015| 550030 [EXT_UI:(Main Thread):<OPSaveLoginWindowController: 0x7faada439f50>] W promptToSaveLoginWithCollectedPageDetails:orLegacyLoginJSON:token:mode: | The primary profile is nil. 1Password needs to be set up before using auto save.

So perhaps something went wrong during installation?

Here are the details:

  • 1Password 5 Version 5.5.BETA-30 (550030) AgileBits Beta
  • Chrome plugin version, Firefox 4.4.3 (same behaviour in both browsers)
  • OS X El Capitain (10.10.4)
  • 'Automatically ask to save new logins' definitely checked in Preferences
  • Tried on numerous different websites/logins that were not already in my vault (e.g.,

Thanks in advance.


  • Update: I've been able to dig up a bit more about this. It seems to be specific to a) Teams accounts, and b) on completely fresh installs of the latest betas on Macs (at least 5.5.30 and 5.5.31). Earlier versions of 1Pass would have an install procedure that created a local Primary vault. The latest betas seem to omit this step in favour of a more streamlined Teams setup process, but this does not create the Primary vault, which appears to be a dependency for the 'save login' popup. I was able to work around the issue by installing an earlier version of 1Pass (which created the Primary vault), then reverting back to 5.5Beta.

    My somewhat convoluted workaround:

    • Exit 1Password and 1Password mini
    • Download latest stable release (5.4)
    • Rename to 1Password 5.4, drag to applications, and run
    • Click "I'm new to 1Pass"
    • Set master pass (to be same as your Teams one)
    • You may get an error about wrong version of 1Pass mini (this dialog froze on me - I had to kill the processes via the terminal)
    • Delete 5.4 from applications
    • Run 5.5-Beta
    • The teams vaults may have messed up names. To fix, go to Prefs -> Teams, click 'Remove account', then re-add it

    Mods - this appears to be a bug in the latest Mac betas rather than a browser filling issue alone, so should this thread be moved back there?

  • Drew_AGDrew_AG 1Password Alumni

    Hi @massza,

    I apologize for the delay in getting back to you! Thank you very much for all the details about the setup, versions, what you've tried, and so on. It's extremely helpful for us!

    I think a few of the quirks you mentioned (such as the error about the wrong version of 1Password mini) are related to having multiple copies of the 1Password app on the Mac at the same time during that part of your troubleshooting. But you were able to take care of that by deleting one of them.

    Now, there's an option in the beta version to allow 1Password to be set up in a "Teams only" mode without creating a personal Primary vault. That's a new feature, so it's possible there are a few bugs that need to be worked out - however, the reason why you're running into some trouble with that and the 1Password browser extension might be due to using the latest stable release of that extension. Instead, please try the latest beta extension in each browser to see if that helps.

    First, please delete the current 1Password extension from the browser(s). After you've done that, go ahead and install the beta extension:

    Is there any difference with the beta extension? Please let us know how it all goes. Thanks! :)

This discussion has been closed.