Citi MasterCard never works, even with submit when enabled or never submit.

I log into https://www.citi.com/credit-cards/citi.action. 1Password enters my username and password, but the site won't accept the login, whether I use enabled, submit when enabled, or never submit. I have to manually enter at least one letter of my username. Is there a solution?
Rob Evans


1Password Version: 5.41
Extension Version: 4.4.4
OS Version: OS X 10.11.2
Sync Type: iCloud
Referrer: kb:change-website-password, kb:disable-autosubmit

Comments

  • Drew_AGDrew_AG 1Password Alumni

    Hi @evansrob,

    I apologize for the delay in getting back to you about this!

    Thanks for letting us know the URL for the site you're having trouble with. Citi login sites are notorious for not playing nice with 1Password, and our developers are always trying to make improvements. However, it's kind of like a moving target - every time our developers get 1Password to work correctly with a Citi login site, it seems like Citi makes a change to that site which causes a new problem for 1Password.

    However, I do have a suggestion that I think will help. Please try these steps to create a new Login item for that site:

    1. Visit the login page: https://www.citi.com/credit-cards/citi.action
    2. Enter your password first (type it manually, or copy/paste) and then enter your username, but don't submit the form yet.
    3. Click on the 1Password icon in your browser's toolbar, then the gear icon next to the search field, and choose Save new Login.
    4. Change the title so you can easily tell the new Login apart from the old one, then click the Save button.
    5. Refresh the page, then try to have 1Password fill your info using the new login.

    Does the new Login work? Let us know how it goes, thanks! :)

  • This solved the problem! Excellent. Many thanks.

  • Drew_AGDrew_AG 1Password Alumni

    You're very welcome, @evansrob! Glad to hear that solved the problem. Hopefully you're all set now, but if you have more questions or need anything else, just let us know. Have a great weekend! :)

This discussion has been closed.