Citi login issues


I successfully generate a new password and save it along with a new user name in 1password. The site accepts the change and logs me on, but when I logout and try to log in again, it will not insert my username and will only insert 3 digits of the 50-digit password. The only way I can make it work is to manually type in my username and select "Last generated password." I have not had this problem with any other password. What am I doing wrong? Thanks.

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: kb-search:last generated password, kb:change-password-safety-nets


  • MikeTMikeT Agile Samurai

    Team Member

    Hi @PamDD,

    Can you tell us which site this is, keep in mind that this is a public support forum and if you want to keep it private, please email us at [email protected], so we can test what's going on.

    You may not be doing anything wrong, some sites are intentionally doing this to prevent malicious tools from grabbing the data and it is a thin line between that tool and legitimate tools like 1Password.

    If it is something like Citibank, please try this:

    1. Use this URL for your Citi Login item, as it is the best compatible one with 1Password's filling:
    2. Enter your username and password but do not submit the form, click on the 1Password icon to go to Settings > Save New Login to save it.
    3. In the main 1Password program, enable multiple URLs in 1Password's File Menu > Preferences > Logins
    4. Also, in the main program, find your Citi Login item, edit it and on the bottom, make sure the username is showing up as a full username and not as user***e. Citi sensors your username before 1Password gets a chance to save it, so that can prevent the username from filling in properly.
  • Thanks, Mike. You got it exactly right. It's Citibank. I'll give it another go. It's puzzling that the Citi IT guy didn't have a clue about the problem and never heard of 1Password.

  • brentybrenty

    Team Member

    @PamDD: Well, to be honest, they have so many login forms and they change so frequently that it doesn't surprise me that they'd have as much trouble keeping track of them as we do! :lol:

    Definitely try Mike's suggestion, as that works for me as well. And if you're still having trouble, be sure to let me know the exact steps you're taking and where you're running into trouble. I'll be happy to help! :)

  • It did work for me, but I'm wondering if it will get more complicated to use 1Password as sites develop more stringent security measures.

  • brentybrenty

    Team Member

    @PamDD: Well, that's certainly a possibility...but I will say that over the years it seems like it's gotten a bit easier (but don't tell the extension developers I said that!)

    Purely from my own personal experience, while many sites I frequent haven't seen much (if any) improvement in ease of use, many have! Off the top of my head, Bank of America, Discover, and PayPal were sites that were a struggle in the past.

    Ultimately, 1Password's filling is based on web standards, so as more websites have adopted them (presumably so they can work in modern browsers, not so they can work with 1Password) it seems to have helped 1Password users. That and many sites have adopted better security practices as well (fewer password limitations, easier login procedures).

    And of course all of us can 'encourage' the companies we do business with to make it easier for their customers to be more secure. When websites work better with 1Password, we have a better experience with them, because we can use a long, strong, unique password that no one will guess, and have 1Password fill it for us. So I think that there's definitely reasons for optimism. :)

  • Having problem with 1Password and Citi, too. However, 1password seems unable to fill-in the password, just the User ID. Tried the procedure suggested in the MikeT's December 18 post, but it didn't help. Made sure the User Id did not have asterisks. Any other suggestions? Thanks.

  • brentybrenty

    Team Member

    @joisagile: I'm sure I can offer you a solution, since I frequently use my Citi login with 1Password as well. Unfortunately without some basic information it's hard to say precisely what the solution may be in your case! Please tell me the OS, 1Password, and browser versions you're using and I'll be happy to test it myself and get back to you with a workaround. Thanks in advance! :)

  • Much appreciated. Here is the information you requested as well as the webpage listed in the 1password login entry. As a reminder, 1password seems unable to fill-in the password.

    Safari 9.0.2
    Mac OS 10.11.2
    1Password 5 Version 5.3.2 (532001) Agile Web Store


  • brentybrenty

    Team Member

    @joisagile: Thanks for getting back to me! This will be pretty easy. First though, be sure to update to the latest 1Password and extension versions, since you seem to have an old one for some reason.

    Manually saving a new login for the site will allow 1Password to save additional information from the form. Just try these steps to save the login manually:

    1. Navigate to the following URL:
    2. Enter your login credentials
    3. Click the 'keyhole' icon to bring up the extension
    4. Click the 'gear' icon for Settings
    5. Click Save New Login
    6. Give it a name and Save
    7. Close the webpage and select your new login from the extension to have 1Password Go & Fill
    8. Submit the form manually if you have autosumbit disabled

    I was able to use my login saved in this way to fill at as well, so if you just add that to your Citi login item as a second URL you can use it there too. Please let me know how it turns out! :)

  • I updated 1Password 5 to Version 5.4.1 (541003), Agile Web Store, then followed the 8 steps. 1P still wasn't able to fill-in the password.

    Tried on Firefox 42.0. Works there!

  • Hi @joisagile,

    Now I don't want to make a mistake by assuming something incorrectly. When I read your post my brain keeps trying to interpret the "Works there!" in a way that suggests success! but it may be that working in Firefox is okay but you need it to work in Safari. Can you just confirm for me please, are you happy because it fills in Firefox and that's all you need or were you more highlighting an observation you made during your troubleshooting? We can continue trying to figure this out if you still want to :smile:

  • Unable to get 1password 5 working with Safari at the website. Would be nice to get it working there but not critical.

    I tried Firefox and 1P5 on the citi website to help determine the source of the problem. Able to logon to citi website using 1P5 and Firefox.

    So, please let me know if you have any suggestions for Safari.


  • Drew_AGDrew_AG 1Password Alumni

    Hi @joisagile,

    Thanks for clarifying! :)

    Can you please let us know which version of the 1Password extension is currently installed in Safari? We have steps to find the extension version number here: How to find which version of the 1Password extension is installed

    Thanks in advance!

  • The extension is 4.2.5. Note that I tried to logon to the Citi website from the application and the extension.

  • brentybrenty

    Team Member
    edited December 2015

    @joisagile: As I mentioned in my previous post, you'll need to be using the newest extension version as well in order to get the same results I'm getting. Please install it from our website:

    1Password browser extensions

    Then follow the instructions in my previous post, as they'll allow you to create a Citi login that works in any browser. And if you're still having trouble, be sure to let me know exactly which step you're having trouble with. Let me know how it turns out! :)

    P.S: I just noticed what your picture says (my cursive reading skills are atrophied). 1Password — and all of us at AgileBits — love you too! :love:

This discussion has been closed.