Chrome on Mac — not offering saved passwords until after several attempts

When I pull up a website that I have routinely logged into with 1P in the past, I use the shortcut key to fill in from Chrome, and 1P does not offer any passwords for the site. I try again, and again, and on the 3rd or 4th attempt, miraculously the standard choices appear. I want to fix this so that the correct options are offered from the get go, as they always were in the past.

Possibly related, possibly not: I'm being prompted very frequently to save passwords on common sites that always log into using 1P. I don't understand why this is happening, since the u/p are unchanged from what already exist in 1P.

Possibly useful context: I'm traveling abroad and browsing and logging in from the other side of the world.


1Password Version: 5.5 Beta 33
Extension Version: 4.5.2.1
OS Version: 10.11.2
Sync Type: Dropbox
Referrer: forum-search:Chrome on Mac — not offering saved passwords until after several attempts

Comments

  • sjksjk oversoul

    Team Member

    Hi @zebdro,

    I'm sorry that 1Password shortcut usage in Chrome has become less response for you. Let's do some troubleshooting to figure out what's tripping it up.

    When I pull up a website that I have routinely logged into with 1P in the past, I use the shortcut key to fill in from Chrome, and 1P does not offer any passwords for the site.

    When this happens are you using the shortcut for Fill Login on current web page (default ⌘\) or Show 1Password mini (default ⌥⌘\)?

    I try again, and again, and on the 3rd or 4th attempt, miraculously the standard choices appear. I want to fix this so that the correct options are offered from the get go, as they always were in the past.

    When things work properly, do you see multiple items to select from after using the shortcut? I'm not sure what you mean by "standard choices" and "correct options". Using the ⌘\ shortcut when only a single item matches for the current page will fill (and autosubmit, when enabled) without having to select an item. But using the ⌥⌘\ shortcut will always display zero or more matching items in 1Password mini to select from.

    Is behaviour any different if you click the 1Password button/icon in Chrome's toolbar instead of using the shortcut?

    And what happens if you select a Login item in 1Password mini after using the shortcut or clicking the toolbar icon, before opening a page to fill on? Normally the page will load first, then filling is attempted on it – open and fill in 1Password jargon.

    Possibly useful context: I'm traveling abroad and browsing and logging in from the other side of the world.

    Were you having the current trouble with 1Password before you'd started traveling? I'm wondering if it's caused by pages not being fully loaded before trying to use 1Password on them. It should be helpful knowing the results from any open and fill tests you can do. Also, can you provide URLs for any pages that are requiring multiple shortcut attempts?

    Thanks in advance for the answers and other details so we can get you some specific suggestions for how to fix this.

  • zebdrozebdro Junior Member
    edited December 2015

    When this happens are you using the shortcut for Fill Login on current web page (default ⌘\) or Show 1Password mini (default ⌥⌘\)?

    I always use the the default.

    When things work properly, do you see multiple items to select from after using the shortcut? I'm not sure what you mean by "standard choices" and "correct options". Using the ⌘\ shortcut when only a single item matches for the current page will fill (and autosubmit, when enabled) without having to select an item. But using the ⌥⌘\ shortcut will always display zero or more matching items in 1Password mini to select from.

    Many of my most common websites have >1 active login. Active logins are what I meant by standard choices.

    Is behaviour any different if you click the 1Password button/icon in Chrome's toolbar instead of using the shortcut?

    I believe the behavior is the same when I click the chrome extension button, and when I click the Mac toolbar version.

    And what happens if you select a Login item in 1Password mini after using the shortcut or clicking the toolbar icon, before opening a page to fill on? Normally the page will load first, then filling is attempted on it – open and fill in 1Password jargon.

    I may not be following you on this one. I always load a page first and then attempt to fill in. Are you asking me to open a blank tab, shortcut 1P, and then type in a search to find the website + login I want to use? I've never done that. But if I got that right and it's helpful, let me know and I will try.

    Were you having the current trouble with 1Password before you'd started traveling? I'm wondering if it's caused by pages not being fully loaded before trying to use 1Password on them. It should be helpful knowing the results from any open and fill tests you can do. Also, can you provide URLs for any pages that are requiring multiple shortcut attempts?

    I don't know for sure if 1P was acting up before I left. I want to say yes.
    As an example, I just saw this behavior again on https://login.mailchimp.com/. Often I see my google accounts as options in place of the actual site's for the first 2-3 attempts, and then Mailchimp's finally display.

  • zebdrozebdro Junior Member
    edited December 2015

    Here's another example. I just pulled up fedex.com. The first 5 renders of 1P from the default keyboard shortcut look like this.

    The sixth render looks right, like this:

    I noticed that this behavior reoccurs when I switch back to the browser window. In this case, when I went back to the window with fedex, and invoked 1P again, instead of pulling up the active logins on the first try, it took 3 attempts.

  • brentybrenty

    Team Member

    @zebdro: I have only seen this issue occasionally, and the solution has been simple in my case: restart Chrome and/or OS X. Usually just restarting Chrome works though.

    Are you keeping the browser open for an extended period of time, using many windows and tabs, or both? That seems to be what triggers it for me. It's impossible to say for certain, but I suspect this is because Chrome loads an instance of each extension for each open tab and window. Over time, as you can imagine, this will have an increasingly larger resource footprint, and it's only compounded by greater numbers of tabs and windows.

    Now, if this doesn't apply to your situation, please disregard. But I wanted to mention it in case my own experience provided any insight into yours.

  • zebdrozebdro Junior Member

    @brenty I start my Mac and chrome fresh every day, and this issue is occurring right away. I don't think your fix is helpful to my situation.

    I will add that I run multiple google profiles simultaneously. I'm not sure if that's relevant. It did not cause a problem in the past.

  • sjksjk oversoul

    Team Member

    Thanks for the additional information, @zebdro.

    This could turn out to be most relevant to the trouble you're having:

    I will add that I run multiple google profiles simultaneously. I'm not sure if that's relevant. It did not cause a problem in the past.

    We're investigating recent issues, now including yours, affecting 1Password shortcut usage with multiple active profiles in Chrome. Can you try temporarily using 1Password with only a single active profile and let us know if that makes any difference?

    From your earlier reply:

    Are you asking me to open a blank tab, shortcut 1P, and then type in a search to find the website + login I want to use? I've never done that. But if I got that right and it's helpful, let me know and I will try.

    You are correct, and it would still be helpful to know the results of testing that starting with multiple active profiles.

    We appreciate your time and patience to help us with this. Cheers!

  • Hello @zebdro,

    Can you check out version 4.5.2.BETA-2 of the 1Password Chrome Extension for us please. I believe I was looking into this problem when answering another query just earlier and as a result we pushed out this new beta just a little earlier. Please do let me know if this helps.

    ref: OPX-1094

  • zebdrozebdro Junior Member

    @littlebobbytables when I opened my extensions, it seems I am already running 4.5.2.2. That's the latest, yea?

    @sjk I think you are on the right track. When I only open one profile and visit sites, 1P seems to be behaving correctly (2 for 2 so far).

  • brentybrenty

    Team Member

    @zebdro: That's the current beta, yes. Be sure to let us know if you have any further issues!

This discussion has been closed.