Username in MFA field on Mac, works on Windows

I've set up a Login item for my BattleNet account.
Using this item on windows correctly populates and submits the form, then takes me on to the next page for MFA.
Using this item on a Mac correctly populates my data on the first page, takes me to the MFA page, then attempts to submit with my username in the MFA field.
Why is this behaving differently on Mac?

If it helps:
Browser: Firefox
Mac: El Capitan
Windows: 10
Tried creating the login item from scratch on both mac + win with no change.

1Password Version: / 5.4.1(mac)
Extension Version: Not Provided
OS Version: OSX El Capitan / Win 10
Sync Type: DropBox
Referrer: forum-search:two factor authentication field


  • Hello @joni_sykes,

    Now I don't have a BattleNet account so I'm wondering if you can help explain things in a little more detail for me please so I fully understand.

    There login sequence spans two pages, one for the username and password and then a second for a MFA code.

    1. Do you manually load the page first in your browser and then use the fill command (either ctrl + \ or ⌘\) or do you use open and fill where you click on the URL from inside the 1Password window?
    2. On the Mac are you saying that after performing this action and with no interaction on your part, 1Password is then attempting to interact with the second page automatically?

    Something strange is going on because if your answer to 2. is yes I'm genuinely surprised. We don't automatically fill any page with the exception of open and fill which is actually the concatenation of two commands (load this URL and then fill with this Login item ) but once it's submitted we shouldn't be taking any action without the express command of the user. Heck sometimes passionate users come to us saying about they don't like this hence my surprise. We'll definitely want to get to the bottom of this.

  • Hi, thanks for replying. I'm using my phone so apologies if this is brief. I haven't tested opening the page in the browser yet, I was previously referring to just double clicking the login from the 1pass application. So I think I'm saying yes to 2.
    I've just tried it again today and it's still doing it so as a work around, I've changed just the battlenet login to 'never submit' however it still puts my email in on the second page like before.
    Your description of the page order was also guessed correctly.
    Let me know if you need more info.
    Also battlenet accounts are free. Go have a dabble.
    Thanks, J.

  • Greetings @joni_sykes,

    At the first opportunity I will create a test account and I'm hoping their MFA is a TOTP that works with Google Authenticator and 1Password as I'll need to have that enabled too to accurately reproduce.

    Now I don't know if it will turn out to be a factor or not but you should only need to single click on a website field, I'm wondering if some confusion is happening because 1Password is seeing two commands to fill. That is something else I'll be able to try testing :smile:

  • The double click suggestion sounds interesting. If the app isn't guarded against one vs. two clicks that could indeed lead to some issues.
    I'm afraid the auth for battle net is not TOTP, it's a different type.
    Despite that, again the auth app is free too.
    Off the top of my head it's called battle net authenticator. It should be very easy to find due to its popularity.
    As my post mentioned, the issue is focusing on the population of fields, not the mfa itself, as I'm already aware only TOTP is supported.
    Again, let me know if I can help.

  • Greetings @joni_sykes,

    So I've had a chance to test and it isn't because you double click. Whatever the issue is it's specific to Firefox as I can reproduce there but not in Safari or Chrome - literally just Firefox. I don't have anything concrete to say just yet I'm afraid as this will require a bit of debugging to get to the bottom of it.

    I apologise for the wording regarding the MFA. What I meant was I felt confident the issue would only be observable with MFA enabled as the issue was reliant on the second page in the authentication process. I was hoping there wasn't going to be any impediment to enabling it. It would have been nice if it hadn't required another app to be downloaded but oh well :tongue:

    Until we can understand why the heck this is happening I can see a couple of possible workarounds. As I noted earlier the issue doesn't seem to happen in either Safari or Chrome on my Mac, just in Firefox so another browser would work. If I visit the login page manually and fill using the keyboard shortcut ⌘\ that also doesn't cause the issue and neither does opening the Login item from 1Password mini. The only combination at the moment that causes this is if you use open and fill from the main 1Password window and do so with Firefox as the default browser. Hopefully one of these alternatives will be acceptable just for now :smile:

    ref: OPX-1092

  • Thanks for the info. Yeah we are on the same page. I'll just keep my blizzard login not submitting by default. I'd prefer that to changing browser.
    Happy Christmas.

  • Greetings @joni_sykes,

    There is clearly an issue though so thank you for bringing this to our attention. I hope you have a wonderful holiday :smile:

This discussion has been closed.