iOS app crashing upon logging in using Dropbox

Hi, I really need your help. I am having an issue after one of the updates. My app opens fine but when I login using my master password, the app crashes and jumps back to the home screen. I'm not sure which update this happened at. I have tried deleting and reinstalling the app. I am using dropbox to sync across. I don't think it happens on icloud. I have sent multiple crash reports upon opening the new app. Thanks in advance for your help.


1Password Version: 6.1.2
Extension Version: Not Provided
OS Version: iOS 9.0.2
Sync Type: Dropbox

Comments

  • BenBen AWS Team

    Team Member
    edited December 2015

    Hi @crutili,

    Sorry to hear about the trouble, but thank you for taking the time to write in with these details.

    Were you prompted to submit crash reports when 1Password quit unexpectedly? If so, could you please tell me the device name (Settings > General > About > Name) of the device this crash happened on?

    Please try force quitting 1Password. To do so:
    1. Press the Home button two times quickly. You'll see small previews of your recently used apps.
    2. Locate 1Password
    3. Swipe up on the the 1Password app's preview to close it.

    Try re-opening 1Password after that and see if the issue is resolved. If it is, I'd like to ask you to create a Diagnostics Report from your iOS device:

    https://support.1password.com/diagnostics/ios.html

    Attach the Diagnostics Report to an email message addressed to [email protected].

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report and ensure that it is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

    Ben

  • crutilicrutili
    edited December 2015

    Yes, as I stated above, I have send multiple crash reports after the app opens up after crashing. The name of the device is "[removed at customer's request]". I have sent many reports.

    Force closing has been tried, and would not likely not be necessary after deleting and reinstalling the app. The app opens if not synced with dropbox. But once synced it works until it is closed, then upon opening again and typing in the master password it crashes every time.

    I am unable to create a diagnostic report email through the app because it is crashing upon opening.

    I use this app for business and I'm lost without it. I really need your help. Thanks

  • I didn't receive a ticket... Would you guys let me know you received this and you're working on it? thanks

  • BenBen AWS Team

    Team Member

    Hi @crutili,

    I had one of our iOS developers look up your crash logs. It appears the crash is being caused by a jailbroken exclusive modification called Virtual Home?

    Is this device jailbroken? If so you may need to undo that, or at least uninstall the Virtual Home mod.

    Thanks.

    Ben

  • Hi Ben, I have installed VirtualHome in the past but it was uninstalled a long time ago. This was working before one of the updates of 1password. I have tried installing and reinstalling VirtualHome just to check but it still crashes. I cannot restore the device at this point in time. Is there another solution? If not, is there a workaround to view my passwords on my phone? thanks chris

  • BEN! I figured it out!! I uninstalled the tweak "AlwaysQuickUnlock" and it works now!! Thank you so much for the tip on it possibly being a cydia issue. I really appreciate your help!! 1Password rocks!!!!

  • Ben, would you mind removing my name of the device from this thread please? thanks

  • BenBen AWS Team

    Team Member

    Name removed. Thanks for the update! Glad to hear that resolved the issue for you. :)

    If we can be of further assistance, please don't hesitate to contact us.

    Ben

This discussion has been closed.