Can't save username/password on login anymore

I've used 1Password(Mac) to log in to for 5 yrs. 2 weeks ago I updated to 1PW5, and noticed that now Mint no longer autofills in the UN/PW on the login page. I decided to change the PW and save as a new log-in, and still won't autofill UN/PW. I went into the main 1PW5 app and saw that the UN/PW fields are empty. Manually editing in the newly saved login in 1PW5 main app doesn't fix the problem. I tried doing the suggestion from your help page about manually saving the login, but still no success. I've had no problems with saving other website logins, but having problems with Any help would be appreciated!

1Password Version: 5.4.1
Extension Version: 4.4.4
OS Version: 10.10.5
Sync Type: DropBox
Referrer: forum-search:I can't save username/password on anymore


  • Hi @rodman54,

    I think the issue with open and fill (I assume that's what you're doing) is that after the page has loaded there is a small delay before the login form appears, I'm guessing because of JavaScript. This delay seems to be enough to put open and fill off of its stride which does attempt to fill as soon as the the browser reports that the page is loaded. To the best of my knowledge there isn't a event that we can watch for that says the page is now ready after post-loading processing by the site's JavaScript. What I did find though is that once the form has been properly created my test Login item worked, filling in both fields with no obvious issue. Do you by any chance find this too, that once the the form is fully generated you can fill, using the keyboard shortcut ⌘\ for example?

  • Thank you littlebobbytables, I forgot about the handy shortcut and then double-click on the log-in again. That's much quicker than doing the copy/paste!

  • Hi @rodman54,

    I'll have to chat to the developers to know if there is anything we can do but at least the keyboard shortcut seems to have helped a bit for you :smile:

  • edited December 2015

    I am a new user of 1Password. I am previewing it to see if I want to purchase it. So far it works with all my sites except on Macbook Air using OS X El Capitan Version 10.11.2. Chrome browser Version 47.0.2526.106 (64-bit) with the 1Password extension up to date (1Password: Password Manager and Secure Wallet I set up Mint a both through login in and changing my password and saving. And then I tried making a new manual version. I have tried the CMD / shortcut. Nothing works except copy/paste. I've used both and also Neither of these work. Please advise.

  • Hi @mbrownstone,

    Can you tell us a little more please when you say nothing works. I visited and created a new Login item just now (using our How to manually save a Login guide) and it successfully filled the two fields, showing the green ticks to the side that the site does. So is the issue that it won't fill the fields for you or that it fails to log you in when the login page is submitted? I haven't tested the latter but I see I can set up an account to test with if that's the case.

  • Thank you for the information. I erased my previously saved login from 1password. I started over with Mint. I went to and I added my username-->green check. I added my password and logged in. I got the pop-up box to save the entry. I saved it. I logged out and tried to enter the Mint site using THREE different methods. Once by clicking the browser extension and choosing the login. It gets me to the login page, but nothing is entered. Also, if I click in the boxes, I don't get an option to fill. Second way is to use the password app and select the login for mint. Again, it takes me to the login page, but nothing is entered. The third way is to navigate to the page where I would normally login and again, the password and username do not get filled in. Not sure what to do to make this work.

  • Hi @mbrownstone,

    We have had reports that what we call open and fill (clicking on the URL from inside the main 1Password window or selecting the Login item in 1Password mini where it opens a new tab) isn't working. When I first viewed the site what I found was that after the page loaded there seemed to be a certain amount of JavaScript that needed to be processed before the login fields appeared. My understanding is we can only react to the page having finished loading, we attempt to fill but the JavaScript hasn't finished meaning there is nothing ready to fill.

    What should work though is once the has loaded the keyboard shortcut ⌘\ should successfully fill the login page. So basically there are 2 ways of using a Login item. One we call open and fill or go and fill where 1Password asks the browser to open the page and once the page is loaded we try to fill. As I say, I've found this doesn't work with my understanding being this delay in the fields actually existing after the page has finished loading. The other way is is what we call Easy log in as described on the page Using a saved Login (Mac) and the keyboard shortcut ⌘\ is what is happening there.

    If you try to fill the page after it has loaded, does it work better?

This discussion has been closed.