Uninstall doesnt remove old (wrong) password from vault memory

Bit of a convoluted title but basically I installed beta 3 on my 950XL but couldn't unlock the key chain from Dropbox (historic old version password problem I read about here), so I changed the password on another device and all good.
However, I then changed the password back to what it was (on another device) and the app on my 950XL wouldn't open without the first changed password. Once open I thought ok, let's change the password back to the original here. Unfortunately something went wrong and whilst the password for my vault is fine on other devices, set to my original password, I can't open 1password on my 950XL. All I'm presented with on launching the app is the enter password screen. Reboots, uninstalls/reinstalls have no affect, it always opens on the password screen (where neither password, original or changed, work) I can't seem to clear out it's memory of the old vault, nor open a new vault.

Comments

  • Nevermind. Further reading found the op://resethard command and that worked a treat. All ok now :)

  • You are much faster to find out about op://resethard than me to share it with you! ;)

    P.S. thanks for sharing your experience with us, I'll add it to our review process, perhaps we might come to a better solution.

  • kurtdkurtd Junior Member
    edited January 2016

    I believe I'm having the same issue. I couldn't unlock my keychain from dropbox either on my 950 until I changed my master password with the desktop app. It was working fine for a few days. After that I changed it again to something else, not the original. Now only my desktop app works. Can no longer unlock the app on my phone or windows 10 PC. I ran the op://resethard but all it does is open 1password.

  • kurtdkurtd Junior Member

    Nevermind, I figured it out. I had to first set a pin on my Windows 10 PC and then run the command. It worked on PC and then I reinstalled the app on phone and that one started working as well. Here's the info if anyone needs it https://discussions.agilebits.com/discussion/53764/new-feature-in-beta-3-resetting-application-data-and-or-master-password

    This seems like a serious issue so hopefully it gets fixed soon.

  • @kurtd there was a bug in previous version - when you changed master password it used your hint as your new password. That is fixed now in Beta 5.

    op://resethard works only when you have PIN setup on your device (this can be done at Windows settings\accounts\Sign-in options\PIN).

    In case that didn't help, you can remove entry for resource op:// in Credential Manager. Just press start button on your desktop and type "credential manager", then look for the "web credentials" and for the line related to op:// resource.

  • kurtdkurtd Junior Member

    Thanks, got it working. See above post.

This discussion has been closed.