1P 5.4.1 just quit filling login fields

Hi, techies:

Mysteriously, 1P 5.4.1 suddenly quit filling fields. Running Safari 9.0.2 on El Capitan 10.11.2. No system or software changes.

Unchecked Fill In Logins on 1P toolbar icon menu. Restarted 1P and rechecked Fill In Logins. Restarted Safari. Restarted computer. Deleted extension and reinstalled. No result.

I'd very much appreciate your recommendations.

Thanks muchly,

Rich

Comments

  • BTW, this occurs on all websites.

  • TheKnackTheKnack
    edited December 2015

    I am having the same problem with Chrome 47.0.2526.106 (64-bit) on Mac. It just started in the past day or two. Restarting my computer or browser doesn't help.

  • Deja BTW, 1P does work with Chrome Version 47.0.2526.106 (64-bit)

  • Aha! Solved. JavaScript was deselected in Safari's security preferences. Odd, since I did not open that dialog box today until troubleshooting a couple of hours after the problem occurred. JavaScript . . . ugh!

  • Hi @SoThere,

    I'm glad to hear you managed to discover the cause of the extension not working for you. It's hard to say how it could have been disabled, we may never discover the cause.

    This would seem to just leave you @TheKnack.

    Can you tell us a bit more about your setup please, the following could help point us in the right direction.

    1. What version of OS X are you using?
    2. What version of 1Password are you running?
    3. What version of the 1Password extension is installed?
  • Hi, there, LBT. Thanks for the reply.

    El Capitan 10.11.2
    Safari 9.0.2
    1P 5.4.1
    1P Extension 4.5.1

    Best fishes,

    Rich

  • brentybrenty

    Team Member

    Thanks for following up! I haven't heard of Javascript spontaneously getting disabled before, but I suppose stranger things have happened with software before. Be sure to let us know if you run into any more issues! Maybe TheKnack is suffering from a similar problem.

    1. I am using OSX El Capitan with the latest updates as of today.
    2. 1password 5.4.1
    3. 1password extension 4.5.1.90

    For me, what happens most of the time is when I press CMD+\ the 1password dialog pops up like it wants me to select from several matching accounts, but the list of accounts it shows me are always Google accounts, regardless of which site I'm on. The 1password extension icon in the top right selects the right accounts for the domain I'm on and will log in if I use it, but the CMD+\ seems to choose the wrong set of accounts for the domain.

  • Hello @TheKnack,

    Do you happen to have multiple Chrome profiles with more than one open and the 1Password Chrome extension installed in each?

    If you do we are aware of a bug. We were trying to improve the user experience when it came to multiple Chrome profiles all trying to interact with 1Password mini and introduced a bug. If this sounds like your experience can you try removing the 1Password Chrome extension please and instead installing the beta version of the Chrome extension which is available at 1Password Browser Extensions (beta). You will need to install the beta version in each Chrome profile but after you've done that do you find it behaves better?

  • Yes, that was my issue. The beta will log in, but still opens the dialog showing the wrong accounts and leaves it open on top of the browser window.

  • Hello @TheKnack,

    So just to confirm, you're running the 4.5.2.2 1Password Chrome Beta Extension in all of your Chrome profiles and you're still experiencing the issue of 1Password mini incorrectly opening?

    I think I know the issue. I apologise as I sometimes forget that I run the beta as much as I do. It used to be I routinely ran the stable version so I was always testing what you as the user was. Ever since 1Password for Teams though my entire usage of 1Password is in the beta version for Teams support. The stable version of 1Password will still incorrectly open 1Password mini after a successful fill because a new extension message isn't understood. The next stable version of 1Password will resolve this. The fix is currently in the beta version and I did forget that momentarily. I don't know when the next stable will be released but with a little luck it won't be long, assuming you prefer to run the stable version of 1Password rather than the beta. I apologise for the inconvenience while we wait for 1Password to catch up.

  • I am running the 4.5.2.2 Chrome Beta extension. It seems to be flaky. I just tried logging into Ebay several times, and the first two times it left the 1Password mini open, but the next 2 times it didn't. I tried logging into support.2xu.com just now and it left the 1Password mini open showing my Google accounts after it successfully logged in. Here's a screen shot of that I took 2 minutes ago.

  • Hi @TheKnack,

    As I said, my error was forgetting that the stable version of 1Password for Mac doesn't yet understand the ignore message we had to add - it's only in the 1Password for Mac beta. The next stable version of 1Password for Mac should include the support required. When you see Login items that don't relate to the page you are on you will find that the active tab in the other profile does. In the beta version of the extension we now send an ignore message but that won't help if 1Password for Mac doesn't understand it. I will be very happy once the next stable comes out as it will hopefully resolve a number of ongoing issues :smile:

  • Do I need to manually switch back to the stable version of the extension once the next version comes out?

  • Greetings @TheKnack,

    You would yes and that applies equally to both the extension and the main application. You may decide that for ease going forward that using the stable release is less of an inconvenience than using betas for a period of time if you intend to revert back to the stables at the first opportunity. As long as my awful memory doesn't work against me I could try remembering to post here when we have new stables of both but I apologise in advance if I do forget as I've seen things flit out of my memory 30 minutes after thinking it too.

    At least with Chrome because the extension betas are signed and distributed through the same system it means they get updated as new betas come out just like with stable extensions. I would say though that for both the extension and the application the most reliable way of reverting to the stable version would essentially be the same. Remove the beta completely, make sure there nothing is potentially cached and then download the stable version.

This discussion has been closed.