Knox APP will not load.

dreukemadreukema Junior Member

I tried several things mentioned in previous posts with this topic, but so far, none have worked.
iMac (27-inch, Late 2009), 2.8 GHz Intel Core i7, 16 GB 1067 MHz DDR3, ATI Radeon HD 4850 512 MB.
I can double click on an existing SparseBundle and it will mount and I can access it. But Knox itself does not load so I cannot create any new bundles. I have deleted the app several times including with CleanMyMac 3. Restarted, re-downloaded Knox, Reinstalled and it still will not load. It does not show up in Activity Monitor.

Can you Help?


  • Hello @dreukema I’m sorry to hear about the recent trouble loading Knox. Just to clarify, if you double click the Knox vault, you are prompted to enter your Password but do not see the Knox icon in either your Menu Bar or Dock to make further changes?

    If you launch Knox directly from your Applications folder, and not via the vault itself, do you see the Knox icon in your Menu Bar or Dock?

    Which version of Mac OS X are you running on your iMac?

  • Hi, I tried a couple of different things including freeing up a fair amount of space on my hard drive. At this point, everything is back to normal and Knox is working fine.

    Sorry to have bothered you but thanks for your attention.

  • Andrew_AGAndrew_AG

    Team Member

    No bother at all. We're just glad to hear it's working okay now. Thanks for the follow up.

This discussion has been closed.