Fill not finding matching logins (Android M)

1Password is currently failing to find any fill matches. I've tried a variety that I know do fill correctly on the mac (and iOS extension), but in Android I get the 'No matching login was found ..' response. This is also the case for filling in apps. I have the custom keyboard and accessibility for 1password enabled.

A caveat though is that I've recently installed Android M developer preview. I can't say for sure that this caused the issue, as I haven't previously been using the fill feature much (I have tended just to copy/paste out of habit). I'm not expecting 1Password to support M yet of course. Just raising it as a possible issue.


1Password Version: 4.5b7
Extension Version: Not Provided
OS Version: Android M developer preview
Sync Type: Wifi (w/Mac)

Comments

  • periperi

    Team Member

    Hey @crisbennett. Thanks for contacting us about this issue. :)

    So far, we haven't been able to reproduce this issue on our devices with Android M. The accessibility service and custom keyboard seem to be working fine.

    That said, I'd like you to please toggle the 1Password accessibility service off, reboot your device, and then toggle the service back on. If 1Password continues to fail to detect logins, would you be willing to update to Android M, Developer Preview 2, which came out yesterday?

    One other thing--have you tried this with multiple apps, or just for one or two? You mentioned that you've tried with a variety of websites, can you confirm that the URLs you have saved for those sites match the URLs of the sites you're filling on?

    Let me know what you find out! Thanks!

  • @peri Thanks for your reply.

    I've just tried the toggling and reboot, but no go. Same issue. I will install Android M DP2, but I'll be waiting for the OTA update, which should arrive over the next few days. I'll let you know if it makes any difference.

    I've tried some logins with a few apps, including where possible, the same login in both a native app and in Chrome. In all cases, yes, the URLs matched (and are ones I get 1Password to fill automatically in Safari on the mac).

  • periperi

    Team Member

    Hey @crisbennett. Thanks for the update.

    Please do update when you have a chance, and then let us know if the keyboard issue persists. If so, I'd like to ask you to create a Diagnostics Report from your Android device:
    https://support.1password.com/diagnostics/android.html

    Then attach the entire file to an email to us: [email protected]

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    A short note here once you've sent the Report in will help us to keep an eye out for it. :)

    Once we see the report we should be able to better assist you. Thanks in advance!

  • OK, I updated to preview 2 this morning, and the issue's still the same.

    I've sent in a Diagnostics Report.

  • saadsaad

    Team Member
    edited July 2015

    Thanks for sending us the diagnostic report. We will take a look through it and let you know what we find out! :)

    ref: KTG-85231-381

  • Is the 1Password keyboard supposed to be finding logins by now? It never has for me, so I leave it disabled most of the time. Periodically I try it again, which I did again today. It still doesn't appear to do anything (the 1Password button on the keyboard is greyed/disabled).

  • OK this is odd. I have 2 Android devices, a 2013 Nexus 7 and a Nexus 5, both running Marshmallow. Both have 1password 4.5.3b2, with keyboard filling enabled (and automatic filling off). Both are syncd over wifi to 1Password on a Mac. I've just tried both on the same web site login in Chrome. It works on the Nexus 5, but not the 7.

  • Sorry, forget this. The Nexus 5 was different in one respect, 'Automatic filling' was turned on in addition to the 1P keyboard (the Nexus 7 only had the latter). I turned both on and it now works.

    The one thing I'm not clear on is why there are two different settings: if just turning on the 1Password keyboard doesn't enable it to fill, why not just have 1 setting?

  • periperi

    Team Member

    Thanks for the update, @crisbennett. You do indeed need to have the accessibility service turned on for automatic filling, as that allows 1Password to detect URLs. You can fill manually with just the keyboard enabled, but 1Password won't be able to detect and fill for you automatically.

    The accessibility service uses more resources, which is why we leave it up to you to enable/disable. Some users may be fine with manual filling using the keyboard, so might not need the accessibility service as well. You can find a little more info about that here:
    https://support.1password.com/guides/android/filling.html

    Let us know if you have further questions. Thanks!

  • Thanks.

    One comment I'd make is that the distinction between the automatic and manual filling methods is fairly undiscoverable (well, I didn't discover it for the last 6 months, and have been manually copying/pasting usernames and passwords).

    In particular, with automatic filling 'off', so the 1Password button on the keyboard is greyed out and unresponsive to a single tap, it just looks like it isn't working (or can't match the context to a login). It didn't occur to me until reading the link you've provided that there was a long press available on that button!

    I'd suggest making this clearer somehow. I don't know if there's something you can do that might make this more apparent on the keyboard. If not, perhaps the wording on the Settings -> Filling screen can be amended to explain what manual filling is (ie. that it requires a long press on the apparently disabled button).

  • saadsaad

    Team Member
    edited January 2016

    I’m really sad to hear that. Although it’s an optional feature, automatic filling is really nice to have.

    I passed on your feedback to the team. We will look into improving the user experience with the filling keyboard. Thanks.

    ref: OPA-750

This discussion has been closed.