Buymeapie login issue: password not filled + unclear how to create a 1P bookmarklet for that site

  1. not sure how to get auto fill working on this site: http://buymeapie.com/ Saved username and PW. But when auto-filling (via keyboard shortcut) only username gets filled and PW remains empty.

  2. don't know how to create a 1P bookmarklet for this site (that auto-logs me in, whenever opening that bookmark link)


1Password Version: 6.0.1
Extension Version: 4.5.3
OS Version: 10.11.3
Sync Type: -

Comments

  • MrCMrC Community Moderator
    edited January 2016

    Hi @LosInvalidos ,

    There is a discussion about this matter that mentions which web form fields you need filled.

    This attached screenshot shows what works for me. I had to manually set the values in those form fill fields, which are captured when you save the new login.

  • LosInvalidosLosInvalidos Junior Member

    Great that worked. I thought I had tried that already but obviously did something wrong. It's working now. Thanks for helping out! Much appreciated. Case closed.

    Have a great day @MrC .

  • Hello @LosInvalidos,

    I hope you don't mind but as your query relates to filling I've moved it over to our Saving and Filling in Browsers section of our forums.

    Can I ask, did you create the Login item from inside 1Password or from inside your browser? In attempting to test this I created a Login item from inside the browser using the steps in How to manually save a Login. I found this would fill both the username and "password" field and given what was being stored I suspect you created your Login item from inside the 1Password window. The reason I suspect this is if if you have a Login item with a password and we don't know what the page looks like we will only fill the password into an input field of type password. This site though has everything showing in clear text - there are no password fields. This is also why even though my test Login item fills it doesn't show the username and password fields in the visible section by default (but it does fill).

    I also don't believe you'll be able to create a 1ClickBookmark for this site. On page load the form isn't visible and isn't until you click the Log in link in the upper right hand corner. Once the form is visible we can fill but not before. If there was a URL that when loaded displayed the login form then we could generate a 1ClickBookmark.

    So I believe you should be able to create a working Login item (and we can help make it look nicer after you confirm it fills) but a 1ClickBookmark won't work here I'm afraid.

  • LosInvalidosLosInvalidos Junior Member

    hey @littlebobbytables
    you are right. I first created the login from within 1P. As that didn't work, I tried the browser and as I was trying to indicate in my previous reply to MrC, I thought I had tried this and that wouldn't work as well. It obviously does now. So all is fine and solved.

  • Hello @LosInvalidos,

    Sorry, I started my reply to you much earlier and wasn't notified there had been posts in between after getting badly sidetracked. If I caused any confusion that's completely on me. We're happy to hear it works now. If you have any other sites that you're having troubles with please do let us know.

This discussion has been closed.