Trouble filling on US Bank site

This discussion was created from comments split from: 1password inserts username into password slot.


  • emelumemelum Junior Member

    I have the same problem with my desktop iMac. I have to click log in on the username page. On the password page, if I go to the menu bar 1PW for US Bank it populates the password field with the user name.

    I tried doing a new login as suggested in other posts but it just put "temporary access" in the username field. Very confusing.

  • Greetings @emelum,

    I think to better help you we'll need a bit of information so we can understand your setup :smile:

    1. What version of 1Password are you running?
    2. What is your preferred browser and the version of that browser?
    3. What version of the 1Password extension is installed?
    4. What is the URL for the page you are having trouble with?

    I understand if you're unwilling to supply the URL and if it's a multi-page login for a bank it might be hard to test anyway unless one of the team happens to also be a customer of theirs. Saying that sometimes we catch a break and somebody here does use the same bank and we're able to be more confident in what we suggest.
    Once we hear back from you we'll have an idea of where to start :smile:

  • I am having the same problem. US Bank has the username and password fields on separate screens. 1Password attempts to fill the username in the password field (second screen).

  • Greetings @attrapereves,

    I would like to ask you the same questions as in the post above yours. I'm not US based myself so I don't know the US banks like you will. The answers to those questions though will help me understand your setup a bit better and then I can start to investigate :smile:

  • The problem occurs with the latest stable version of 1Password on OS X and Windows in Safari (OS X only), and Chrome.

    It can be tested by going to and creating a fake Login entry in your 1Password vault. I used "testing" as the username and "password" as the password. On both the username and password fields, 1Password attempts to use the "testing" username.

  • littlebobbytableslittlebobbytables

    Team Member
    edited February 2016

    Hi @attrapereves,

    Thank you for the username. That bit was key to ever seeing the second page as any attempt I've made so far has been blocked for being an invalid username. Having taken a peek can you try the following for me please.

    1. Manually enter your real username so you reach the password page.
    2. Manually enter your password and then before submitting, use the steps in our How to manually save a Login guide.
    3. In the freshly created Login item edit it and click on the button show web form details. In there we will need to change the field identified as the username from the tempAccessCode field near the bottom to the personalId field at the top. To help illustrate this see the image at the bottom of this post. Basically we want the silhouette of the person against the personalId field in the web form details section.

    If you attempt to fill with this new Login item does it work any better?

    Now to why it's causing problems. The U.S. Bank's login form is actually using a text field for the password and then using JavaScript to hide the characters. When 1Password has to guess when filling a field it will only ever attempt to fill your password into a password field as that's almost always what is used. As they've tried to do something differently it's confusing 1Password hence what you're seeing. By saving a Login item from the second page we capture enough of the page so that 1Password knows that even though it isn't a field of type password that this field should contain your password.

    Now what I can't do is say what happens once the Log In button is clicked because I don't have an account. Do you find the above allows you to log in?

    This post was updated 07 Feb '16 after realising the tempAccessCode is irrelevant.

  • emelumemelum Junior Member

    Sorry for the delay responding.

    Password Version 6.0.1
    Safari Browser 9.0.3
    Password Extension 4.4.3

    I haven't reviewed the new comments yet.

  • Hi @emelum,

    Thanks for the information. Once you get a chance (life can be busy at times) can you see if the post I wrote just above your one here helps at all for you. I'd love to know if it allows you to create a working Login item :smile:

  • emelumemelum Junior Member

    That did not work. The only deviation from the instructions, I think, was that I selected "Update Existing"

    When I try to log in, 1Password first takes me to the log in screen. My username is partially filled in as eric****. (I wonder if this is being filled in by Safari's automatic login). I click log in which takes me to the passwords screen. Then I go to the 1Password menu icon and select US Bank, but rather than filling in my password as it used to do, it fills in my username and US bank sends me a login error message.

    I can log in if I go back to the 1Password app, copy the password, paste in into the password box, and then log in.

  • Hi @emelum,

    The option to update an existing Login item doesn't currently touch the contents of the web form details in a Login item, it only updates the two visible fields at the top of the Login item, username and password. To be honest I only recently learned that it was willing to update the username part, something I'm not entirely convinced of myself. Anyway, the key part is making sure the Login item has a correct web form details section otherwise when it sees this "password" field, which is really just a plain text field, it will want to enter your username because in most cases a text field is your username, and the password field is for passwords. It genuinely is uncommon to see a text field being used in this way.

    Can you see if there is any change if you create a brand new Login item please. Due to the way update existing currently works it is possible for it not to help here.

  • emelumemelum Junior Member

    Web details were ok.
    No luck with creating a new login item.
    It still puts my username into the password field.
    The interesting thing is that it worked in previous versions of 1P.
    Guess I'll go back to the copy paste plan. You might forward this to the team as a bug.

  • Hello @emelum,

    The only problem with reporting it as a bug is I when I follow the steps in my earlier post (which I revised today after realising both 1Password and I had misidentified the real field that holds the username) I can only get 1Password to fill my password into the password field. Unless we can figure out why this isn't working for you it will be very hard to pin down what this bug is.

    Maybe it's something we changed in a more recent version of the extension and I haven't realised it's having an effect here. You said you are using version 4.4.3 of the 1Password Safari Extension. Can you try the following please.

    1. Uninstall the 4.4.3 version of the 1Password Safari Extension.
    2. Restart Safari (to avoid any possible caching issues).
    3. Install a fresh copy of the 1Password Safari Extension using this link for 1Password in Apple's Safari Extension Gallery. This will install version 4.5.2.

    I would be interested in knowing if:

    1. The image I added to my earlier post is what the new Login item looked like for you.
    2. Does using the newer version of the extension in Safari make any difference?
This discussion has been closed.