Don't hide desktop view when entering the master password

Whenever I want to unlock the master keychain, the desktop is hidden and only shows the window with the field to enter my password. I can just click "X" and return to the normal application to enter the password, but I'd have to do this every them when I want to unlock the master keychain.

Is there an option to not hide the desktop and simply input the password into the main window of the application?


1Password Version: 4.6.0.598
Extension Version: 4.5.3.90
OS Version: Windows 10
Sync Type: NAS Folder

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Macusercom,

    You're using the Unlock on Secure Desktop feature, no other programs can run on this isolated desktop which works against keyloggers from listening in. This is why you only see the unlock dialog and nothing else.

    When you clicked on 'x', you're cancelling the Secure Desktop and returning to the regular desktop to unlock the program without the additional protections.

    If you do not want to use this, disable the Unlock on Secure Desktop option in the Browsers setting. To do this, open the main 1Password program, unlock, go to the File Menu > Preferences > Browsers and uncheck the box next to Unlock on Secure Desktop.

    For the main program, don't press the Unlock on Secure Desktop if you don't want to use it.

  • edited February 2016

    Thank you very much @MikeT! I knew I've seen this option before, but I never tried to find it under "Browsers". I didn't quite know that the Secure Desktop actually helps against keyloggers. If it's true what you say, I think I'll just leave it as it is.

    Thanks for your help and your quick response! :)

  • MikeTMikeT Agile Samurai

    Team Member
    edited February 2016

    You're welcome.

    There might be a way to improve the look of the secure desktop by taking a screenshot of the regular desktop and use it as a wallpaper for the secure desktop. By doing this, it would look like it is on top of your desktop but you won't be able to interact with the desktop. It is on our list to try in the future.

This discussion has been closed.