App keeps logging out when losing focus

Hi, installed 30 day trial for Android, running current Droid version on HTC M8. After logging in to 1password - If you go to any other browser screen and try to go back to the app, you have to log in again - that app exits itself. I had to log in 6 times in 1.5 minutes. So really cannot use the app currently. Can't get in to set settings so it does not close immediately when focus on itself is lost to another page. Thanks for any advice. Sync worked well. Nice app, have been using trial version in Windows and will soon purchase license. Great effort!


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: kb:create-multi-page-login, kb-search:android how to use, ug:android/log-in-to-websites, kb-search:android how to use

Comments

  • Version was downloaded today from your site, the Droid version is 4.42. Thank you.

  • periperi

    Team Member

    Hi @oxygen6. Thanks for getting in touch with us today!

    If Lock on exit is set to ON, and if you have not enabled a PIN code or fingeprint, 1Password will indeed lock every time you switch apps. You'll need to launch 1Password on Android and tap Settings > Security, and either set Lock on exit OFF, or enable a PIN code which you'll be asked for instead of the Master Password.

    That said, you mentioned that you can't get into the Settings menu. What happens when you tap to open it?

  • Hi, well - as soon as I log in, the app does not appear, instead the phone screen switches to Chrome browser at Amazon.com where I am logged in there. I cannot get into 1password after it decrypts my password entered, the green circle shows success but the app then vanishes, and I am sent to a current Chrome browser tab, so I cannot get into the app at all. When I select 1password from the recently used apps access bottom control on the phone (the one that shows all recently used apps) 1password wants me to log in again when it gets focus. So I can't log in at all, it sends me to a chrome browser page tab. I think it worked on my phone a few times, I was able to get in. But now can't get in at all. Thanks...

  • dtearedteare Agile Founder

    Team Member

    Thanks for the update @oxygen6. It sounds like you are launching 1Password using the 1Password keyboard while within Chrome. Is this correct?

    If so, I had a similar issue happen to me yesterday while filling my Google password while making a purchase. Each time I launched 1Password from the 1Password Keyboard, it would open, allow me to unlock, and then it would crash and return me to the home screen. I reported this issue and the team is looking into it.

    Can you try launching 1Password from your home screen instead of the keyboard? You should be able to launch it successfully from there. Once launched, you can change your locking settings like Peri was talking about.

    With that said, even with more relaxed locking settings, it is expected that you will unlock after 1Password crashes, regardless of the settings. So, we'll still need to track down why this is crashing and fix it.

    I hope that helps. Please let us know.

This discussion has been closed.