Touch ID Prompt Not Showing Up in 640010

iPhone 6s
After updating to today's TestFlight build, Touch ID prompt never shows up. I am forced to enter my Master Password every time.


1Password Version: 6.4 (640010)
Extension Version: Not Provided
OS Version: iOS 9.3.1
Sync Type: Families

Comments

  • After 6.4 (640010) update:
    iPhone 6S
    iPad mini 4
    Touch ID prompt works as described.

  • MrRooniMrRooni

    Team Member

    Good morning @tommyang. Thanks for your report. I'm sorry that you're seeing trouble with Touch ID. I'd like to ask you to create a Diagnostics Report from your iOS device:

    Sending Diagnostics Reports (iOS)

    Attach the Diagnostics Report(s) to an email message addressed to [email protected].

    Please do not post your Diagnostics Report(s) in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report(s) in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report(s) and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

  • MrRooniMrRooni

    Team Member

    Thanks for the update, @iamecho. Glad things are working properly for you.

  • FooliganFooligan
    edited April 2016

    I am also experiencing some inconsistency with touch ID. I am able to reproduce the odd behavior with these steps:

    1. Unlock 1P, either through the Safari extension or through the main app.
    2. Open Safari.
    3. Open the 1P extension.
    4. Change to a non-primary vault (in this case it is a vault where I have read-only access and the contents are disabled when All Vaults is selected).
    5. Close the extension.
    6. I then have to re-enter my master password through the extension and main app. No option to unlock with touch ID.

    EDIT: I just tested it using several other vaults as well in the Safari extension. The only time that it does not auto-lock requiring the master password is if All Vaults is selected.

  • Hi, @MrRooni, I sent in the diagnostics: #HRK-12371-136. I notice that this happens when I quit the app by double-clicking home button and swipe up. This behavior is not the same as in 6.3.1.

  • MrRooniMrRooni

    Team Member

    Thanks for all the info, folks. We were able to reproduce the problem and get a fix in place for it. You should see a new Release Candidate build out shortly that should behave properly. Of course if it does not please let me know. Thanks!

  • @MrRooni

    I can confirm that 640011 has fixed the behavior that I described above. Thanks for the quick update!

  • MrRooniMrRooni

    Team Member

    Cheers @Fooligan, thanks for the confirmation!

This discussion has been closed.