1Password cannot fill in both username and password at FuelRewards.com

The following Sign In page is not properly filled by 1Password. Fills in username fine, then appears to skip over password. If I put the cursor in the Password field and select the login a second time, it fills in the password.


1Password Version: 6.2.1
Extension Version: 4.5.5
OS Version: OS X 10.10.5
Sync Type: Dropbox
Referrer: forum-search:fuel rewards


  • Hi @jbthomson2,

    Based on your description I felt confident I knew what the site was doing and I was correct. What they do is they alter the password field when you click on it and what they're doing is they're altering it from a text field to a password field. If the extension tells 1Password that it sees two text fields 1Password won't attempt to fill the password into that field which you probably agree doesn't sound like a totally daft precaution. What puzzles me though is we do have a check for this type of behaviour in the extension as it's not that uncommon to see. So we still make a note that it starts of life as a text field but we also factor in that it's a password field when clicked on and so is probably a safe bet for being the right place to fill.

    As such my initial attempts all succeed, 1Password fills correctly without requiring focus to be on the password field. I don't remember us making any changes to this area in version 4.5.6 of the 1Password Browser Extension but my memory can be shocking at times. It might be worth getting your browser to update the extension to version 4.5.6 though just to see if that makes any difference. If you find your browser resists you may need to uninstall the extension, restart the browser and then install a fresh copy from our 1Password Browser Extensions. That should get you onto version 4.5.6.

    If you're still having problems we'll definitely investigate as everything here seems to indicate we should work. Something that might be worth checking out is if other extensions may be having some sort of effect. Do you see the same undesirable filling behaviour if you try disabling other extensions and reload the page?

  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    I have two valid Logins saved for this site that both work properly for me using the latest 6.3 betas. Looking at the list of changes, it seems the change that @littlebobbytables is mentioning will be available for you in 6.3, which is in its last steps toward being released. Once it's out, please let us know if you still have this trouble.

    Jamie Phelps
    Code Wrangler @ AgileBits

  • jbthomson2jbthomson2 Junior Member

    Updating to the extension version 4.5.6 seems to have done the trick. Worked first time I tried it. Thank you.

  • That's great to hear @jbthomson2. Please do let us know if you run into any other issues and especially if the annoyance with this site :smile:

This discussion has been closed.