Android client with 1P Teams - OCR and folders?

Hi - we've signed up for 1P teams, and a number of our team members with Android phones are all hitting the problem that the OCR to get account details on their phones doesn't seem to work?

When they have manually typed in the details, they all seem to have a team account, but the folders they are assigned to don't appear in their android apps?

Are these known problems?

Our IOS users aren't having any problems - its works great.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • Is no-one else having problems with Teams and the Android app? I'm wondering if its just all the guys on my team?

    The Scan OCR functionality to join a team on the Android client is obviously broken on a variety of phones (now 4 members of my team have all had to painfully type in the access-code).

    Having got through this problem, I did spot that for a couple of them I had forgotten to add them to a "dev group" and this explained why they didn't see any vaults (even in the mac client), however when I added them to that group - on the mac client things then looked correct and they could see logins, however on the Android clients it didn't refresh? Is this another broken feature?


  • The scan QR code worked well for me on a Nexus 5x. I'm sure Agile Bits would appreciate knowing about any devices where it's not working as intended.

    After I added a new vault from the web interface, I moved several items over to it using the Mac app. When I next started the Android app, it showed up in the "vault picker" on Android, but when I chose that new vault the rest of the screen was blank (no categories, no all items, etc.) I switched away to a couple of other screens within 1PW, then when I switched back to my new vault all the logins appeared as they should have.

    I didn't have a chance to try this (because my logins had showed up by the time I tapped on the vault a second time), but the next thing I would have tried is a pull down to refresh. You may want to give that a try and see if that helps.

  • periperi

    Team Member

    Hi @365nice. Thanks for getting in touch with us. :)

    Like EnerJi, I have no problem adding accounts using the QR scanner on Android, and I haven't heard other reports of this. Can you let me know what devices your teammates are using, as well as what version(s) of Android? Is each team member scanning the QR code from their own Emergency Kit?

    That said, can you clarify what happens after they are able to add their accounts manually? Are their accounts listed but their Teams vaults are empty?

  • Hi - I will try and get the phone and os details from them. I have found a 4th team member who made it work, so it may be an os version problem (by the way on iOS it scans amazingly quickl, you barely have to pint at it).

    When they do typin the code and login, they get an empty vault problem. Well actually all they see is a personal vault.

    This was initially me forgetting to add them to some groups (there is a seowrate post on this - would be good to setup sone initial defaults). However when I added them to some groups, the vaults didn't appear like they do on OS X or iOS. They have to delete the team membership and do it all again (which is tedious).

    For one guy who I did add to some groups before he did this, it seemed to work, but I haven't tried adding a new vault and seeing if it refreshes properly (or if this is an initial signup thing)


  • brentybrenty

    Team Member

    @365nice, @peri: I wonder if it's a camera issue.

    I've had trouble with 1Password for Android scanning the QR codes for my 1Password Teams/Families accounts...because my device has a really terrible camera. :(

    However, I found that enlarging the QR code (it was displayed in the browser on my computer) made it readable without fail. Does that help any of your teammates, 365nice?

    Also, I'm sorry about the difficulties your team has been having with vault permissions not updating in the app. We've improved this in the latest version, but it may be necessary to re-add the 1Password Account in the app after updating. Be sure to let us know if you're still having trouble with this!

  • I'll ask one of them to try that (although now they are members it's a bit of a moot point - it just wasn't the initial user experience I was looking for as I want people to get comfortable using managed passwords).

    Saying this, I watched one of them do it, and it was a decent sized qr code on a retina mac screen and we were all surprised it didn't work. They all say they've scanned qr's with other apps without issue - I think getting OS versions and phone models might help.


  • I am one of Tim's team that is having a problem with the QR code.
    My phone is a Galaxy A3 with android 5.0.2

    The problem is that the inbuilt QR scanner fails to recognise the QR code (although a distinct app can read it).

  • periperi

    Team Member
    edited May 2016

    Thanks for the update @fawkes_team and @365nice! I'm curious as to the other devices having this problem. I've tested on a Nexus 5X and Samsung Galaxy S5 and was able to add an account easily with the QR scanner.

    That said, the QR scanner relies on Play Store services so it's important that this is up-to-date. Can you please verify that you have the latest version of Play Store services installed? Also, you mentioned scanning from the Mac screen. Can you try printing out your Emergency Kit and scanning from there?

    As to the issue with items not syncing, we recently discovered a problem where 1Password for Android does not handle certain account updates correctly and causes sync to fail. This is because of the app's inability to update credentials that have changed on the server. We will be fixing this in an upcoming update.

    The good news is that you can work around this problem very easily by removing and re-adding your 1Password account. This can be done by going into 1Password's Settings > Accounts > [Your Team Name] and then tap on Remove Account. Once you have added your account again, sync should work correctly.

    Let us know how that goes!

This discussion has been closed.