iCloud sign-in required in Vivaldi and Brave

An annoying thing I'm noticing is that I repeatedly have to sign-in to my iCloud account in order for 1P to work with the Vivaldi and Brave browsers. Despite checking the box on "remember my decision," it pops right up the next time. THEN, the iCloud sign-in page changes to "synching" and shows the little arrow wheel spinning indefinitely until the tab is closed, which appears to make no difference to the actual sign-in to the web page that initiated this iCloud sign-in silliness.


1Password Version: 6.3
Extension Version: Not Provided
OS Version: 10.11.5
Sync Type: iCloud

Comments

  • brentybrenty

    Team Member

    @pdboyer: Thanks for reaching out. I'm sorry you're having this issue. In fact, it isn't at all related to your browser preference as far as we can tell. It's bitten me as well the past couple days, and we're pursuing this with Apple since it isn't clear why iCloud is requiring all of us to re-authenticate repeatedly!

    Please do the following, as it may resolve the issue for you:

    1. Open 1Password Preferences > Sync
    2. Disable iCloud for your Primary vault but DO NOT tell it to delete the data
    3. Re-enable iCloud syncing and login to your iCloud account

    Others have reported that this has resolved the repeated prompts for them. Please let me know if that helps! :)

  • pdboyerpdboyer Junior Member

    Hey guys, success!! No demand for iCloud login today after downloading latest beta today. Great going!!

  • brentybrenty

    Team Member

    Excellent! Thanks for the update. I haven't seen it either myself today. Hopefully we've heard the end of it! :)

This discussion has been closed.