Autounlock not working in Safari 5.0 on Snow Leopard

I'm having the same problem with Autounlock as per previous posts but note that the questions and responses seem to refer to users running Safari 5.1 or Lion.

But I have the same problem with current software. My system comprises an iMac with OSX Snow Leopard 10.6.8 (fully up to date), Safari Version 5.0.5 (6533.21.1), and 1Password Version 3.6.1 (build 31057). Since my upgrade to 3.6.1, if I unlock 1Password, then I still have to unlock it again when I first use Safari (but only the once until 1Password locks or Safari is closed as per Khad's most recent reply).

I didn't have this problem with Safari 5.0.5 before I updated 1Password yesterday............ No problem if it's a known issue with this most recent upgrade and "production" versions of Safari, OSX, etc., but I wanted to check that I hadn't missed something (I've checked my preferences and they all seem to be in order.....).

Thanks in advance for any help, Mike

Comments

  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, Mike! I'm sorry that you are having this trouble. :(

    I split your post from the previous thread since the Safari 5.1 extension is completely different code, so your issue will be unrelated.

    Can you please ensure that "Disable automatic unlock for all applications" is unchecked in 1Password (Preferences > Security)?

    20110704-deu1s77n42ub6k4ft7h6yr9fkb.jpg

    Please let me know. Thanks!
  • edited July 2011
    I am having the exact same problem. I have double checked my preference settings and the "Disable Unlock..." is not checked.

    Ideas?
  • Khad, thanks for your post - I was about to send you a post saying that my preferences settings were correct but decided to do an additional check first........ So, I shut down 1Password and also "reset" Safari (deleted history, cache, downloads, cookies and saved names/passwords) and then closed Safari. Also, before quitting 1Password I checked the two "Disable automatic unlock....." boxes and then unchecked them after I restarted 1Password (this was to "force" 1Password to update the preferences file). After restarting Safari and 1Password, the system now works as expected..............

    I'm pretty sure that 1Password was restarted as part of the update to Version 3.6.1 (build 31057) but I wouldn't have quit and restarted Safari. In previous updates to 1Password this hasn't been a problem, but this time it would seem that the update wasn't quite as "clean" a break with Safari as it might have been.

    So, I don't know if it was closing 1Password, fiddling with the preferences, closing Safari, or resetting the Safari cache/etc. that did the trick - but one of them did! Of course, I should have taken each action one at a time to isolate exactly where the problem was, but that's hindsight for you.........

    So, thanks for taking the time to reply and help, very best wishes, Mike
  • I tried doing the same thing, but I still get the same problem.
  • khadkhad Social Choreographer

    Team Member
    Zaxcom, I just want to confirm which versions of Mac OS X, 1Password, and Safari you are using before we go too far. There is a known issue with autounlock in the Safari 5.1 extension. Can you please let me know?

    Thanks!
This discussion has been closed.