Transfer / Misc / Requests

edited June 2016 in Business and Teams

Hi guys,

it´s been a while since I´ve been around.

First of all, thank you very much for listening to us customers and implementing the stuff that we request. A few things I noticed where the prompt when deleting the trash and the extra billing mail address. I´m sure there´s more. Super. :)

Second, I´ve got a major problem ... or, not so major, but it sure is a PITA!

1) Moving items from one vault to another is not possible in the browser view (latest Chrome on W10). As such, the browser still doesn´t have as many features as the App, if I´m not mistaken? Or, to put it differently: Both the browser and the App have features the other doesn´t?

2) This lead to me using the App (W10, latest version) so that I can transfer a couple of dozen items. Originally, we had one vault, but I decided to split it up, but then I noticed that it was better with the items together and tag separation, so I decided to put them all back together ... Ergo I selected the items from the vault, selected the destination vault, and presto the items were copied - not moved, which is still annoying. Cf. Feature Request b).
The vaults were A, B and C. I first moved A into B, but then decided to put them back into C, since we weren´t really talking about a large number. And since the users were all the same ... So C is now the current vault. The vaults A and B are marked with an X and are awaiting deletion.

Digression: I just noticed that a new update - v.6 - was released, but this doesn´t change anything, I think. I´ll expand on this in Feature Request a).

3) So there was me all happy. 1Password working wonderfully, and everything in working order. :)

4) Back to the browser the rude awakening. And now I´m not sure if this is my fault. I haven´t been following the forum / blogs as attentively as I usually do, so I might have missed something ...

Anyway, back in the browser, I open the vault, and all of the items are there. The tags, too. Great. Since I usually use the search function at the top, I didn´t notice anything strange or peculiar. Until I decided to use the tags at the left. A picture says more than a thousand words:

And you know how the selected tag goes dark grey? It doesn´t at the picture above. And it´s definitely selected.


Jeez, the pictures are big.

Again, this is only in the browser. The tags work fine in the W10 App.

How do I go about solving this? I almost always use the browser, but this is highly annoying!

Feature Requests:
a) An update button, that automatically updates the programm. Even if that means that I have to type in all of the login info again. But searching in the app store (no update showed up there, either) for new versions is time consuming and, IMO, shouldn´t be expected. I´m sure there a many out there, who do 90+ hours a week and just don´t have the time!

b) When moving an item
b1) The item is actually moved and not copied to the destination folder. I don´t want to have to delete the old one. I think it should be done automatically.
b2) The items history is moved with it. I didn´t notice this before moving (I did a test move), but now all of the items have the same inception date.

c) How far are we on the browser implementation? Yeah, I know, I´ll probably get "WIP", but hey, I gotta ask. ;)

All the best,
Lorenz

Edit finished. Please proceed.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • nmottnmott 1Password Alumni
    edited June 2016

    Whew! This is a big post. Let me take things one at a time.

    Moving items from one vault to another is not possible in the browser view (latest Chrome on W10). As such, the browser still doesn´t have as many features as the App, if I´m not mistaken? Or, to put it differently: Both the browser and the App have features the other doesn´t?

    You can move items between vaults on 1Password.com by using the share icon (right next to the favorites star) and selecting move/copy.

    The vaults were A, B and C. I first moved A into B, but then decided to put them back into C, since we weren´t really talking about a large number. And since the users were all the same ... So C is now the current vault. The vaults A and B are marked with an X and are awaiting deletion.

    That's a known problem that we're hoping to improve as we get closer to moving 1Password 6 for Windows out of beta.

    So there was me all happy. 1Password working wonderfully, and everything in working order.

    :+1: :)

    How do I go about solving this? I almost always use the browser, but this is highly annoying!

    I can see how that would be frustrating. I wasn't able to recreate this on my end, though. Do you mind testing to see if this is the case with all tags? And does it affect tags added in the browser or in the app? Let's figure out what's going on here :)

    An update button, that automatically updates the programm. Even if that means that I have to type in all of the login info again. But searching in the app store (no update showed up there, either) for new versions is time consuming and, IMO, shouldn´t be expected. I´m sure there a many out there, who do 90+ hours a week and just don´t have the time!

    I don't know if this is planned for the Windows Store version of 1Password. But you might be interested in the version of 1Password 6 that we distribute ourselves. It's still in beta, but it might be worth checking out if you want to have easier updates.

    b1) The item is actually moved and not copied to the destination folder. I don´t want to have to delete the old one. I think it should be done automatically.

    That is the current behavior in all but the beta versions of 1Password for Windows.

    b2) The items history is moved with it. I didn´t notice this before moving (I did a test move), but now all of the items have the same inception date.

    That should be the case with a "move" versus a "copy," which is what 1Password for Windows does now.

    How far are we on the browser implementation? Yeah, I know, I´ll probably get "WIP", but hey, I gotta ask.

    We just reached our 10th birthday. We've offered a browser app for less than a year. You'll have to give it a little more time before a completely new app (even one that lives in the browser) becomes as well established as software we've worked on for a decade ;)

    ref: OPW-40

  • edited June 2016

    Whew! This is a big post. Let me take things one at a time.

    I don´t do short. :p

    You can move items between vaults on 1Password.com by using the share icon (right next to the favorites star) and selecting move/copy.

    Jeez. How did I miss that? Thanks. :)
    Erm, how do I select multiple items?

    I can see how that would be frustrating. I wasn't able to recreate this on my end, though. Do you mind testing to see if this is the case with all tags? And does it affect tags added in the browser or in the app? Let's figure out what's going on here :)

    I´ll have to expand a bit on this. Originally, there were actually seven vaults (V1-7). The tags are named after them.

    • Not all tags. The tags / items from V3 & 7 were affected. V1, 2, 4, 5, 6, were not concerned. These function properly. I would have thought that it might have had something to do with the amount of items, but V3 has 5, and V7 has 15 items (+/-3). And some of the other vaults that I moved had more.
    • V1-5 were moved into V6, and then V6 into V7.
    • The tags in V3 and V7 were created in both the browser and in the app. I can´t recall where exactly for each one.
    • It only affects the tags in the browser. I can view everything in the app.
    • Incidentally, I created a V7 tag on another item from V2, but this wasn´t accepted either. It shows up in V2, but not V7.

    I hope I didn´t lose you. ;)

    I don't know if this is planned for the Windows Store version of 1Password. But you might be interested in the version of 1Password 6 that we distribute ourselves. It's still in beta, but it might be worth checking out if you want to have easier updates.

    I do hope so. I´ll check out the beta, but I really don´t want to be using another beta. I´ve got enough as is on my system. :p:

    We just reached our 10th birthday. We've offered a browser app for less than a year. You'll have to give it a little more time before a completely new app (even one that lives in the browser) becomes as well established as software we've worked on for a decade ;)

    Haha, true. I just thought I´d ask. Happy birthday, btw. :)

  • nmottnmott 1Password Alumni

    Erm, how do I select multiple items?

    That's one of those pesky things that we're working on :)

    I hope I didn´t lose you.

    Hmm, I'm not sure I follow. But if I'm interpreting this correctly, you're saying this even affects new tags created in the browser?

    I do hope so. I´ll check out the beta, but I really don´t want to be using another beta. I´ve got enough as is on my system.

    I gotcha. Like I said, I don't know how much we can control the update process for the Windows Store app, but the version we distribute remains an option!

    Haha, true. I just thought I´d ask. Happy birthday, btw

    No harm in asking. I just wanted to let you know where we're at right now. (Thanks!) :)

  • edited June 2016

    Hmm, I'm not sure I follow. But if I'm interpreting this correctly, you're saying this even affects new tags created in the browser?

    Reading through that again ... I lost myself. :p

    Yes, it affects new tags in the browser. And two vaults I had copied into another.
    The tags were added before I moved the items. However, four other vaults
    moved fine.

    I gotcha. Like I said, I don't know how much we can control the update process for the Windows Store app, but the version we distribute remains an option!

    Will we get a mail or something, once that version is out of beta? I´ll definitely be using the non-W Store program, if that allows updates.

    No harm in asking. I just wanted to let you know where we're at right now. (Thanks!) :)

    Wuhu. :)

  • JasperJasper

    Team Member
    edited June 2016

    Hi @Unicade_Music,

    I'm pretty sure I know what the problem with those tags is, and I think I was able to get it fixed. This fix should make it into our next release, so please try again after few days. Thanks for reporting the issue!

  • Will do.

  • nmottnmott 1Password Alumni

    :+1: :)

  • edited July 2016

    Thanks, @nmott and @JasperP . :)
    The problem has been fixed.

  • brentybrenty

    Team Member

    Awesome! Thanks for the update. We're here if you need anything else! :chuffed: :+1:

This discussion has been closed.