Spotlight search not working on iPad or iPhone

As the title says, really. I am using 1P for Families on an iPad Air 2 and also an iPhone 6. Everything is at the latest version (iOS and 1P).

I have enabled spotlight search in 1P settings, and also checked in the iOS settings app that 1P is enabled for spotlight search.

Any thoughts?

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • Drew_AGDrew_AG 1Password Alumni

    Hi @MortalWombatUK,

    I'm sorry you're having some trouble using Spotlight to find 1Password items on your iPad and iPhone!

    It sounds like you've correctly enabled Spotlight Search for 1Password, but it might help to take a quick look at this knowledgebase article: Use Spotlight to search 1Password on your iPhone, iPad, or iPod touch

    In particular, please check out the 'Get help' section of that article, which mentions that it might take a few minutes before Spotlight is able to find items in 1Password. Have you tried using it again since posting your message here? And if so, is there any difference? If it still doesn't work, can you please confirm that you're searching for the names of your items?

    Thanks! :)

  • Hi there,

    Thanks for the response. Having read the article, I have tried restarting my iOS devices, but still no joy. Spotlight search has been enabled for quite a while (many weeks) but has never worked!
    I am indeed searching for item names, but still none are found...

  • khadkhad Social Choreographer

    Team Member


    I'm guessing you already tried turning off Spotlight Search in 1Password > Settings > General and turning it back on again. I actually had that work for me with a similar Spotlight problem.

    If that's not working, I am hoping a Diagnostics Report may shed some a spotlight on this Spotlight conundrum.

    Sending Diagnostics Reports (iOS)

    Attach the Diagnostics Report(s) to an email message addressed to [email protected].

    Please do not post your Diagnostics Report(s) in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report(s) in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can track down the report(s) and ensure that this issue is dealt with quickly. :)

    Once we see the report we should be able to better assist you. Thanks very much!

  • Hi Khad,

    OK... now here is an odd thing. I just disabled spotlight from within 1P, went to my homescreen, swiped down and typed in a search term for which I knew I had an associated item in 1P. It didn't find it of course, but it DID find other items (emails and an app) which contain the same term. Previously (with spotlight enabled in 1P), it would not find any of these other items at all. So it seems as though disabling spotlight in 1P, somehow made the system wide spotlight start working properly!

    I have now re-enabled spotlight search within 1P and it is now finding ALL items containing the search term. Hopefully this situation will last! This odd behaviour was seen on both iPad and iPhone.

    Thanks for the pointer, all seems to be working as expected now, although it does seem as though there is some odd bug in the way the spotlight preferences interact between the 1P app and the operating system.

    Thanks again!


  • khadkhad Social Choreographer

    Team Member

    Phew! I'm glad that did the trick. Please do let me know if you run into any further trouble.

    Have a great weekend!

This discussion has been closed.