Plesk Login

Bump. I'm having the same problem in Safari.

Running:
1Password Version 3.5.9 (build 30884)
Safari Version 5.0.5 (6533.21.1)
Plesk 8.4.0

Thank you.

Comments

  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, Wolfgeek!

    I split your post from the thread in the Chrome forum. I hope you don't mind, but the Chrome extension is a different beast, so the tips and/or troubleshooting procedures are a bit different at the moment.

    That said, I would love to get your Plesk login working for you in Safari. Please try saving the login manually like this:

    1. Enter your username and password, but DO NOT submit the form.
    2. Click the 1Password button in your browser's toolbar, and choose Save Login.
    3. Set the Action field to Create New Login (or to Replace <login-name>, to update an existing Login item).
    4. Click the Save button.

    Using the above technique I was able to save and fill a sample Plesk login in Safari.

    Manually saving a login can be useful for logins that are either problematic to begin with or were once working but have since stopped. Doing this allows 1Password to refresh everything it "knows" about the page. Login pages often change as websites are updated and this can be a necessary but very useful tip. :-)

    If you are still having trouble, please take a look at our "Website Login Issues" guide:

    http://help.agile.ws/1Password3/login_issues.html

    Note especially that editing the login to change the Submit value from "If Autosubmit is ON" to "Never" works on a lot of sites which modify the form before submitting it or are looking for a literal key press or mouse click. This will give you the chance to actually give them what they are looking for by submitting the form yourself rather than allowing 1Password to do it on your behalf.

    I hope that helps. Please let me know. If you are still having trouble could you please provide the URL?

    Thanks!
  • I followed your instructions and it still doesn't work. It doesn't automatically submit the login info. If I click on the 1P button and search for the login and click it, it submits the login info, but returns to the login page again. Logging in manually works fine.

    Here is a video of me following your directions and showing the behavior of 1Password / Plesk / Safari once the login has been saved.



    Thank you,
    Zak Wolfinger
    IT Director - ISP Operations
    KC Online
    [email protected]


    khad wrote:

    Welcome to the forums, Wolfgeek!

    I split your post from the thread in the Chrome forum. I hope you don't mind, but the Chrome extension is a different beast, so the tips and/or troubleshooting procedures are a bit different at the moment.

    That said, I would love to get your Plesk login working for you in Safari. Please try saving the login manually like this:

    1. Enter your username and password, but DO NOT submit the form.
    2. Click the 1Password button in your browser's toolbar, and choose Save Login.
    3. Set the Action field to Create New Login (or to Replace <login-name>, to update an existing Login item).
    4. Click the Save button.

    Using the above technique I was able to save and fill a sample Plesk login in Safari.

    Manually saving a login can be useful for logins that are either problematic to begin with or were once working but have since stopped. Doing this allows 1Password to refresh everything it "knows" about the page. Login pages often change as websites are updated and this can be a necessary but very useful tip. :-)

    If you are still having trouble, please take a look at our "Website Login Issues" guide:

    http://help.agile.ws/1Password3/login_issues.html

    Note especially that editing the login to change the Submit value from "If Autosubmit is ON" to "Never" works on a lot of sites which modify the form before submitting it or are looking for a literal key press or mouse click. This will give you the chance to actually give them what they are looking for by submitting the form yourself rather than allowing 1Password to do it on your behalf.

    I hope that helps. Please let me know. If you are still having trouble could you please provide the URL?

    Thanks!
  • Of course reading your complete instructions would have been a good idea. I turned off Autosubmit and it works now.

    Thank you.

    Wolfgeek wrote:

    I followed your instructions and it still doesn't work. It doesn't automatically submit the login info. If I click on the 1P button and search for the login and click it, it submits the login info, but returns to the login page again. Logging in manually works fine.

    Here is a video of me following your directions and showing the behavior of 1Password / Plesk / Safari once the login has been saved.

    Thank you,
    Zak Wolfinger
    IT Director - ISP Operations
    KC Online
    [email protected]
  • jpgoldbergjpgoldberg Agile Customer Care

    Team Member
    Wolfgeek wrote:

    I turned off Autosubmit and it works now.

    Thanks for the update, Zak! I'm glad everything is working now.

    Please continue to participate in our forums and let us know if there is anything else we can help with.

    Cheers,

    -j
  • Gotta love this forum. I have having the same problem with 3.6.1 and Firefox 5, manually saving a new logon and turning off auto submit seems to have worked a charm :)

    Loving 1Password more and more every day :)
  • khadkhad Social Choreographer

    Team Member
    Thanks for the update (and the kind words), The_Hawk! :-)

    We'll try to get autosubmit working properly on these logins, but in the mean time, disabling autosubmit sounds like it does the trick.

    Cheers,
  • Hello Khad,

    I have the same problem with Plesk 10.1.1 on a dedicated server by MediaTemple.

    1. The auto save doesn't come up.
    2. Of course I can manually save the login.
    3. When I fire the 1Password panel, it does't show the login details.
    4. I browser the saved passwords, I find the good one, click on it and the page is only reloaded. Never connected.

    Safari 5.1 / 1Password version 3.6.1 (build 31057)

    Thanks!
  • khadkhad Social Choreographer

    Team Member
    The Safari 5.1 extension has different form filling code, so it may not work the same as it does for the folks above. However, please disable autosubmit for the Plesk Login as mentioned above.

    Edit the Login in 1Password and change the "Submit" value from "If Autosubmit is ON" to "Never:.

    20110715-d23w1c1hbp1dmn196nyd4qbskd.png

    I hope that helps. Please let me know. If you could provide a URL for testing, that would be perfect.

    Thanks!
  • I already disabled the auto-submit but it doesn't work.

    Edit : it seems it does work with the url but not with the ip...
  • khadkhad Social Choreographer

    Team Member
    edited July 2011
    Thanks for the update!

    1Password does not do any DNS resolution, so only what is actually in the address bar will be compared to the URL saved in the Login item. For now you will need to create two different Login items if for some reason you need to connect to the same site by both IP address and fully qualified domain name.

    We are looking at the possibility of "equivalent domains" in the future, so you can make both the IP address and URL to the save Login item in 1Password. :-)

    Cheers,
This discussion has been closed.