Context menu and external Go & Fill not yet supported in Safari 5.1

I am, according to 1Password, running the latest beta.

I am running the most up to date Lion.

I can install the extension and the 1P button shows up.

I can click the button, and some unfamiliar "unlock" window comes up.

When I right-click on a form entry, I do not see the 1Password additions to the menu.

Alternately, if I open/unlock the 1Password app, and go to a password entry, and click on the item which usually takes me to that page and fills in the fields, it goes there, but does not fill in.

Comments

  • khadkhad Social Choreographer

    Team Member
    edited July 2011
    Hello amgems!

    Sorry for the confusion here. If 1Password is filling your login credentials in Safari 5.1 it is not broken. If it is not, then we would love to help you get it installed and working properly. :-)

    The Safari 5.1 (Lion) extension is a complete rewrite and is using the native Safari extension APIs. There are some differences between the stable version of the extension running in Snow Leopard and the beta version running on a the developer preview of Lion. It is not feature complete yet.

    At the moment Go & Fill is not supported from outside the browser. Please use the "All Logins" tab from within the 1Password popup. Additionally, 1Password does not currently integrate provide a context menu (ctrl- or right-click menu) in Safari 5.1.

    The developers are hard at work on the Safari 5.1 beta extension to make it even better. Thanks for testing this prerelease software for us and providing your feedback!

    If you need any further assistance, please let us know.

    We are always here to help!
  • I'm running the GM release of Lion. The Safari/toolbar extension works but I can't get the context menu. I've removed and installed extensions several times and also reinstalled 1Password. Still no 1Password in the context menu!
  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, darwinosx!

    I merged your post with the appropriate thread. Please see above and let me know if you have any additional questions or concerns. Thanks!
  • MidSummer2010MidSummer2010 Junior Member
    edited July 2011
    Edit: Ok, it seems I can click the task bar 1P and then hit enter, much better.

    Still, context menu would be nice too!
  • I upgraded to Lion, then 1PW stopped working nicely with Safari. What happend < Lion: Launch a 1PW login, 1PW autofills username and password. What happens > Lion: Launch a 1PW login, 1PW does NOT autofill so I use 1P extension to complete login. But, then, 1PW shows me a popup to enter my 1PW password; however, 1PW is already up and running !!

    Config: 1PW 3.6.5.BETA-23 + Lion + Safari 5.1 + 1PW Extension
  • terryzxterryzx Senior Member
    I have to say that I really DISLIKE this new interface action also
  • I have exactly the same issue. Selecting "Go and Fill" from the 1Password app brings me to the web page but does not fill in the username and password.

    My configuration: Lion, Safari 5.1, Extension 3.6.5.BETA-23, 1Password 3.6.1 (build 31057).
  • I'm having the same issue. Can't get sites to accept login with 1password now with new version of Mac OS X version 10.7 or Lion. Need help.
  • brentybrenty

    Team Member

    Edit: Ok, it seems I can click the task bar 1P and then hit enter, much better.

    Still, context menu would be nice too!


    We're on the case. Frankly, I can't wait until this is added myself! :)
  • diittodiitto Junior Member
    Hi... Yesterday 1Password worked fine, including how for most of the websites I visit that have secure logins (username/password), when I would double click my 1Password Login for a specific site, it would take me to the page (in Safari) and put in the username/password information for me... That's why I use 1Password...

    Then earlier this morning I downloaded and installed the new OS X Lion NOT on my main drive but instead only on an external USB drive that was (prior to loading Lion) a Clone of my main drive (the main drive is running OS X 10.6.8 Snow Leopard. I've then booted into Lion a number of times... What I discovered is that 1Password opens ok but when it first opens it puts up a message (see attached jpg) that asks me if I want to "Enable Automatic Extension Updates"... First, where did that come from??? I haven't updated 1Password in a few days and prior to loading Lion on this cloned external drive, I had never seen that message before... And now, after loading Lion, I DO see it... I don't know what it means so I just keep hitting cancel anytime I launch 1Password and that message comes up...

    So that's question 1... What does that message mean and why did it show up now??? Then it gets worse because now I notice that ALL of my Logins which used to autocomplete usernames and passwords for me now do not... Not a single one of them gets beyond loading the login page for a given website and then it stops... What happened???

    And then for the worst news of all... I now switch back from running on the external hard drive running Lion... I shut down and completely disconnect that drive... I then reboot onto the main hard drive that is still running 10.6.8... When I open 1Password I get exactly this same "Enable Automatic Extension Updates" question to which I still just say "cancel" and just as in Lion, not a single one of my 1Password Logins will autocomplete anymore on that main drive setup either?????

    What happened??? How do I get autocomplete to work again??? Was it just coincidence that the "Enable Automatic Extension Updates" happened at the same time that I installed Lion on another drive??? What does that message even mean????

    Any help would be much appreciated... thanks... bob...[attachment=865:1password message.tiff]
  • edited July 2011
    I have experienced exactly the same problems! — Michael
  • khadkhad Social Choreographer

    Team Member
    edited August 2011
    From the Safari 5.1 troubleshooting section in the 1Password User Guide:

    At this time, the Safari 5.1 extension does not support Go & Fill from outside the browser extension. If Safari 5.1 is set as your default browser, the following actions will open the correct page in Safari 5.1, but will not automatically fill the login information:

    1. Double-clicking an item in 1Password
    2. Using 1Password’s dock icon to select a login
    3. Clicking a 1Click bookmark (even from within Safari 5.1)
    4. Selecting a 1Password item from AllBookmarks

    We are looking into this issue. In the meantime, please consider using the ⌥⌘\ (Option-Command-\) keyboard shortcut from within Safari 5.1 or clicking the “All Logins” tab in the 1Password extension.
  • khadkhad Social Choreographer

    Team Member
    And now, after loading Lion, I DO see it... I don't know what it means so I just keep hitting cancel anytime I launch 1Password and that message comes up...

    We recommend enabling automatic updates for Safari extensions. 1Password is one, and if you download any others from Apple's Safari Extensions Gallery they can all be automatically updated to get the latest fixes and features as they are released. If you prefer to leave this disabled for some reason and do not wish to keep clicking Cancel, simply check the box that says "Do not show this message again".

    This change occurred in the latest version of the 1Password extension since it now uses the native Safari extension APIs (along with the awesome autoupdate that is provided by Apple there). I presume you updated to Safari 5.1 in Snow Leopard which explains why you are seeing the prompt there as well. Safari 5.1 requires the new extension.

    Simply press ⌘\ on your keyboard to fill a Login as always or use ⌥⌘\ to bring up the "All Logins" section in Safari. :-)

    Please let me know how it turns out.

    Cheers,
This discussion has been closed.