Why can't I use my PIN to unlock when using the 1Password keyboard

I'm using 1Password individual account. On my Nexus 5x, I don't mind so much, since I have a fingerprint reader, but on my Nexus 5 it's unbearable to have to type my Master Password every time I want to fill in a password form. I can't even change my Master Password to something simpler on this device (I think because it's not a local vault). So, I thought a PIN would do the trick. No go. I have the PIN set up, but every time I use the 1Password keyboard and hit the 1Password icon to do password filling, I get the Master Password prompt.

My settings (in Security):

PIN Code: On
Lock on exit: Off
Automatically Lock: Never
Automatically clear clipboard: Never

OS: Android 7.0 (though I saw this in 6 as well)
Android app version: 1Password 6.4b6

Thanks.


1Password Version: 6.4b6
Extension Version: Not Provided
OS Version: Android 7.0
Sync Type: 1Password account
Referrer: forum-search:PIN

Comments

  • periperi

    Team Member

    Hey @stacecom. Thanks for getting in touch with us and for reporting this bug! I can indeed reproduce this on my end. I've opened up an issue internally for our developers to review, and hopefully we'll be able to get it resolved soon.
    ref: OPA-1003

    In the meantime, you could disable Lock on exit and set an auto-lock timer if you like. :)

    Let us know if you need anything else!

  • Thanks. As noted above, I have disabled auto-lock on exit and timer, but it has no affect on this behavior.

  • periperi

    Team Member

    Sorry! Thanks for pointing out that info, which I somehow missed. I'll let the team know. :)

This discussion has been closed.