Frequent Prompts for Master Password [Improved in 245d update]

hydrophishhydrophish
edited September 2016 in Windows Beta

I'm having a problem where the application prompts for my master password every ten minutes, even when I'm actively working in a browser. I've got it set to minimize to the notification area. How can I set it so I don't have to enter my password every ten minutes, which is extremely annoying.


1Password Version: 6.0.239d
Extension Version: 4.6.0.90
OS Version: Windows 10
Sync Type: Subscription

Comments

  • I'm having the same problem, which IS extremely annoying

  • I am also having the same problem. I'm using Windows 8.1 Pro; Firefox 49. It seems to get triggered by the browser actions although I haven't figured out which action. I thought it happened when 1P detected a page with login fields but it has also popped up on pages that don't have any fill-in fields.

  • Hi everybody,

    What is the time out setting for 1Password 6 on your systems?

    You can set this individually in Settings > Options > Security > Auto-Lock.

    I hope this helps! Let us know if you have any other questions.

    Cheers,

    Alex

  • MikeTMikeT Agile Samurai

    Team Member
    edited September 2016

    Hi guys,

    There's a bug related to how the timer works, it is not listening to your activity in the main 1Password window. In addition, it does not reset when you use 1Password mini instead of the main app, so it will always lock in 10 minutes by default.

    The good news is that the upcoming update will have an overhauled locking system that will track your idle activity on the computer, rather than what you're doing in 1Password. This means the timer only kicks in once you stop using your keyboard/mouse for 10 minutes or whichever time you set in 1Password's setting.

  • I have the same problem.
    Can we please have an option to never ask for master password again after unlocking? I think there was a similar option in 1P4.
    I hate entering my master password over and over, I want to enter it when my computer is up and running and never again until I reboot my computer.

  • @MikeT Can't wait for this! Any idea when this is due to drop?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    @tigole,

    Can we please have an option to never ask for master password again after unlocking? I think there was a similar option in 1P4.

    You can, change the auto-lock timer to "never" via the Settings > Security, as shown in this screenshot:

    We will simplify this UI a bit in a future update.

    @brandscill,

    Can't wait for this! Any idea when this is due to drop?

    No ETA yet, there are a lot of internal changes we're doing and it needs to be tested heavily before we can ship it. It shouldn't be long.

  • Hi MikeT,

    Actually mine is already set to "Never" but maybe it's getting locked because of the idle timer bug you mentioned earlier in this thread.

  • brentybrenty

    Team Member

    @tigole: Indeed. I'm sorry for the inconvenience there. We're working hard on the next update. Thanks for your patience!

    P.S: Tell Furor I said hi! :pirate:

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    We've just shipped the 1Password 6.0.245d update that includes an overhauled auto-locking system, it now tracks your idle activity before it locks instead of monitoring the last interaction in the main 1Password window.

    It also added more time settings, going up to 12 hours.

    Please let us know how it is working out for you guys.

  • According to my 1Password version I am still running 6.0.252. Tried to reinstall it but it won't update to the version you mention @MikeT.
    Is the versions different between Windows 8.1 and Windows 10?
    I am running 1P in Windows 8.1.

  • @tigole

    Can you please check again? It should be available. If you can't find it, download it from our Release Notes site manually and install it.

  • @AlexHoffmann latest build on the release notes page is 6.0.252 (build #252) – released 2016-09-30.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @tigole,

    That's fine, version 252d is newer than 245d, we've already shipped a few newer builds after my last post. In other words, you're up to date now.

    Are you still having issues with the auto-lock?

  • Hi @MIkeT, I had the issue earlier today when it was set to "Never". I changed it to "8 hours" now and so far it seems ok.
    I will switch back to "Never" again to see if it fails or not.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @tigole,

    Just to be clear, in the latest update, we now track your idling activity, which means it only starts after 8 hours of no computer activity with your mouse/keyboard, not 8 hours from the last interaction you did within the main 1Password window.

    Never only works for the running instance of 1Password, you will have to unlock if you terminate 1Password once.

  • Seems to be improved but it still seems to time out fairly frequently. I use laptop all day and it's locked before 30 minutes several times.

  • @MikeT, @AlexHoffmann: I noticed that the version number is different depending on where you look.
    If I open the "cogwheel" at the top right corner it says "1Password 6.0.252d" as version number.
    If I go to "cogwheel" -> "options" -> "update" it says: Current version: 6.0.252.

    So I seem to have the latest version already.

  • brentybrenty

    Team Member

    @tigole: Ah, sorry for the confusion there! The "d" just indicates that it's the "desktop" version. Only the number will increment when you update. :)

    @brandscill: If you're still encountering this issue, be sure to generate diagnostic information so we can look at the logs to determine exactly what is happening:

    1. Open the main 1Password app
    2. In the Search box, type /log and press Enter
    3. Save the log and attach it to a new email to [email protected]

    Just be sure to include a link to this forum thread and your username in the email so we can 'connect the dots'. You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here so we can quickly track it down. Once we see it we should be able to better assist you. Thanks in advance!

  • @brenty #PYB-89291-527

  • brentybrenty

    Team Member

    @brandscill: Thanks! I see that we've received your email, so we can continue the conversation there. We'll take a look at the diagnostics and get back to you shortly! :)

    ref: PYB-89291-527

This discussion has been closed.