Chrome extension not functioning

Hi,
I have been running the Chrome extension successfully for months with no problem. Last week it stopped working. The extension icon appears, and if I click on it, the icon is animated. However the 1Password context menu does not appear. I have added the lookback ip address as an exception in Sophos. I have also uninstalled and reinstalled the Chrome extension. I have restarted the 1password helper agent. All with no success. I know the helper is running because the extension for Internet Explorer works fine. And here's the weird bit: if I use the shortcut key Ctrl+\, then the 1password context menu shows up in Chrome. It just doesn't work if I click the icon. Also, I can't right-click within a username / password textbox to bring up the 1password login details. Any help gratefully received.

Chrome version: 53.0.2785.116 m
1Password version: 4.6.0.604
Chrome extension version: 4.5.9.90


1Password Version: 4.6.0.604
Extension Version: Chrome 4.5.9.90
OS Version: Windows 10 Pro
Sync Type: Not Provided
Referrer: forum-search:chrome extension not working

Comments

  • Hello @davedrat,

    Thanks for reaching out to us!

    While the fact that you can use the keyboard shortcut in Chrome is a bit strange, it's likely that some piece of software on your PC is interfering with the communication between 1Password, the 1Password Helper (a necessary background application) and the browser extensions. The most common culprits are antivirus and firewall applications or the use of a proxy server.

    Can you please tell us which security software you're using and whether you're using a proxy server?

    Cheers,

    Alex

  • Hi Alex,
    The antivirus is Sophos. It is maintained by a network administrator and I don't have rights to edit the settings. However, I have already requested that they add the loopback address to the list of the exceptions. They assure me this has been done, but it hasn't made a difference to the issue.

    Windows firewall is installed and enabled on the local machine. The browsers are configured to use a proxy server - automatic configuration used via DHCP.

    Thanks

  • brentybrenty

    Team Member

    @davedrat: Ah, I see. Thanks for clarifying! You'll also need to make sure that the firewall and proxy are setup to allow 1Password, as these will redirect (or block) the connection. Please let me know what you find!

  • Hello again,
    This morning I downloaded the latest version of the 1Password app. And I updated my extensions for IE, Chrome & Firefox.
    I was hoping this might fix my issues, but if anything I've taken a slightly backward step.

    The situation is this:

    1. In IE, the extension works fine.

    2. In Chrome, clicking on the extension takes you to a page saying the helper agent can't be found. It is definitely running, as IE works fine. Before the latest 1password update, I was able to use CTRL + \ to bring up the context menu. This no longer works. If I use Ctrl + Alt+ \, then I do get a context menu, from which I can launch the app etc.

    3. Firefox - identical behaviour to Chrome

    I have tested this with Windows Firewall temporarily disabled, and the behaviour of all three browsers is exactly the same, so I don't think Windows Firewall is the culprit.

    I have had the loopback address added to the exceptions list in Sophos.

    Basically, it seems that Internet Explorer is trusted to connect to the helper agent in a way that Chrome and Firefox are not. I've thoroughly searched the 1Password forum for an answer with no luck. I really could use some help with this.

    Thanks

  • brentybrenty

    Team Member
    edited October 2016

    @davedrat: I'm sorry for the confusion! Internet Explorer uses very old add-on technology, so it cannot connect to 1Password Helper. And similarly, since 1Password itself installs the IE add-on, there is no reason to authenticate. Chrome and Firefox handle extensions themselves though, and while they will update them automatically, how and when this is done is unpredictable, so the only way to ensure you get the latest version is to uninstall the old one and download the latest from the AgileBits website. Just follow these steps:

    1. Remove the 1Password extension from Firefox and Chrome
    2. Complete any browser updates
    3. Restart Windows
    4. Install the 1Password browser extensions

    At this point, when you use the extension, you should be presented with a webpage and also a prompt from 1Password. Just verify that the codes match, authorize the connection, and you should be all set. Let me know how it turns out! :)

This discussion has been closed.