Mac menubar spinning gear: ""1Password_autosubm" running". How turn off?

An icon in the menubar on my Macbook pro has a spinning gear icon. A dropdown menu reads: ""1Password_submis" running". Since I have a data cap on my internet account, I don't want 1Password continually querying the cloud. How do I turn it off, or doesn't it matter to data?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:Mac menubar spinning gear: ""1Password_autosubm" running". How turn off?

Comments

  • Drew_AGDrew_AG 1Password Alumni

    Hi @weaverm,

    Thanks for reaching out to us for help with this! Don't worry about your data - that icon in the menubar is for the 1Password auto-submit script, which simply simulates pressing the return/enter key after 1Password fills a sign-in form on a website. (That script is used in the Mac App Store version of 1Password.)

    I don't know why it's getting stuck, but you can solve that by deleting the auto-submit script:

    1. Close all browsers and 1Password.
    2. In the Finder, go to the following folder: ~/Library/Application Scripts/2BUA8C4S2C.com.agilebits.onepassword-osx-helper
    3. Delete the 1Password_Autosubmit.scpt file.
    4. Reboot your Mac.

    1Password should still be able to automatically submit login forms on many (if not all) of the sites where you have logins. But if not, you can easily reinstall the script: Just open the main 1Password app and go to 1Password > Preferences > Browsers. Disable & re-enable the option for "Automatically sign in after filling usernames and passwords" and you'll be prompted to reinstall the script (just choose the suggested folder).

    Hopefully this helps, but please let us know if you have any trouble with that, or if you have more questions. Cheers! :)

  • Drew_AGDrew_AG 1Password Alumni

    Hi @weaverm,

    Thanks for reaching out to us for help with this! Don't worry about your data - that icon in the menubar is for the 1Password auto-submit script, which simply simulates pressing the return/enter key after 1Password fills a sign-in form on a website. (That script is used in the Mac App Store version of 1Password.)

    I don't know why it's getting stuck, but you can solve that by deleting the auto-submit script:

    1. Close all browsers and 1Password.
    2. In the Finder, go to the following folder: ~/Library/Application Scripts/2BUA8C4S2C.com.agilebits.onepassword-osx-helper
    3. Delete the 1Password_Autosubmit.scpt file.
    4. Reboot your Mac.

    1Password should still be able to automatically submit login forms on many (if not all) of the sites where you have logins. But if not, you can easily reinstall the script: Just open the main 1Password app and go to 1Password > Preferences > Browsers. Disable & re-enable the option for "Automatically sign in after filling usernames and passwords" and you'll be prompted to reinstall the script (just choose the suggested folder).

    Hopefully this helps, but please let us know if you have any trouble with that, or if you have more questions. Cheers! :)

  • Thank you, Drew_AG. Did the trick:)

  • brentybrenty

    Team Member

    Excellent! Thanks for the update. On behalf of Drew, you are most welcome! I'm glad to hear that all is well. It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance. We're always here to help! :)

This discussion has been closed.