Login requires two user IDs, 1Password doesn't understand

I have a new login that requires two user IDs (plus a password). One is an overall company ID, and one is a user ID. I can't persuade 1Password to autofill both IDs. I thought perhaps I could edit the form details in 1Password to mark both fields as User IDs, but 1Password only allows one.


1Password Version: 6.5.1
Extension Version: 4.6.1
OS Version: 10.11.6
Sync Type: Dropbox
Referrer: forum-search:usernames

Comments

  • Hi @davidrdana,

    Is this from a Login item saved inside the browser or one you created from inside the main 1Password window? Unless the site is a bit quirky a Login item saved from inside the browser should work but only if saved from in the browser. For any site that goes beyond a simple text field for a username and password field for the password we need to know details about the page to understand what to fill where. If you did save from inside the browser and find it isn't filling could you let us know the URL for the site please as we'll happily look and see if we need to tweak 1Password to better work there.

  • Hi, please tell me how I can send you the URL without posting it in the public forum. I did save the login inside the browser, and 1Password doesn't recognize either of the user IDs as information that needs to be saved. I was able to edit the web form details to create one of them as an auto-filled user ID, but not both.

  • brentybrenty

    Team Member

    @davidrdana: Definitely try to manually save a new login first, but if you're still having trouble you can send us the details at [email protected] and we'll take a closer look. :)

  • Hi @davidrdana,

    Brenty has supplied the email address but just to confirm, are you saying that after saving a new Login item that before altering it in any way it wouldn't fill or when you looked at it you didn't think it would fill? Login items have a few default fields, one of which is the username field and another being the password field. It will never show two visible username fields at the top but that doesn't mean it won't fill correctly. Now if a newly saved, unmodified Login item saved from inside the browser isn't working then please do email us.

  • Hi, manually saving the login was the key. I still had to edit the form details a bit to handle the password on the second page, but now all is well. Thanks for the help.

  • Wait, never mind...it didn't work after I tried the login again. I'll email details...

  • brentybrenty

    Team Member

    @davidrdana: Thanks! I see that we've received your email, so we can continue the conversation there. We'll take a look at it and get back to you shortly! :)

    ref: JWT-62591-749

This discussion has been closed.