Opera plugin is suddenly doing nothing (Windows)

I've been using Opera and 1Password4 for a year without a hitch. Now suddenly just two days ago I got this problem too. The 1Password plugin does (close to) nothing. I cannot make it open the "Unlock 1Password Vault" window, or anything else.
I have reinstalled the plugin and even the software.

One thing I've noted is this: If I select "Restert 1Password Helper" from the client, and then click on the Plugin, it will open a new tab and do its "Looking for the 1Password helper" for a while, before telling me "Couldn’t connect to 1Password "Either the helper is not running, or something is preventing it from communicating with the 1Password browser extension".

I can do this all day. If I relaunch the browser it again will seemingly do nothing until I restart the helper, in which case I'm back to the error above.

Also pingback to this this

On the same system everything is working fine for Chrome.

Opera 42.0.2393.85 Stable
1Password 4.6.1.616
Plugin 4.6.2.90
Windows 64bit 10.0.14393

Works fine on my Win7 machine, all same other versions (same vault).


1Password Version: 4.6.1.616
Extension Version: 4.6.2.90
OS Version: Windows 10 x64
Sync Type: none/local

Comments

  • Hi

    Waking up this thread.
    I've been using Opera and 1Password4 for a year without a hitch. Now suddenly just two days ago I got this problem too. The 1Password plugin does (close to) nothing. I cannot make it open the "Unlock 1Password Vault" window, or anything else.
    I have reinstalled the plugin and even the software.

    One thing I've noted is this: If I select "Restert 1Password Helper" from the client, and then click on the Plugin, it will open a new tab and do its "Looking for the 1Password helper" for a while, before telling me "Couldn’t connect to 1Password "Either the helper is not running, or something is preventing it from communicating with the 1Password browser extension".

    I can do this all day. If I relaunch the browser it again will seemingly do nothing until I restart the helper, in which case I'm back to the error above.

    On the same system everything is working fine for Chrome.

    Opera 42.0.2393.85 Stable
    1Password 4.6.1.616
    Plugin 4.6.2.90
    Windows 64bit 10.0.14393

  • Oh I just realised the original querry was OSX, and I'm having the problem on Windows. Please let me know if you wish for me to repost in the correct thread!

  • Hi @neurocis,

    I'm surprised, it shouldn't work on your Windows 7 machine. Opera have transitioned to a different certificate it seems for signing the application. 1Password is looking for the previous certificate and so as of Opera 42 it can't validate the browser code signature. An update to 1Password for Windows will be required as knowledge of the certificates is built into the application itself. Unfortunately it means that for now we won't fill in Opera. I apologise for this but hopefully normal service will resume shortly.

    ref: OPW-599

  • Thats the nugget I needed to know .... Go to Help >>> Advanced >>> uncheck "Verify web browser code signature" ... Close Opera ...Help >>> Restart 1Password Helper ... Restart Opera. All seems to be well as a workaround until the plugin is updated.

    Cheers!

  • @qip See here
    Cheers!

  • brentybrenty

    Team Member

    On behalf of lil bobby, you are most welcome! I'm glad to hear that helped. We're hoping to have an update available to everyone which knows Opera's new signature shortly. It sounds like you should be all set, but don't hesitate to reach out if we can be of further assistance. We're always here to help! :)

  • Drew_AGDrew_AG 1Password Alumni

    Hi @Sqip,

    I hope you don't mind, but I moved your posts to the thread from the link neurocis gave you. (Thanks, @neurocis! :) )

    It sounds like the problem you described is the same as the one being discussed here. Does the information from littlebobbytables and neurocis help to explain why that's happening and what you can do? Please let us know how it goes and if you have any questions about it. Cheers! :)

This discussion has been closed.