Singapore Airlines login not filling

Hi guys,

I am having some issues with the Singapore Airlines website

When I try to autofill in my account number and password nothing happens if I use the key combo. If I try click on the 1password logo in chrome I get taken to the welcome page at first click then the second it menu opens where I can choose the singapore airlines log to use

I have tried this on multiple pages on this website. Some logins are a pop up some are a flat webpage that allows details to be entered. Either way it does not fill and I have to do the copy/paste method.

I have tried this on two different macos machines with different versions of chrome with the same result.

I tried to report the issue via the chrome plugin and get taken to a website with an error on it

Oops, something went wrong.

Please make sure that you:

attempt to fill an item first and then report the issue second.
use the Report Website Issue option in the 1Password extension or in 1Password mini.
update to the most recent version of 1Password for Mac or 1Password for Windows Beta.

This is the link (23)&url= (Macintosh; Intel Mac OS X 10_12_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.28 Safari/537.36&platform=MacIntel

I have removed and added my account details to 1password for Singapore Airlines multiple times with the same result.

Anything else I can do to help fix this please let me know


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Hi, @MrBr0. Sorry for the trouble you're having. It sounds like 1Password mini is not starting up automatically, but I can't say for certain just yet.

    Does this behavior happen only on the Singapore Air site? For instance, if you restart your computer and then visit another site like Facebook, Twitter, or Amazon (to name just a few that we test pretty often) does it happen the same way?

    Does this behavior happen on Singapore Air's website if you use another browser like Safari or Firefox? There is a known issue with Chrome where some pages with particularly large numbers of fields can cause the connection to 1Password mini to break and need to be reestablished. But, if this is the case, it's usually also the case that subsequent filling attempts do not work for the same page.

    Let us know what you find and we'll see how we need to move forward.

    Jamie Phelps
    Code Wrangler @ AgileBits
    Fort Worth, Texas

  • Hi Jamie,

    Thanks for the prompt reply.

    The issue is only on the Singapore Airlines website, everything else works fantastically well.

    I just tested in Safari and it works perfectly so it's a chrome issue.


  • jxpx777jxpx777 Code Wrangler 1Password Alumni

    Thanks for the quick confirmation. I'm sorry that this is a known issue with Chrome at the moment. We're working toward a more robust connection approach, but I don't have a timeframe to share for when it might be available right now.

This discussion has been closed.