Error on uploading team logo. "Failed to send image to the server. Invalid request parameters."

When I upload my team logo I get this error:
"Failed to send image to the server.
Invalid request parameters."

My logo then appears on the Dashboard and other places for a while, then reverts to the anonymous head.

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:team logo


  • rubyatMRrubyatMR
    edited December 2016
  • roustemroustem AgileBits Founder

    Team Member

    Thank you very much for the screenshot!

    We are trying to figure out what could be causing this problem. Unfortunately, we are not able to recreate it on our side. I do see the error in the server logs but it does not include enough information for us to see where it could be coming from.

    Do you remember if you changed any other account or billing settings before trying to upload the image?

    And do you see this error if you logout, refresh the page, and login again?

    Thank you!

  • I've gotten this error for several days in a row, including today, after having been logged out and then logging in each time.

    I don't access to change many other settings, but the team name and sign-in link. Could the issue be that I am an admin but not owner of the account?

  • roustemroustem AgileBits Founder

    Team Member

    Oh, yes, you are absolutely right about it.

    I checked our code again and found the problem. We will try to get the fix out asap.

  • Great. Thank you!

  • JacobJacob

    Team Member


  • Can you update this thread when it's fixed? Thanks.

  • brentybrenty

    Team Member

    Will do. :)

  • Having the same problem. I'm also getting API errors when I try to make other changes on the Team Settings page as well -- changing the team name, changing the URL, or enabling Beta features. All give the error message "Error. Failed to save settings. Invalid request parameters."

    Same error on both Safari and Chrome:
    macOS 10.12.2
    Safari 10.0.2
    Chrome 55.0.2883.95 (64bit)

    Not sure if that's related to the image upload problem or if I should create a new thread for the other issues.

  • Update -- it appears changing the team URL worked, even though I got the error message. Changing the name fails though.

  • FrankFrank

    Team Member

    Hi @mrburrito -

    Thank you for reaching out to us and I appreciate the additional details you provided. I'm digging the profile picture - fellow drummer myself :-) I'm glad the url change worked. When you try to change the Teams name, are you receiving the same error message "Error. Failed to save settings. Invalid request parameters." Just want to make sure and I look forward to your reply back.

  • @Frank_AG yep. same error message for everything.

  • FrankFrank

    Team Member

    Hi mrburrito - I just sent you over an email so we can continue the conversation in private since we will be discussing your account. I hope that is ok with you. Talk to you soon :-)

    ref: KVW-24665-586

  • Hi, any news about allowing non-owner admins to update the team logo?

  • JasperJasper

    Team Member

    Hi @rubyatMR,

    This issue should hopefully be fixed in our next deployment. It's currently in a test build, which hasn't made it to our production servers yet. Sorry for the delay!

  • Ok, great. Thanks, @JasperP!

  • rickfillionrickfillion Junior Member

    Team Member

    On behalf of Jasper, you're very welcome.

    Let us know if you run into any more issues.


This discussion has been closed.